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PRO-V STUDIO REFERENCE MANUAL

Chapter 1: Welcome to pro-V Studio!
hank you for purchasing pro-V Studio by Curious Labs. pro-V Studio is the 
ultimate tool for 3D interactive Web authoring. Using pro-V Studio, you can 
create Viewpoint presentations in a fully visual environment. No programming 

required! Combine 3D objects, images, Macromedia FlashTM (*.SWF) animations, and 
more for spectacular results that make the Web come alive. Use pro-V Studio to create ad 
campaigns, visualize products, provide online learning, deliver online user 
documentation, setup online games- The possibilities are only limited by your 
imagination. pro-V Studio is the ultimate tool for 3D interactive web authoring

PRO-V STUDIO FEATURES

pro-V Studio has the following key features and benefits:

Visual authoring environment: Until now, Viewpoint scenes had to be hand-created by 
editing XML files, a daunting task for most Web developers. pro-V Studio’s visual 
interface lets any Web designer create 3D interactive Web content quickly and easily- 
no programming required!

Pre-configured drag and drop components: You may edit any interaction component at 
any time. Attach interaction components by dragging and dropping them onto the 
target object. Create powerful state-based behaviors with just a few mouse clicks.

Increased productivity: Standardized content handling assures reproducible quality for 
large projects. Need content? pro-V Studio accesses the Content Paradise Web portal, 
your gateway to a whole world of rich media content that you can add to your pro-V 
Studio Library.

Multiple Undo/Redo: Multiple levels of undo/redo provide the flexible editing 
capabilities you expect from a professional application. Fireplace is fully XML based, 
making round-trip editing possible for project & configuration files, external library 
content descriptions, and export. This offers very tight integration with the Viewpoint 
platform. XML allows easy automated post processing or server-based data handling if 
desired.

T
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INTRODUCTION

Create breathtaking Web interfaces: Build beautiful user interfaces using pro-V 
Studio's action primitives for buttons & checkboxes. Unlike other solutions such as 
Java Script, this method is platform-independent and functions with Internet Explorer 
& Netscape on Windows & Macintoshes, as well as with native Compuserve and AOL 
(non-HTML) pages. HyperView adds a new level of immersion to your scenes, 
allowing you to literally go beyond the traditional window boundary.

Add value to your existing media assets: Import a wide variety of content in diverse 
formats such as SWF, ASE, OBJ, and/or existing Viewpoint scenes. Integrate this 
content into new scenes. Reusing content reduces production time and costs.

Flexible content library: Import media assets using pro-V Studio’s powerful Importer 
module and store them in the flexible Library.

Template-based publishing: Integrate your scene into existing Web pages or use the 
included HTML templates. Select published quality on a per-object basis for easy 
scene optimization.

Easy scene setup: pro-V Studio makes composing scenes easy. Built in tools let you 
quickly position and set up each object in an intuitive visual environment that lets you 
preview your work as you go.

For ease of use, pro-V Studio is divided into seven workspaces called rooms. This feature 
gives you a simple step-by-step workflow that presents the tools you need when you need 
them with no additional clutter. The pro-V Studio rooms are:

SCENE SETUP ROOM

The Scene Setup room is where you build and preview your scenes. Drag and drop assets 
to create instances in your scene, create hierarchies, and add interaction components here. 
See the results in real time. Test your scene as you go.

MATERIALS ROOM

Apply colors, alpha maps, bump, and light to give your objects realism or any effect you 
want using the Materials room.

ANIMATION ROOM

The Animation room lets you bring your scenes to life. Create animators, timelines, and 
keyframes. Edit existing animations. Preview your work.
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INTERACTION ROOM

Build behaviors and other interactions in the Interaction room. Interactivity immerses 
viewers in your scene and gives it impact that no static presentation can ever hope to 
emulate.

WEB INTEGRATION ROOM

The Web Integration room loads HTML (either custom or premade templates), allowing 
you to preview your final output and integrate it into a Web page.

PUBLISH ROOM

Once your scene is built and tested, the Publish room creates and saves the final output 
ready for distribution and presentation to viewers.

CONTENT ROOM

Want to get additional pro-V Studio content? pro-V Studio’s Content room hosts Content 
Paradise, your gateway to leading online marketplaces where you can purchase, 
download, and install new content in your library or project assets. You can search for, 
purchase, and download content from multiple marketplaces using a simple friendly 
interface. Best of all, pro-V Studio can detect and install many types of content 
automatically! Please refer to “Content Room” on page 62 for more information about the 
Content room.

INCLUDED DOCUMENTATION

pro-V Studio includes the following documentation:

pro-V Studio Reference Manual: If you purchased pro-V Studio on CD, this Reference 
Manual is included in both hard copy and in electronic PDF format on your pro-V 
Studio CD. If you obtained pro-V Studio via download, this Reference Manual will 
appear in PDF only. Selecting Help>pro-V Studio Help within pro-V Studio will also 
launch this manual.

NOTE
IF YOU PURCHASED PRO-V STUDIO ON CD, THE ELECTRONIC EDITION OF THIS REFERENCE MANUAL MAY 
CONTAIN UPDATES TOO RECENT FOR THE HARD COPY EDITION. IF YOU PURCHASED PRO-V STUDIO VIA 
DOWNLOAD, THIS ELECTRONIC VERSION IS COMPLETELY UP-TO-DATE. THE ELECTRONIC VERSION 
ACCESSIBLE FROM THE HELP MENU IS OPTIMIZED FOR SCREEN VIEWING. IF YOU WISH TO PRINT IT OUT, YOUR 
PRO-V STUDIO CD CONTAINS A VERSION THAT IS OPTIMIZED FOR PRINT IN THE DOCUMENTATION FOLDER.
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SYSTEM REQUIREMENTS

Windows 2000 or XP

500MHz Pentium class or compatible (1GHz or greater recommended for large 
projects)

256 MB system RAM (512MB or greater recommended)

24-bit color display, 1024x768 resolution (1280 x 1024 or greater recommended)

250 MB free hard disk space

Internet connection required for Content Paradise

OTHER CURIOUS LABS PRODUCTS

Check out these products from Curious Labs:

Poser 5: Poser 5 is the ultimate 3D-character design and animation tool for artists and 
animators. Create 3D figures from a diverse collection of ready-to-use 3D human and 
animal models. Poser's innovative interface makes figure design, posing and animating 
fast and easy. Map facial photos, grow and style hair, and create dynamic cloth to add 
extraordinary realism to your figure. Quickly output movies and images from your 
posed figures for content in web, print and video projects. Add life to your 3D worlds 
using exported, posed figures. Whether you’re new to 3D or an experienced artist, 
Poser 5 generates fast and dynamic results that will leave you speechless.

Poser Pro: Want to host Poser scenes inside leading 3D applications such as 3D Studio 
Max, Lightwave, Cinema 4D, and others? The Poser Pro bundle (consisting of Poser 4 
with the Pro Pack add-on) is the solution for you!

Avatar Lab: Create custom avatars, bring them to life, and use them to explore and 
communicate with others in these online worlds. Your Web avatar can even have your 
own face! Create a custom 3D head simply using a front and side photograph of 
anyone you choose. Avatar Lab’s intelligent face-mapping technology does the rest. 
Piece together pre-made body parts. Scale each part, and apply custom colors and 
materials to them. Avatar Lab’ s pre-made content allows thousands of avatar 
combinations. Add personalized faces, and the possibilities are endless!

All Curious Labs products can export still and animated content usable by pro-V Studio!
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WHEN YOU HAVE QUESTIONS

As you begin using pro-V Studio, you’ll undoubtedly have questions or want to network 
with other pro-V Studio artists. You’re not alone! There are many resources available for 
pro-V Studio artists. Here are just a few:

NEED HELP?

pro-V Studio includes the Help menu, which serves to answer most of your questions 
while using the application:

About: Selecting Help>About displays the pro-V Studio version and copyright 
information. This option will be useful if you need to obtain technical support, since 
the Technical Support representative will need to know this information.

pro-V Studio Help: Selecting Help>pro-V Studio Help opens the electronic version of 
this Reference Manual.

Tutorials: Selecting Help>Tutorials opens the Curious Labs Tutorials page in your 
Web browser. Check back often as we will be updating this site regularly! You will 
need an Internet connection and a Web browser in order to access the tutorials.

CURIOUS LABS RESOURCES

Online Support: For technical support, customer service, downloads, and to visit the 
Curious Labs pro-V Studio community and gallery, visit us at http://
www.curiouslabs.com. 

To Learn More: If you’d like to learn more about Curious Labs, visit us at 
http://www.curiouslabs.com/aboutUs/aboutus.html.

Contacting Technical Support: If our Web Knowledge Base does not resolve your 
situation, please email us at tech@curiouslabs.com. Please refer to “Technical 
Support” on page 180 to view our technical support policy.

Sales: You may reach our sales department by emailing sales@curiouslabs.com.

Other Links: Selecting Help>Curious Lab Web Links or Help>Other Web Links 
within pro-V Studio lists other valuable online resources.
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OTHER IMPORTANT RESOURCES

Visit the following sites to learn about the technology supported by pro-V Studio:

Viewpoint: Home of the Viewpoint 3D Web format.
The Viewpoint Web site is located at http://www.viewpoint.com.
The Viewpoint user forum is located at http://metastream.coolboard.com
Obtain Viewpoint developer information from http://developer.viewpoint.com
XML-based Viewpoint documentation is available at http://xml.viewpoint.com

ABOUT YOUR REFERENCE MANUAL

Curious Labs strives to provide documentation that is complete, accurate, informative, and 
friendly. Your feedback is always welcome. This Reference Manual uses several 
notational conventions to present information of special importance:

Lists of items, points to consider, or procedures that do not need to be performed in a 
specific order appear in bullet format:

Item 1

Item 2

Procedures that must be followed in a specific order appear in numbered steps:

1 Perform this step first

2 Perform this step second

Keyboard keys are depicted in square brackets and are capitalized. For example: [ESC]. If 
more than one key should be pressed simultaneously, the notation appears as 
[KEY1]+[KEY2], for example [ALT]+[F4].

Screen prompts, menu and window names, fields, buttons, boxes, etc. appear in bold type. 
Where you need to access a palette, command, or submenu, the syntax is 
Menu>Submenu. For example File>Save As means you should open the File pull-down 
menu and then select Save As to open the Save As dialog box.

Program and script code appears in standard Courier font, for example: 
cd\letters\business\legal [ENTER]

NOTE
NOTES DETAIL TIPS, TRICKS, AND OTHER IMPORTANT INFORMATION.

WARNING
WARNINGS ALERT YOU TO POTENTIALLY HARMFUL CONSEQUENCES SUCH AS DATA LOSS.
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Chapter 2: Installing pro-V Studio
efore opening your CD holder, please take a moment to read, understand, and 
agree to the pro-V Studio End User License Agreement (EULA). If you do not 
agree with the terms of the EULA, please return your entire pro-V Studio package 

including the unopened CD holder to Curious Labs or your place of purchase. If you 
obtained pro-V Studio via download, your purchase of this product indicates your 
acceptance of the pro-V Studio EULA, a copy of which was made available to you prior to 
completing the transaction.

WARNING
CURIOUS LABS IS UNABLE TO ACCEPT RETURNS ON PRODUCTS WITH OPEN CD HOLDERS OR ON 
DOWNLOADED PRODUCTS.

PRO-V STUDIO END USER LICENSE AGREEMENT (EULA)
Curious Labs, Inc. (Company), a California-based Corporation, provides the Program and 
the Documentation in this package and licenses its use. Breaking the seal on the Program 
CD jacket indicates that you agree to follow and be contractually bound by all of the terms 
and conditions comprising this EULA. If you do not agree with these terms, please return 
both the Program with an intact CD jacket seal and all package contents in resalable 
condition to its original point of purchase for a refund. If the point of purchase does not 
refund your money, contact the Company at the address below.

THIRD-PARTY TECHNOLOGY

Portions of Program contain technology and/or other components licensed by Company 
from Viewpoint Inc., who retain both ownership and copyrights to their respective 
contributions to Program.

GENERAL

A. Curious Labs maintains an ongoing EULA enforcement program. Violation of any 
provision in this EULA automatically terminates this EULA and may subject you to civil 
and/or criminal prosecution at the Company’s sole discretion.

B
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B. Your payment of the license fee grants you a LIMITED, PERSONAL, and NON 
EXCLUSIVE license to use Program and Documentation in accordance with all of the 
terms stated in this EULA. This license is NON TRANSFERABLE except as expressly 
permitted in this EULA or by US copyright law.

C. You expressly acknowledge that the Company has a valuable proprietary interest in 
both the Program and the Documentation. You own the physical media upon which the 
Program is provided. However, all title, ownership, and rights to the Program and the 
Documentation not expressly granted to you by this EULA and applicable laws remain 
with the Company.

D. You cannot use, copy, modify, derive, or transfer Program or Documentation or any 
copy, modification, derivation, or merged portion thereof in whole or in part via any 
means or for any purpose whatsoever except as expressly provided in this EULA.

E. You assume full responsibility for your selection of the Program to achieve your 
intended results and for the installation, use, and results you obtain from the Program.

F. You may only use the Program on a single computer, meaning that you must treat the 
Program like a book. “Like a book” means that the Program may be used by any number 
of people and may be freely moved from one computer to another so long as no possibility 
exists of the Program being used at more than one computer simultaneously. More than 
one person at a time cannot read the same copy of a book, and this restriction applies to the 
Program. The Company is pleased to offer site licenses for multiple simultaneous users. 
Please contact the Company at the address below for details.

G. You, your employees, and/or authorized agents must protect the Program’s 
confidentiality and act to enforce this EULA. You cannot distribute or otherwise make the 
Program or Documentation available to any third party via any means whatsoever, public 
or private, for any purpose, commercial or not, unless explicitly allowed by either this 
EULA or applicable US copyright law.

H. You may not copy or reproduce the Program or the Documentation except to make one 
(1) archival copy of the Program for your personal backup purposes, in support of your 
using the Program in full compliance with this EULA. You may not transfer this archival 
copy or permit this archival copy to be transferred to any other person or entity via any 
public or private means whatsoever, whether for compensation or not, unless this archival 
copy is part of a one-time permanent transfer of the Program, the Documentation, and all 
rights to use the Program and the Documentation granted by this EULA. Further, you must 
reproduce and include the Company’s copyright notice on the archival copy of the 
Program. Company retains full ownership, title, and all other rights to the copy of the 
Program contained on your archival media, and all of the terms of this EULA apply to this 
archival copy as if it was the original Company-produced copy of the Program that was 
furnished to you when you paid the licensing fee.
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I. You cannot reverse engineer, decompile, debug, disassemble, circumvent security 
features, or interfere with the normal Program functionality and operation for any reason 
whatsoever without the express prior written consent of the Company. Any such activity 
performed without the required consent is a violation of this EULA that may subject you 
to civil and/or criminal prosecution at the Company’s sole discretion.

J. Any portion of the Program merged into or used in conjunction with another program 
remains the property of the Company and subject to this EULA. You must reproduce and 
include the Company’s copyright notice on any portion of the Program merged in or used 
in conjunction with another program.

K. The sale of legal copies of the Program and the Documentation is restricted in 
accordance with US copyright law and any existing distributor and/or reseller agreements 
currently in effect between the Company and authorized distributors/resellers. This EULA 
does not grant the user the ability to act as a reseller of the Product or the Documentation. 
You may perform one permanent transfer of assignment of your personal copy of the 
Program, the Documentation, and this End User License Agreement as permitted under 
US copyright law provided all materials shipped with the Product (including the Program, 
the Documentation, the Allowed Content, the Restricted Content, and all rights granted by 
the EULA) are complete and unaltered and that all copies in your possession in original 
and converted forms are transferred. The party receiving the permanent transfer must 
accept the terms and conditions of this EULA and any other terms and conditions upon 
which you legally purchased a license to the Program.

L. You may not rent, lease, sublicense, or lend any versions or copies of the Program that 
you do not use. If the Program is an update to a previous version of the Program, you must 
possess and maintain a valid license to such previous version in order to use the update.

M. You may continue to use the previous version of the Program on your computer 
provided that all previous End User License Agreements are observed. You may not 
transfer the previous version without transferring or destroying the updated version.

DISTRIBUTION

Publication of any content created using pro-V Studio requires a separate broadcast key 
license from Viewpoint. For information on how to obtain a broadcast key license, please 
visit http://www.viewpoint.com. Publication requiring a license from Viewpoint includes 
publication for commercial or non-commercial purposes, whether on the Internet, CD-
ROM, an intranet, or any digital media.
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APPROPRIATE USE

You may not use the Program in any manner that violates any applicable laws in your 
locality. The Company is not responsible for any illegal use of this software.

TERM

This EULA remains in full force and effect until terminated. You may terminate it at any 
time by returning the Program and the Documentation to the Company together with all 
copies, modifications, and merged portions of the Product and the Documentation in any 
form. The Company is in no way obliged to issue refunds in cases where the original CD 
jacket seal has been broken. This EULA will also terminate upon the conditions set forth 
elsewhere in this EULA, including but not limited to your violation of any of the 
provisions herein. 

Upon termination, you must immediately return both the Program and the Documentation 
to the Company along with all copies, modifications, and merged portions in any form. 
Termination of this EULA for any reason in no way limits the Company’s right to 
continue enforcing all rights provided by law and does not entitle you to a refund of your 
license fee except as provided herein. All provisions of this EULA that protect the 
Company’s proprietary rights continue in full force and effect after termination.

LIMITED WARRANTY

As the Program’s and Documentation’s sole warranty, the Company warrants that the 
original physical medium on which the Program and the Documentation is distributed free 
from defects in materials and workmanship under normal usage conditions for a period of 
ninety (90) days from the date of delivery to you as evidenced by a copy of your receipt.

No distributor, dealer, or any other entity or person is authorized to expand or alter either 
this warranty or this EULA, and the Company will not be bound by any such 
representation in any way. The Company does not warrant that the Program’s functionality 
will meet your requirements or that the Program operation will be uninterrupted or error-
free.

Except as stated in this EULA, the Program and the Documentation are provided to you 
as-is without any expressed or implied warranty of any kind, including but not limited to 
implied warranties of merchantability and fitness for a particular purpose. You assume the 
entire risk of the Program’s and the Documentation’s quality and performance. Should the 
Program prove defective you (and not the Company, authorized Company Distributor, or 
dealer) assume the entire cost of all necessary servicing repair or correction.

This warranty gives you specific legal rights. You may also have other rights, which vary 
from state to state and from country to country. Some states and countries do not allow the 
exclusion of implied warranties, so the above exclusion may not apply to you.
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LIMITATION OF REMEDIES

The Company’s entire liability and remedy will be either:

Replacing any original physical medium not meeting the Company’s ‘Limited 
Warranty’ explained above, which you return to the Company or an authorized 
Company distributor or dealer along with a copy of your receipt.

If the Company cannot deliver a replacement physical medium conforming to the 
warranty provided within this EULA, you may terminate this Agreement by returning 
the Program and the Documentation to the Company, authorized Company Distributor, 
or dealer for a refund of your license fee.

PRODUCT RETURNS

If you must ship the Program and the Documentation to an authorized Company 
Distributor, Dealer, or the Company, you must pay all shipping costs and insure the 
Program and the Documentation for the full license fee. If you are returning the Program 
to the Company for replacement of a defective physical medium during the ninety (90) 
day warranty period, please provide your full name and address, the original defective 
physical medium, and a copy of your receipt to the address provided below. Prior to 
returning the Program, please contact the Company for a Return Merchandise 
Authorization (RMA) number at the address below. 

In no event will the Company be liable to you for any damages, whether direct, indirect, 
incidental, or consequential, including damages for any lost profits, lost savings, or other 
incidental or consequential damages arising out of your use or inability to use the Program 
and the Documentation, even if the Company has been advised of the possibility of such 
damages or for any claim by any other party. Some states and countries do not allow the 
limitation or exclusion of liability for incidental or consequential damages, so the above 
limitation or exclusion may not apply to you. In no event will the Company liability for 
damages to you or any other person ever exceed the amount of the license fee paid by you 
to use the Program regardless of the form of the claim.

U.S. GOVERNMENT RESTRICTED RIGHTS

The Program and the Documentation are provided with restricted rights. The use, 
duplication, or disclosure by the United States Government is subject to restrictions as set 
forth in subparagraph (c)(1)(ii) of the Rights in Technical Data and Computer Software 
Clause at DFARS 252.227-7013 or subparagraph (c)(1) and (2) of the Commercial 
Computer Software Restricted Rights at 48 CFR 52.227-19, as applicable. The Contractor/
Manufacturer is Curious Labs, Inc.
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APPLICABLE LAW

The laws of the state of California govern this EULA, except that federal and international 
law governs copyrights, patents, and registered trademarks. Should any court having 
appropriate jurisdiction find any provision of this EULA invalid, that particular provision 
will be deemed null and void and will not affect the validity of any other provision of this 
EULA.

CONTACT INFORMATION

If you have questions concerning this EULA or need to contact Customer Service, please 
contact Company at this address:

Curious Labs, Inc.
655 Capitola Road, Suite 200
Santa Cruz, CA 95062
(831) 462-8901 phone
(831) 462-8925 fax
Customer Service (returns, warranty): service@curiouslabs.com
Legal (EULA questions, illegal activity reporting): legal@curiouslabs.com

For technical support, please refer to “Technical Support” on page 180.

COPYRIGHT

Program and Documentation are ©2002-2003 Curious Labs, Inc. and EGISYS AG. All 
rights reserved. The Curious Labs logo is a trademark of Curious Labs, Inc. Curious Labs 
and pro-V Studio are registered trademarks of Curious Labs, Inc. and EGISYS AG. All 
other product names mentioned in Program, Documentation, or other documentation are 
used for identification purposes only and may be trademarks or registered trademarks of 
their respective companies. Registered and unregistered trademarks used herein are the 
exclusive property of their respective owners.
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INSTALLING PRO-V STUDIO

To install pro-V Studio:

1 Double-click the Setup.exe icon.

2 The Welcome screen appears. Click Next to continue.

3 The Choose Destination Location window appears. Select your desired folder in 
which to install pro-V Studio. Click Browse to navigate to the desired folder or enter 
any valid existing or new path to your pro-V Studio installation. Once you have made 
your selection, click Next to proceed.

4 The pro-V Studio EULA appears. You must accept the pro-V Studio EULA prior to 
installing pro-V Studio on your computer. Click Next to proceed.

5 The pro-V Studio Readme appears. This text file contains information that is too late 
to be incorporated into other documentation. Once you have read it, click Next to 
proceed.

6 pro-V Studio will be installed to your selected directory. Be sure to reboot your 
computer following installation.

7 Launch pro-V Studio by double-clicking the pro-V Studio icon.

8 Personalize your copy of pro-V Studio by entering your name and serial number.

Thank you for purchasing and installing pro-V Studio by Curious Labs!
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Chapter 3: The pro-V Studio Process
Before we can discuss how to use the application, it is important that you 
understand what is going on behind the scenes. This knowledge will make your 
work in pro-V Studio far easier and more enjoyable.

PROJECTS AND SCENES

Everything in pro-V Studio centers around projects, which act as containers for scenes. A 
project contains all of the assets (images, objects, settings, etc.) in a separate folder tree on 
your hard drive. Of all the assets available in a given project, you will use some or all of 
them to create scenes. The scene is what will actually be published to the Viewpoint 
format.

A scene is that collection of project assets that you decide to use. Once you finish your 
scene, it will be published to the Viewpoint format.

When you launch pro-V Studio, you will be prompted to open an existing project or create 
a new one. The project/scene architecture is central to pro-V Studio’s functionality. When 
working in pro-V Studio, you are working in a project.

As mentioned above, pro-V Studio creates a folder tree on your hard drive for each 
project. It also creates a master project file named <name>.xml, where <name> is the 
name of your scene. This file stores all of your project settings and references to all objects 
in that project in XML format.

WARNING
DO NOT ALTER THE MASTER PROJECT FILE IN ANY WAY UNLESS YOU ARE AN EXPERT USER. DOING SO MAY 
CORRUPT THE FILE, WHICH COULD CAUSE YOUR PROJECT TO BEHAVE UNEXPECTEDLY AND/OR PRO-V STUDIO 
INSTABILITY.

N
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LIBRARY VS. PROJECT ASSETS

As mentioned above, assets consist of all items that can be used for scenes. In order to use 
an asset in a scene, you must either import it or access it. pro-V Studio supports three 
levels of assets:

pro-V Studio Library: Assets in the pro-V Studio Library (A) can be used in any pro-V 
Studio project (C). The Library is where you store the assets you use most often.

Project: Each project has its own assets, allowing you to create multiple scenes, each 
using different assets. For example, you could upload all content for a particular client 
to a project’s assets and then create any number of scenes using those assets.

You can use assets in the pro-V Studio library in any of your projects and can use project 
assets (B) for that given project (C). Project assets do not have to be part of the pro-V 
Studio library.

If you use assets from the pro-V Studio Library in a project, those 
assets will be duplicated and added to your project assets. This 
prevents damage to one or more projects if you delete anything in 
your pro-V Studio library.

Please refer to “Import” on page 70 and “Content Room” on 
page 62 for more information about adding content to your Library or project assets.

PRIMITIVES

Primitives are a third category of content consisting of basic geometric shapes such as 
planes, spheres, and cones. They are available for use in all projects and do not need to be 
loaded into the libraries. Please refer to “Primitives Tab” on page 109 for more 
information on accessing primitives.

NOTE
FOR CLARITY, THIS MANUAL WILL USE THE TERM “LIBRARIES” WHEN DISCUSSING THE LIBRARY, PROJECT 
ASSETS, OR PRIMITIVES. THE SPECIFIC NAME WILL BE USED WHENEVER THE DISTINCTION BETWEEN LIBRARY, 
PROJECT ASSETS, AND PRIMITIVES IS IMPORTANT.
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INSTANCES

Once you load an asset into either library, adding it to your scene creates an instance of 
that asset. The remainder of this manual will call instanced assets either objects or 
instances. An instance is like a photocopy in that you will see however many copies of the 
asset you desire. Like a photocopy, pro-V Studio only needs to load the original file once. 
This can allow huge memory and other resource savings. For example, say you have a 
scene with three identical cars of different colors. If each car object is 1MB and you had to 
load it three times, your scene would require 3MB. By instancing, the car is loaded once 
and “duplicated”, meaning you only need just over 1MB to display the three cars.

Each instance can have its own unique attributes such as scale (size), translation 
(location), material, lighting, etc.

PROJECT ORGANIZATION

pro-V Studio creates a folder tree on your hard drive for each new project you create. This 
tree looks as shown in the graphic.

In this example, “<project>” is the name of your 
project. The sub-folders in the project tree are:

Objects: This folder contains all imported objects 
(*.OBJ or other meshes).

Sound: This folder contains all imported sounds 
added to your project.

Textures: This folder contains all 2D objects in your scene, including images and all of 
the maps (texture, bump, alpha, and light). Please refer to “Maps” on page 42 for 
information about maps.

Javascripts: This folder contains all Java scripts added to your scene.

Scenes: This folder contains all of your imported scenes in all supported formats 
(*.MTX/MTZ, ASE, and NFF).

Export: By default, this folder contains scenes in the Viewpoint formats (MTS, MTX/
MTZ, and HTML) ready for publication and incorporation into your Web site. You can 
alter this path when publishing your project. See “The Publish Room” on page 172 for 
more information.

WARNING
DO NOT ADD OR REMOVE CONTENT TO/FROM THESE FOLDERS. REMOVING FILES MAY CAUSE SCENES TO NOT 
UPDATE CORRECTLY. ADDING FILES WILL NOT IMPORT THEM INTO YOUR PROJECT. TO ADD ASSETS. ALWAYS 
IMPORT THEM USING THE PRO-V STUDIO INTERFACE.
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EDITING ASSET FILES

With certain limitations, you may directly edit the files in your project folder trees. The 
limitations are:

Do not rename or reformat asset files. For example, if you edit a JPG image, do not 
save it as a TIF.

Do not edit any MTS or MTX/MTZ files unless you are an advanced user. Doing so 
could cause your project to crash or behave unexpectedly.

Your project folders each contain a file called <project>.XML. Do not modify this file 
directly. You may lose data, and/or cause pro-V Studio or your scene to crash or 
behave unexpectedly.

WARNING
USE EXTREME CAUTION WHEN EDITING PROJECT ASSET FILES. FAILURE TO ADHERE TO THE ABOVE 
LIMITATIONS COULD LEAD TO DATA LOSS, APPLICATION INSTABILITY, AND/OR ERRATIC OR UNEXPECTED 
PROJECT/SCENE PERFORMANCE.

NAMING INSTANCES & OBJECTS

pro-V Studio does not allow you to reuse the same instance name in the same hierarchy. 
All instances in your scene must be uniquely named. pro-V Studio will automatically 
force unique names. This avoids potential confusion between instances.

HIGH LEVEL WORKFLOW

This diagram illustrates how pro-V 
Studio handles data:

As you have seen, all data imported 
into pro-V Studio becomes assets 
for the current project and/or the 
pro-V Studio Library. These assets 
can include files created in a variety 
of 2D and 3D authoring/modeling 
applications. After import, you add 
the assets you wish to use to the 
project assets for use with pro-V 
Studio’s Project Editor. The Project Editor is the heart of pro-V Studio and is the portion 
of the application most visible to users. You create a scene using project assets and saving 
your work to project files that contain every asset and setting used in your scene.
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When your project is finished and ready for publication to the Viewpoint format, pro-V 
Studio sends your project to the Publish process. This in turn generates the MTS, MTX/
MTZ, and HTML files needed to distribute the project over the web in Viewpoint format.

THE PRO-V STUDIO PROCESS

The overall scene creation/publication process requires seven steps:

In more detail, these steps are:

1 Import all of the assets needed for your current project.

2 Lay out your scene and edit each object as desired.

3 Add materials, lighting, etc.

4 Add interaction to bring your scene to life.

5 Add any animation you want to your scene.

6 Debug and integrate your scene and prepare it for publishing.

7 Distribute your scene to a Web site ready for use.

MODES

pro-V Studio has two modes:

Edit: In Edit mode, you are manipulating your scene (adding objects, creating 
animation, etc.). You cannot view the results of your work in this mode.

Playback: In Playback mode, you are viewing the results of your work. In general, 
you are in Playback mode whenever you are playing an animation using the Play 
Controls palette. You can preview animations (such as in the Simple Animations 
palette), but will remain in Edit mode. While in Playback mode, you cannot edit your 
scene. All extra palettes disappear when in Playback mode.

Switching between these modes occurs transparently.
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LAYERS

Each pro-V Studio scene consists of four layers:

From back to front, these layers are:

BACKGROUND LAYER

As its name implies, the background layer (1) acts as a backdrop for your scenes. It can 
hold standard images, SWF movies, or panoramas. This layer maintains its distance from 
the camera, meaning that you cannot zoom in or out of the background.

pro-V Studio allows you to place more than one file in the background layer. However, 
this layer does not allow you to order these files, meaning that you cannot control which 
file will appear in front of another once you add them to the layer. Each file is rendered in 
the order you add it to the scene, with the most recently added file appearing on top of the 
others. Panoramas and images will always appear in front of SWF (Macromedia Flash) 
animations. See “Transparency” on page 24 for more information.

The background layer supports three types of projection:

Flat: This projection method places the image or 
SWF animation in the background as a fixed 
backdrop. This backdrop is anchored to the 
camera, meaning that it will not appear to move 
when the camera moves.

Cylindrical: This projection method is designed to 
work with panoramic images (potentially 
imported from QuickTime VR). Rotating the 
camera will scroll the background. Horizontal 
rotation will keep the background within the 
camera’s field of vision, however vertical rotation 
can exceed the panorama’s boundaries. This type 
of panorama is useful for scenes such as a 
landscape where you constrain the user’s ability to 
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rotate the camera vertically. When using this projection method, the bottom of the 
panorama is located at the scene’s ground level.

Spherical: This projection method is designed to 
work with unwrapped IPIX (<<EXTENSION>>) 
files. These are true spherical panoramas that 
scroll no matter how the camera rotates. This type 
of panorama could be used to hold a star map, for 
example.

All items in this layer are scaled to your scene 
window, meaning you cannot scale or position it. This 
layer does not capture user input and cannot support interactions.

NOTE
YOU MAY PLACE ZOOMVIEW IMAGES AND SWF ANIMATIONS IN ANY LAYER.. TYPICALLY, HOWEVER, ZOOMVIEW 
IMAGES ARE PLACED IN THE BACKGROUND LAYER, WITH SWF ANIMATIONS APPEARING IN ANY 2D LAYER.

Ordering Objects Within The Background Layer

Keep the following tips in mind if you opt to load multiple files into the background layer:

Images and panoramas will appear in front of SWF movies. If you have both an image/
panorama and one or more SWF movies, you must set the image/panorama to be 
partially transparent (see “Transparency” on page 24 for more information about 
opacity).

SWF movies appear in the order you add them, with the most recently added file 
appearing in front of the others.

You cannot adjust the order of SWF movies once you add them to this layer.

3D LAYER

The 3D layer (2) hosts all of the 3D objects in your scene. You have full control over 3D 
objects including transformation, animation, materials, interactions, etc. Much of this 
manual discusses handling 3D objects. This layer captures user input such as mouse 
clicks, etc., allowing you to add interaction to 3D objects (see “Interactions” on page 47).

2D LAYER

The 2D layer (3) is similar to the background layer. However, unlike the background, this 
layer does capture user input such as mouse clicks, etc. You can add text hotspots and 
image hotspots (see “Modifiers” on page 48), action primitives (see “Create Action 
Primitive” on page 89), as well as images and animations. In essence, action primitives are 
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2D objects with interactions or behaviors attached. pro-V Studio allows you to add 2D 
checkboxes and 2D buttons as action primitives.

This layer only supports flat projection, that is, objects in this layer cannot be cylindrical 
or spherical panoramas. Like the background and foreground layers, this layer retains its 
distance from the camera and always remains in the camera’s field of view. You can 
position and scale objects in this layer.

Ordering Objects Within The 2D Layer

You can select the order in which 2D objects appear in this layer by setting the Viewpoint 
render layer in the Object Attributes dialog, which is discussed in “Object Attributes 
Palette” on page 141.

FOREGROUND LAYER

The foreground layer (not shown) functions similarly to the background layer. You can 
add images and movies to this layer. Like the background layer, these objects will be 
rendered in the order they are added, with the most recently added object appearing in 
front of the others. This layer does not capture user input. You can, however, mimic this 
functionality as discussed in “Foreground Interactivity” on page 24.

This layer only supports flat projection, that is, objects in this layer cannot be cylindrical 
or spherical panoramas. Like the background and 2D layers, this layer retains its distance 
from the camera and always remains in the camera’s field of view. Objects in this layer are 
scaled to the scene window. You cannot scale or position them.

ABOUT RENDER LAYERS

So far, we have viewed the four pro-V Studio layers as being in a distinct order from back 
to front, implying that various objects must occupy certain spaces and appear in certain 
ways. In most cases, this description is sufficient. However, there are ways to expand on 
this basic functionality to achieve truly advanced results.

NOTE
THESE ADVANCED EXAMPLES ARE INTENDED FOR ADVANCED USERS ONLY SINCE MISUSE CAN RESULT IN 
UNEXPECTED SCENE BEHAVIOR. WE ENCOURAGE YOU TO EXPERIMENT WITH THESE AND OTHER ADVANCED 
SCENE MANIPULATIONS USING ONLY NON-CRITICAL TEST SCENES THAT WILL ALLOW YOU TO SAFELY EXPLORE 
AND ADVANCE YOUR PRO-V STUDIO SKILLS. 
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USING RENDER LAYERS

In “Ordering Objects Within The 2D Layer” on page 23, we only discussed using render 
layers to order objects in the 2D layer; however, this concept applies to most objects in 
most layers. Viewpoint renders objects by render layer (not to be confused with pro-V 
Studio’s four object layers), beginning with the rearmost layer and proceeding forward. 
Each render layer is numbered, with lower-numbered layers appearing in front of higher-
numbered layers. This gives you great flexibility. For example, you can give a 3D object a 
lower number than a 2D object and make the 3D object appear in front of the 2D object. 
Each object retains its basic abilities and limitations based on its assigned object layer, 
however. Modifying the default render layer settings will override the standard order in 
which objects are rendered.

In general, the higher the render number, the more distant the object will appear. For 
example, if you have a green square assigned to render layer 100, a blue circle with render 
layer assigned to 99, and a red triangle assigned to render layer 101, the square will render 
in front of the triangle with the circle in front of both objects

TRANSPARENCY

As mentioned above, certain objects appear in front of 
others by default. For example, in the 2D background 
layer, images and panoramas appear on top of SWF 
animations. Normally, the image/panorama would 
hide the SWF animations from view. By altering the 
image/panorama’s transparency, you can make the 
SWF movies visible.

In the foreground layer, you can add images or 
animations that are partially transparent, allowing you to view the rest of your scene 
through the transparent portions as shown in the graphic.

FOREGROUND INTERACTIVITY

The foreground layer does not support interactivity such as mouse clicks. You can emulate 
this functionality as follows:

1 Place your image (standard or ZoomView) or SWF animation into the foreground 
layer. This will become the interface (GUI) visible to your users once your scene is 
published.

2 Place one 2D object behind each location in the foreground content that you want 
users to be able to click on (such as an animated “Buy Now!” icon). These objects will 
be invisible when your scene is rendered.
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3 Add the appropriate interactions to the 
2D object(s). When users click the 
icon, the interactive 2D object behind 
the icon, the expected action will 
occur as if they had clicked the icon 
itself.

The image shows an animated interface 
applied to the foreground layer with 
hidden 2D objects actually handling the 
user input:
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Chapter 4: 3D Basics
s described above, pro-V Studio contains a 3D layer where you can insert and edit 
3D objects. It is therefore helpful to explain a few basic 3D concepts. The 
following discussion centers on pro-V Studio, however most of these concepts 

apply to all 3D applications. Novice 3D artists should read the entire chapter to gain 
valuable “behind the scenes” insight that will help in learning and using pro-V Studio. 
Veteran 3D users can use this chapter as a handy reference or refresher.

ABOUT 3D SPACE

Let’s begin by defining the three dimensions:

Zero dimension: A point is an example of a zero-dimensional object. It defines a point 
in space but has no length, height, or width.

First dimension: A one-dimensional object is a single line. It has length but no height 
or depth.

Second dimension: A two-dimensional object has any two of the following three 
dimensions:

Length
Height
Depth

Pick any one of the three dimensions and call it A. Now pick 
either of the remaining two dimensions and call it B. In the 
graphic, the arrows represent the two dimensions and the 
rectangle represents a two-dimensional object. You will 
immediately notice that all two-dimensional objects are 
perfectly flat, like the surface of a sheet of paper. Two-
dimensional objects are called planes.

Third dimension: Three-dimensional objects use all three of the dimensions (length, 
height, and depth).

As you can see from the graphic, the cube is a three-
dimensional object. It has length, height, and depth. That’s 
pretty simple, right? Here’s the hard part: You create 3D 
data using two-dimensional tools. Your computer screen is 
a two-dimensional object and your mouse can move in two 
dimensions; it can report left-right and front-back motion 

A
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but cannot report how far above or below the desk it is. Furthermore, your output will 
always be two-dimensional. Look at the above graphic: It does not have depth. It does, 
however, represent three dimensions using a simple optical illusion called perspective, 
which is defined as the tendency of objects to appear progressively smaller the farther 
away they are until they disappear on the horizon at a location called the vanishing 
point. You can see this by standing at the corner of a long building and noticing how 
the roofline appears to get closer to the ground the farther away you look. Given these 
limitations, you ask, how can one create 3D information?

The short answer is that all 3D applications, pro-V 
Studio included, create a “virtual” 3D space. Look at 
the above graphic again. We can view and 
manipulate the cube in three dimensions by 
separating them into views. One view will display 
the A and B dimensions, the second will display the 
A and C dimensions, and the third will display the B 
and C dimensions. You will also have a fourth view 
that displays all three dimensions. This graphic 
shows how the four views might look in a 3D 
application.

Let’s look at the same graphic again, only this time 
let’s substitute a simple boat for the cube to better illustrate the concept. One of the 
benefits of this system is that it becomes possible to precisely control your 3D model. For 
example, you can determine the length of the boat using the AB or AC view, the width 
using the AB or BC view, and the height using the AC or BC view. Which view you use 
depends on what you are trying to accomplish. For example, to create the stern, you would 
probably use the BC view, and would probably use the AB view to create the overall 
shape.
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In these examples, the A, B, and C dimensions are collectively called axes. Taken 
individually, each dimension is called an axis. So far, we have used each axis to describe 
one of the three dimensions without caring about which axis describes which dimension. 
The A dimension could describe any of the three dimensions with B describing either one 
of the remaining two dimensions and so forth. We did this to illustrate the most basic 
theory behind 3D applications such as pro-V Studio. Let’s expand on that.

It should be obvious that the AB, AC, and BC views lack perspective. Two-dimensional 
views without perspective are called orthogonal views. Each three-dimensional object has 
six orthogonal views: Top, Bottom, Left, Right, Front, and Rear. Pick up any object you 
like and look at it from all angles; you will see that this always holds true. So, while the 
boat example above shows the Top (AB), Left (AC), and Rear (BC) views, it could just as 
easily show any three of the six possible views. This is important because, like the boat, 
not all three-dimensional objects are symmetrical.

Now that you understand this fundamental concept, let’s learn how it’s used in the real 
world. To recap, the three dimensions are width, length, and height or depth, each 
dimension is represented by an axis, and we can view each pair of axes in two ways to 
generate a total of six possible views. So far so good, except for one small problem: If 
everyone used an arbitrary system of axes to define the three dimensions, then it would be 
difficult to pass data back and forth. In the above example, we are using the AB as the Left 
view. Someone else could just as easily define AB as any of the six available views. You 
can see the chaos that could ensue. To prevent this, both 2D and 3D objects conform to a 
standard system of axes called the Cartesian coordinate system. The term Cartesian is 
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used in honor of the French mathematician and philosopher Rene Descartes (1596–1650), 
who was one of the first to employ such coordinate systems.

CARTESIAN COORDINATES

Before getting too far into Cartesian coordinates, let’s 
pause for a quick math review: If you arranged all of the 
numbers from negative infinity to positive infinity along a 
line, the number 0 would be in the center of that line. 
Negative numbers would be on the left side of 0 with –1 being the closest to 0, and 
positive numbers would be on the right side of 0 with +1 being the closest to 0.

Negative numbers being on the left (or front) works for horizontal lines or axes. For 
vertical lines, negative numbers are beneath 0 with positive numbers above 0. This stands 
to reason, since negative numbers are literally less than 0. When dealing with coordinate 
systems, we assume that each dimension is infinite, with zero representing the 
dimension’s center or origin.

The Cartesian coordinate system goes one step further by defining three axes, called X, Y, 
and Z. In our previous examples, we deliberately used the arbitrary letters A, B, and C to 
illustrate the concept of axes and avoided using the actual letters because we wanted to 
familiarize you with the general idea of axes and dimensions before focusing on how they 
are actually used. In the Cartesian coordinate system, the axes correspond to dimensions 
as follows:

X: Width

Y: Height

Z: Depth

Let’s combine the origin with the Cartesian axes as follows. 
As you can see, the Cartesian coordinate system uses three 
axes to represent each of the three dimensions: X, Y and Z. 
The positive X axis points to the right, the positive Y axis 
points up, and the positive Z axis points towards the front of 
the scene. The center of the 3D space is a single point, which 
is the midpoint (origin) of the three axes. Thus, the 3D space 
extends to infinity in both negative and positive directions 
along all three dimensions.

Now that we have a standard system for defining 3D space and objects within that space, 
we can use coordinates to define the object’s shape. Remember that coordinates are 
always listed in XYZ order. Coordinates themselves are defined as the distance from the 
origin along each of the three axes. For example, the coordinate {1,1,1} signifies a point 
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that is 1 unit to the right of the X origin, 1 unit above the Y origin, and 1 unit behind the Z 
origin.

NOTE
 THE FORMAT OF LISTING THE X, Y, AND Z COORDINATES WITHIN BRACES AND SEPARATED BY COMMAS IS THE 
STANDARD SHORTHAND USED WITH THE CARTESIAN COORDINATE SYSTEM.

Remember the box we used in the previous 3D example? 
We can use Cartesian coordinates to define its corners. 
What if we move the box over somewhat? The graphics 
on the right show how that might affect the coordinates. 
As you can see, Cartesian coordinates serve to define an 
object’s shape, size, and location in 3D space.

PLANES

As we discussed earlier, 3D applications must depict and 
manipulate 3D data using a series of 2D views and tools. 
You already know that 2D objects are planar because they 
exist on a mathematically defined plane. A plane is a 
formula defining the relationship between two 
dimensions, such as XZ. Combining these two facts with 
what we just learned about the Cartesian coordinate 
system and a quick glance at our monitor, we find that 3D 
applications like pro-V Studio use coordinate planes to 
help you locate points in 3D space. 

WORLD VS. OBJECT COORDINATES

There is one last wrinkle to the Cartesian coordinate system. To explain this wrinkle, let’s 
use the example of a motorcycle rider leaning into a turn. What just happened? For the 
sake of argument, let’s assume that the headlight is 30 inches above the ground when the 
motorcycle is upright. If the rider leans the motorcycle 45 degrees to the left, then 
headlight will now be 21.2 inches to the left of center and 21.2 inches off the ground.

NOTE
 FOR ANYONE INTO TRIGONOMETRY, WE FIND THE NEW LOCATION BY MULTIPLYING THE ORIGINAL LOCATION 
BY THE SIN AND COSINE OF THE ANGLE. IN THIS CASE, SIN(45) = COS(45) =.707, AND.707*30= APPROX. 21.2.

Thus, the headlight’s coordinates will have changed from {0, 30,0} to {21.2, 21.2, 0}. 
However, nothing has changed about the motorcycle itself. The headlight is still in the 
exact same position relative to the rest of the machine. To demonstrate this, let’s create a 
second 3D space using the motorcycle’s center of gravity (balance point) as the origin. 
Let’s further say that the headlight is 12 inches above and 30 inches in front of the center 
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of gravity. This means that the headlight’s relative coordinates are {0, 12, -30}, and these 
relative coordinates do not change because the headlight does not move relative to the 
center of gravity. But what do we mean by relative?

Has the motorcycle leaned 45 degrees to the left, or has the world leaned 45 degrees to the 
right? To an observer standing on the ground, the motorcycle has leaned over 45 degrees. 
To the rider, s/he is still on top of the motorcycle and it is the world that has leaned over 45 
degrees. Further, the rider maintains her or his relationship to the motorcycle, meaning 
(for example) that her or his head is still 30 inches behind and 32 inches above the 
headlight. Thus, while the motorcycle’s world (or global) coordinates have changed, its 
object (or local) coordinates have remained the same.

If this seems a bit complex, bear with us as we 
use a far simpler example. Each object in pro-V 
Studio has its own object coordinate system. 
When an object is first created, its center and 
orientation are the same as the world’s. As 
described above, this changes when the object 
moves. The world’s center and orientation are 
still the same, but the object’s center and 
orientation may have changed. Look at the square 
in the graphic. Say the upper-left corner is located 
at {-5,5,0}. When the object is first created, that 
point is the same in local and global coordinates because the object’s center is at {0,0,0}. 
If we move the object +7 along the X axis and +3 along the Y axis, the upper-left corner 
would now be at {2,8,0} in global coordinates but would remain at {-5,5,0} in local 
coordinates, that is, relative to the object’s center. In other words, any point can be 
specified relative to its object’s local coordinate system (object space) or relative to the 
global coordinate system (world space or global coordinates) shared by all objects.

TRANSFORMATION

So far, you have learned about 3D objects, the Cartesian coordinate system, and the 
difference between object space and world space. Let’s move on and learn how we can use 
XYZ values to define an object’s transformation in addition to its size, shape, and 
position.

An object’s transformation describes an object’s position (translation), orientation 
(rotation), and size (scale) in 3D space. When an object is first created, its transformation 
is set to align with the global coordinates. Its position is set to {0,0,0}, its orientation is set 
to {0,0,0}, and its size is set to {1,1,1}. An object’s transformation values are almost 
certain to change as you work with the object.
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Translation

An object’s translation describes its position in 3D space relative to its center and is 
measured in defined grid units. Let’s take another look at the box we used in an earlier 
example:

As you can see, the box’s center is the same as the origin ({0,0,0}). What happens if you 
want to move the box? You can move each one of the points, delete the existing box and 
draw a new one in its new location, or simply translate the box. For example, setting a 
Translate value of {2,2,2} would move box’s lower left corner to {0,0,0} since (-2)+2=0. 
Again, the Translate value refers to the location of the center of the object relative to world 
space.

Rotation

An object’s rotation value refers to its orientation in 3D 
space measured in degrees. As you probably know, any 
actual object will revolve around its center of gravity 
(balance point).

Let’s think back to the motorcycle example. If you model 
a motorcycle and decide you wish to lean it 45 degrees, 
nothing is stopping you from performing trigonometric 
calculations to determine the new location of each part. Remember that each part of the 
motorcycle will move in at least two dimensions as the whole machine rotates. In this 
case, since the motorcycle is rotating about the Z axis, you could simply enter a rotation 
value of {0,0,45}. The trigonometric calculations will still need to be performed, however 
pro-V Studio will get stuck with the job instead of you.

Rotation can also be thought of in 
terms of roll, pitch, and yaw. To 
illustrate this, let’s use the example of 
a small plane with its X, Y, and Z axes 
labeled:

Pitch: rotation of the selected 
object about its own X axis

Yaw: rotation of the selected object 
about its own Y axis

Roll: rotation of the selected object 
about its own Z axis
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Scale

An object’s scale value refers to its size in relation to itself and is measured in percent. In 
this case, a value of 1 corresponds to 100%. Take the example of a circle. As with all other 
pro-V Studio objects, it is initially created with a scale value of {1,1,1}, meaning that it is 
100% of its original size in all three dimensions.

Now that your perfect circle is in place, 
you realize you need to double its 
height on the Y axis. Simply enter a 
scale value of {1,2,1} and the circle 
will turn into an ellipse that is twice as 
long on the Y axis as it is wide. To 
stretch it on the X axis, you would enter 
{2,1,1}.

To compute every point on a model, multiply the original coordinates by the X, Y, and Z 
components. With this in mind, it becomes easy to see how different values can change the 
size of your object. For example, entering a scale value of {2,2,2} would double the 
circle’s size. pro-V Studio allows you to set each scaling factor independently in order to 
obtain squashing and stretching effects. This is called differential scaling.

Shear

pro-V Studio also allows you to add shear 
effects. As the name implies, a shear 
involves a “tearing” motion along one or 
more axes.
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Chapter 5: Additional 3D Elements
ow that we have learned the basics about how 3D works, let’s discuss more 
advanced concepts applicable to pro-V Studio. Understanding these concepts will 
help you work with pro-V Studio more efficiently and get the most from this 

application.

SPLINES

Splines are lines that are 
defined by multiple control 
points. The graphic shows 
three basic types of splines. 
The simplest type of spline 
consists of a set of control 
points connected by 
straight lines, called a 
linear spline (shown on the 
near right). The other two 
splines are curved. You can curve a spline by adjusting its basis, or method used to 
compute the spline. Splines can be divided into interpolating and approximating.

An interpolating spline will always touch the points that define it. In the above graphic, 
the two splines on the left are interpolating. This gives them a more drastic skin-like bend 
than approximating splines. Approximating splines, such as the rightmost example in the 
above graphic, have a softer curve because they don’t necessarily touch the points that 
define them. Either type of spline requires three or more control points in order to show 
any curvature.pro-V Studio uses splines when calculating animations (see “Interpolation” 
on page 40 for more information).

THE PRO-V STUDIO STAGE

The pro-V Studio Stage is the virtual world in which you build your scenes. This world 
contains an origin and the three axes. Don’t confuse the Stage with the workspace, which 
is the term we use to describe the pro-V Studio interface as a whole (you affect objects on 
the Stage using the workspace).

The Scene Display window acts as the viewfinder for the currently selected camera. By 
looking through this viewfinder, you can see the Studio. Please see “Scene Display 
Window” on page 54 for more information about the Scene Display window.

N

AUTHORED BY ANTHONY HERNANDEZ - (415)786-2081 - anthony94122@outlook.com



35

PRO-V STUDIO BASICS

NORMALS

A surface normal is a line (vector) that points 
perpendicular to (away from) the surface it 
originates from. Since models have more than 
one surface, knowing which way the normals 
are facing can help you understand how a 
particular function will affect a model. This is 
important when rendering a model. If a model’s 
normals are inverted, your model may render 
incorrectly. pro-V Studio gives you some 
control over the direction of the normals and 
automatically performs these calculations for you (see “Importing 3D Objects (OBJ)” on 
page 72 for more information).

CAMERA

The camera is the vantage point or 
portal from which you view the 
studio and your scene. Once your 
scene is published, viewers will see 
the finished scene from the camera.

pro-V Studio includes two cameras:

The Edit camera is the one you use 
when building your scene. You can 
position, rotate, and zoom this 
camera any way you like to get the best views. pro-V Studio does not record the Edit 
camera’s movements, nor is this camera included in your published scene.

The Runtime camera is the camera that gets published with your scene and is the camera 
your viewers will use when viewing your scene. Like the Edit camera, you can position, 
rotate, and zoom this camera. pro-V Studio records the camera position for publication 
with your scene. You can also animate this camera to add interesting effects to your scene 
such as pan (pivoting to follow a passing race car) or follow (staying behind the car) shots.

NOTE
 THE SIMPLE ANIMATIONS PALETTE IS A GREAT WAY TO ANIMATE THE RUNTIME CAMERA.
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Chapter 6: Hierarchies
ow that you’ve learned about 3D objects, Cartesian coordinates, object space vs. 
world space, and object transformations, let’s go ahead and learn a little about 
hierarchical (sometimes called parent-child) relationships.

pro-V Studio allows you to group objects in a hierarchy 
in order to facilitate manipulation. The original object is 
known as a parent, and each object linked to it is known 
as a child. The graphic shows an example of a simple 
hierarchy. In this example, the trunk is the parent. The 
branch is a child of the trunk, the twig is a child of the 
branch, and the leaf is a child of the twig. Selecting and 
moving the trunk will also move the branch, twig, and 
leaf. Moving the branch does not affect the trunk but 
moves the twig and leaf, and moving the twig moves the 
leaf without affecting the branch or trunk. Selecting the 
leaf only moves the leaf. 

Let’s try another example: Bend your arm at the shoulder. Notice that your shoulder 
rotation moves your upper arm, lower arm, wrist, hand, and fingers. In this case, your 
upper arm is a child of your shoulder and so forth. Now try bending a finger. Your hand, 
wrist, arm, and shoulder do not move.

The concept applies in pro-V Studio. A child object will move as its parent moves. For 
example, if you parent a sphere to a cube, the sphere will maintain the same relative 
position to the cube no matter you translate or rotate it. You can, however, move the child 
object without affecting the parent. For example, you could create an animation with the 
sphere close to the cube, add a keyframe, move the sphere away from the cube, add 
another keyframe, and move the cube. The sphere will now move with the cube relative to 
its most recently keyframed position.

NOTE
 NOT ALL ATTRIBUTES PROPAGATE ACROSS HIERARCHIES. EXAMPLES INCLUDE VISIBILITY AND OPACITY.

pro-V Studio includes extensive support for hierarchies. You are allowed an almost 
unlimited number of hierarchical relationships in each scene. Create and rearrange 
hierarchies using a simple drag and drop interface. Please refer to “Hierarchy Viewer 
Window” on page 54 for more information.

N
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COLLAPSING OBJECTS

Collapsing an object removes the selected instance and any children (but not parents). 
Removing unneeded objects from the rendering hierarchy improves performance on end 
viewer computers due to decreased resources and rendering times. This option is good if 
the currently selected object and its children are not currently needed when the interactor 
is triggered
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Chapter 7: Animation
iewpoint Studio lets you animate virtually everything in your scene including 
objects, lights, materials, and the camera. Each scene object has different settings 
(attributes) that can also be animated. For example, you can animate an object’s 

scale, rotation, translation, and shape. You can animate any component of an object’s 
material and can simulate animating lights (pro-V Studio calculates shadows 
automatically). Plus, you can animate the camera’s position and rotation. Creating 
animations involves making changes to these parameters over time and assigning these 
changes to keyframes.

KEYFRAMING

Animations are made up of individual images known as frames. An animation is created 
when a series of frames that vary slightly from one frame to the next are displayed one 
after another over time.

Keyframing is the core of computer animation and involves the following general process: 
First, a starting frame is created on a timeline and all attributes for each object in the scene 
are assigned to that frame. Next, an ending frame is created later on the timeline and all 
changes to any attributes are assigned to this frame. pro-V Studio then compares the 
attributes assigned to the starting and ending frames and calculates all of the intermediate 
(tween) frames that occur between the starting and ending frames. This calculation is 
called interpolation and is enabled when you check the Tween box for your selected 
timeline in the Animation room as described in “Animation Details Window” on 
page 158.

For example, if you tell pro-V Studio that a ball is large and red at the beginning of the 
animation then small and blue 10 seconds later, then 0 and 10 seconds become the 
keyframes for that object. pro-V Studio then calculates the intermediate values for all of 
the frames in between the keyframes. Thus, as the animation moves from 0 to 10 seconds, 
the large red ball will gradually shrink and turn blue with each passing frame until it 
reaches the values you set for it at the 10 second keyframe. In this example, the ball will 
probably be medium and purple 5 seconds into the animation. Keyframing and 
interpolation allow you to create complex animations with a minimum amount of work.

The overall animation sequence is called a timeline. Most 3D applications use a single 
timeline that contains the keyframes for the entire animation. For example, if you have a 
10-second animation running at a speed (or frame rate) of 30 frames per second, your 
timeline is 300 frames long (frame rate * running time). All keyframes must reside on that 
one timeline.

V
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pro-V Studio handles this a little differently. As you noticed above, keyframes are created 
at specific times instead of at specific frames. pro-V Studio scales its performance to each 
unique combination of bandwidth and performance and therefore cannot guarantee a 
single frame rate in all cases. Thus, three different users with different computers and 
Internet connections might see three different frame rates, since higher frame rates require 
more resources and vice-versa.

For this reason, pro-V Studio uses multiple timelines, one for each animated object/
property combination in a scene. When setting up keyframes, you do it by time instead of 
frame number. Thus, instead of specifying that Frame 250 is a keyframe for a particular 
object, you would specify (for example) “Position A at 0:05 and Position B at 0:08”. At 
worst, viewers may see choppy movement, however the objects will still be at their 
keyframed position on time. This feature provides the ultimate in flexibility for both the 
content creator and the widest possible range of viewers.

pro-V Studio supports two kinds of timelines:

Normal timelines begin when the animator that contains them is triggered. You can 
disable timeline processing for each timeline. If you need to trigger animations 
separately, place each such timeline into separate animators. You can also contain 
normal timelines in animators that are set to begin playing when the scene loads (auto 
start). In this case, the normal timeline can behave similarly to an action timeline.

Action timelines are a very powerful way to add more interaction. For example, if you 
are creating a game, you could have several seconds elapse after a character enters a 
room before a door closes. Several seconds later, a sound plays. Action timelines have 
action keyframes, which function very similarly to Multi reactors (see “Multi 
Reactors” on page 119 and “Action Timelines” on page 163 for more information). 
Each animator can contain one action timeline.

ANIMATION HIERARCHY

pro-V Studio uses a hierarchical animation system that gives 
you full control over animations within a scene. At its most 
basic, this hierarchy appears as shown in the image.

As you can see in the above image:

The root animator is the master container for each 
scene’s entire animation hierarchy. It cannot be 
modified.

You can insert an arbitrary number of animators in your 
scene. Each animator can be a child of either the root animator or another animator. 
Note that it is possible to import other types of animators in existing scenes. These 
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imported animators may not be editable within pro-V Studio but will be published with 
the rest of your scene.

Each animator can contain one or more timelines (but only one action timeline).

Every timeline controls one target/property combination. A target is the object being 
controlled by the timeline, such as a sphere. A property is some attribute of the target 
object, such as its location in 3D space (translation) or rotation.

Each timeline can contain an arbitrary number of keyframes.

Please refer to “Creating Simple Animations” on page 112 for more information on 
creating/editing animations within pro-V Studio.

As mentioned above, pro-V Studio’s hierarchical animation system gives you full control 
over your scene. You can only have one identical timeline per animator. For example, say 
you want clicking one button to move a sphere up. Clicking another button moves the 
sphere laterally. Each of these motions requires its own timeline, and each of these 
timelines controls the same target object (sphere) and property (translation). In this case, 
you would need to place each timeline in a separate animator.

INTERPOLATION

pro-V Studio uses splines (see “Splines” on page 34) to interpolate between keyframes. 
Please see “Keyframing” on page 38 for a discussion about keyframed animations. 
Different spline types produce different results. pro-V Studio supports the following spline 
types:

Constant: This has no intermediate poses. If you set a 
change a property’s value over time using different 
keyframes, the first value will be maintained until the 
second keyframe, at which point it will instantly change to 
the second value, which will be maintained until the third 
keyframe, and so on.

NOTE
 CONSTANT OR “STEP” INTERPOLATION IS NOT DIRECTLY SUPPORTED IN PRO-V STUDIO. YOU CAN ACHIEVE 
THE SAME EFFECT BY DISABLING TWEEN FRAME GENERATION.
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Linear: Takes the two keyframes and divides the motion 
between them equally with no acceleration or deceleration 
of the moving objects. In the above example, the arm 
would move at a constant velocity from keyframe to 
keyframe. If you created a third keyframe with the arm 
back down, the change direction at the second keyframe 
would be abrupt.

Catmull-Rom: Places tween frames on a curve. Motion 
begins at one keyframe, accelerates to full velocity, and 
gradually slows down as it approaches the next 
keyframe. For example, if the first keyframe has an arm 
by a figure’s side and the second one has it raised, the 
arm will begin moving slowly, accelerate to a constant velocity, and slow as it reaches 
the second keyframe. This is not to say that the movement will be fast; actual speed of 
motion depends on the amount of change between keyframes and the number of tween 
frames. In our above example, having the second keyframe 1 second from the first 
would make a very rapid motion, while having 10 seconds between keyframes would 
make a very slow motion. The key thing to remember is that this type of animation 
resembles a smooth curve and is normally the most realistic.

TCB spline: A TCB spline is similar to the Catmull-Rom 
spline discussed above. However, this type of spline 
remains tangential to its control points as shown to the 
right. By comparing this image with the one for the TCB 
spline, you can see how these interpolation methods are 
both similar to and different. TCB splines are useful for, 
among other things, simulating bouncing objects.

Smooth Rotation: Rotation interpolation is only used when rotating an object. Smooth 
rotation is akin to linear interpolation. Rotation starts and stops abruptly with no 
acceleration or deceleration.

Catmull-Rom Spline Rotation: Rotation will accelerate and decelerate smoothly to and 
from the keyframed values.

TCB Spline Rotation: Rotation will accelerate and decelerate smoothly, but will “lag” 
behind the keyframed values. For example, if you specify a rotation to the left 
followed by one to the right in the same timeline, the rotation will continue to the left 
for a little ways beyond the left-most keyframe before moving back in the opposite 
direction.

Please refer to “Key Frame Settings Window” on page 162 for more information about 
selecting interpolation methods.
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Chapter 8: Materials & Lights
his section describes how pro-V Studio handles object materials and scene 
lighting. pro-V Studio includes powerful materials and lighting support that give 
you great flexibility when working with your scenes.

MATERIALS

Look at any object. A material can consist of many things, including:

Color

Texture map (or diffuse texture)

Bump map

Alpha (Transparency) map (or alpha channel)

Light map

Let’s discuss these in a little more detail.

COLOR

pro-V Studio lets you specify an object’s color. Please refer to “Material Tab” on page 149 
for more information on selecting a color.

MAPS

Look at your own skin. Notice the differing colors, hairs, veins, 
moles, and other features. Look at any object. Is it smooth or 
rough? Opaque or transparent? If transparent, does it have the 
same transparency all over or in portions? Is it matte or glossy? 
Is it reflective? What sort of texture or pattern does it have? 
Now look at the objects around you. They all have different 
material properties. How can you capture these properties in 
your 3D objects? One answer is mapping. Each object in your 
pro-V Studio scene can have its own map, which provides an 
efficient way to add advanced effects to your objects. For 
example, if you had to model every detail, your object’s 
polygon count (number of polygons) would quickly become 
prohibitive. In fact, most of the 3D figures and other objects you see in feature films have 
relatively low polygon counts and make extensive use of mapping. Here’s an example of a 
shirt along with its texture map.

T
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As you can see, the texture map looks like the shirt was cut down the middle and laid out 
on a flat sheet. It also looks like the artist who created this texture map “colored outside 
the lines”. How can this possibly produce a smooth texture? The answer lies in something 
called U/V coordinates. The best way to explain U/V coordinates is to think of a map with 
latitude and longitude lines. Each coordinate on the flat map corresponds to a point on the 
round Earth. For example, 37o37’08”N/122o22’29”W corresponds to San Francisco 
International Airport. U/V coordinates have values between 0,0 and 1,1, with 0,0 being the 
upper left corner of the map and 1,1 being the bottom right corner. Thus, 0.5,0.5 is in the 
exact center of the map.

When the artist created the original shirt object, s/he assigned a UV coordinate value to 
each point on the shirt and created the texture map in such a way that the buttons, cuffs, 
underarms, etc. corresponded to the correct locations on the 3D geometry. The act of 
assigning 2D coordinates to locations on a 3D object is where the term map comes from.

Why did the artist color outside the lines and why don’t the excess textures and colors 
appear on the 3D shirt? The 3D object only uses a portion of the U/V coordinates. Any 
color placed in an area where the U/V coordinates aren’t mapped to the 3D object will not 
appear on the object. For example, if you drew a large red X on the lower right corner of 
the texture map, that X would not appear unless portions of it extended into the used 
portions of the texture map. If that happened, you’d only see those portions of the X that 
are within used portions of the U/V map.

Most of the content you obtain for use with pro-V Studio will 
already have U/V coordinates and all the maps you need. If 
you create your own content, you’ll need to create maps and 
edit them to get your desired results. Please refer to your 3D 
modeling application’s documentation for more information 
about creating U/V coordinates for any content you create. To edit the maps, use your 
favorite graphic editing software (such as Adobe Photoshop).

Whether your object has U/V coordinates or not, you can still apply an image to an object. 
In this case, however, you will get some unexpected results, as shown. You can apply 
textures to non-U/V-mapped 2D objects and 3D primitives. All other non-U/V-mapped 3D 
objects will display a warning when you attempt to texture them.

The important things to remember are that:

Maps are 2D representations (images) of 3D surfaces.

Each coordinate (location) on the 3D surface corresponds to a location on the map.

The map may or may not resemble the 3D surface
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pro-V Studio supports four types of maps:

Texture Maps

From the above examples, you can see that texture maps can provide detailed color 
information and ensure that the colors/details appear in the correct location.

Bump Maps

A bump map is used to simulate roughness 
on a surface. Bump maps are grayscale 
images where dark gray/black signifies 
lower areas and bright white/light gray 
areas signify higher areas. They work by 
shifting the object’s normals to give the 
illusion of depth. On a human figure, a 
bump map allows you to simulate wrinkles 
and other imperfections/textures. Unlike 
displacement maps, bump maps do not 
alter an object’s actual geometry. Thus, a 
rough-looking object will appear smooth 
around the edges. Viewpoint does not 
currently support displacement maps.

Alpha Channel (Transparency Maps)

Many 3D applications use the term transparency map to describe what pro-V Studio and 
many photographic applications call an alpha channel. Used in this context, both terms 
mean the same thing.

An alpha channel map is like a bump map in that it is a grayscale image, however it 
regulates the amount of opacity in a given location. The darker the color is, the greater the 
transparency, and vice versa. Here’s a sample transparency map for eyelashes.

Look at the bump map above. The lighter colored areas around the eyelashes indicate that 
they should have height, that is, they should stand out from the figure itself. The alpha 
channel map allows only those portions of the texture map corresponding to the lighter 
areas to show through. Combined with the texture map, the end result is eyelashes that 
stick out from the eyes. Where there are no eyelashes, you can see the skin beneath them. 
This is a great example of how combining maps can create very realistic effects.
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Light Maps

pro-V Studio uses light maps to determine how 3D objects in a scene are lit. This is 
different from most 3D applications, which allow you to create and position individual 
lights. If you wish, you can load a map to specify how a scene or object is lit. If you load 
both scene and object light map, all object lightmaps will override the scene light map (in 
fact, all pro-V Studio object settings will override their corresponding scene settings). All 
objects without light maps will be lit using the scene map. Please refer to “Lightmap 
Settings” on page 82 for information on creating scene lightmaps and to “Light Map 
Palette” on page 156 for information on applying light maps to individual objects.

To ease the transition between creating lights and light maps, pro-V Studio allows you to 
create/edit light maps using a simple and intuitive light creation interface. Please refer to 
“Procedural Lightmaps” on page 82 for more information.

MATERIAL GROUPS

Imported assets can have one or more material groups. For example, say you export a 
figure from Curious Labs Poser and bring that figure into pro-V Studio. The figure itself is 
a single mesh object, as shown in the image. You can see several body parts in these 
images, including the head, eyeballs, neck, shoulders, chest, and abdomen.

Each polygon in the figure “belongs” to both a material group and a body part group. This 
makes the following group combinations possible:

One body part may have one material assigned to it. For 
example, the neck has the “skin” material.

Two or more body parts may use the same material. For 
example, the head, neck, and portions of the chest and 
shoulders may all use the “skin” material.

One body part may use more than one material. For 
example, each eyeball may have separate materials for the 
eyeball, iris, and pupil.

In this example, the head, neck, and portions of the chest use 
the skin material. The chest and collars use the shirt material. 
The eyes use eyeball, pupil, and iris materials. The head uses 
several materials including skin, lips, and eyebrows.

This brief example demonstrates that a single mesh object can 
have more than one material group. pro-V Studio maintains 
all material groups when importing assets, and each material 
group can have its own image maps, color, etc. Materials 
assigned to the currently selected asset appear on the bottom 
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of the Hierarchy Viewer window when in the Materials room. Please see “Hierarchy 
Viewer Window” on page 54 for more information about the Hierarchy Viewer window 
and “Materials Room” on page 57 for more information about the Materials room.
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Chapter 9: Interactions
iewpoint’s real power lies in its ability to add simple or complex interactions to 
scenes. Want to add a simple reaction to a mouse click? Build a complete 3D 
experience such as a game or virtual reality setting complete with complex 

interactions (such as puzzle solving, walkthroughs, etc.)? pro-V Studio makes it fast and 
easy!

pro-V Studio supports four types of interaction components. An interaction component is 
something that allows an interaction to occur. It will affect the selected target object(s) and 
any children (see “Hierarchies” on page 36 for an explanation of hierarchical 
relationships). In general, an interaction component alters the values of one or more of the 
target object’s attributes. An object’s attributes include details such as position, scale, 
color, transparency, etc. In short, interaction components alter the target in some manner. 
This change is permanent. For example, if an interaction component moves an object to 
the left, that object will remain there until another interactor changes that new position.

Viewpoint itself does not support interactors beyond the “native VET components” (see 
“Native VET Components” on page 48). pro-V Studio adds a list of custom interactors 
and seamlessly translates your specified settings into their Viewpoint equivalents. This 
saves you time when developing scenes since pro-V Studio does the translation and 
programming for you behind the scenes and allows you to take Viewpoint’s powerful 
features to completely new heights, all with the absolute minimum effort.

Some interaction components change an object’s state. For example, if one reactor causes 
an object to move up, that object is in a new state, meaning that some of its attributes have 
been changed. To return to the previous state or proceed to a third state, you would have to 
add a second reactor. Alternatively, you could assign a behavior that both changes object 
states and has internal states (see below). Behaviors can also have states, which must not 
be confused with object states.

You can apply the four types of interaction components to your scenes as easily as 
dragging and dropping them onto your desired object from the Interaction palette. Please 
see “Interaction Palette” on page 56 for more information about the Interaction palette.

V
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REACTORS

Reactors are the simplest type of interaction: A triggering event occurs, and the reactor 
reacts. Depending on your settings, the reaction could be anything from animating the 
object to triggering other events. Please refer to “Reactors” on page 114 for more 
information about working with reactors.

BEHAVIORS

At their simplest, behaviors act as containers for other interaction components. Behaviors 
have initial (starting) states, which can be altered by reactors or other interactions 
contained within the behavior. Each state holds one or more reactors. When the behavior 
is in a given state, all of the interactors contained within that state are active and all other 
interactors within the same behavior are disabled. Changing states activates the interactors 
assigned to the new state and disables the interactors assigned to the previous state. Please 
refer to “About Behaviors” on page 167 for more information about working with 
behaviors.

NATIVE VET COMPONENTS

The native VET components are those directly supported by Viewpoint. Please refer to 
“Native VET Components” on page 120 for more information about working with native 
VET components.

MODIFIERS

Modifiers add a special level of interactivity to a scene or object by allowing you to add 
text or image hotspots to objects, zoom your scene beyond its window, and/or add sound 
to your scenes. You can enable or disable modifiers at will. Please refer to “Modifiers” on 
page 48 for more information about using modifiers.
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Chapter 10: Common UI Elements
his chapter discusses the basic user interface (UI) elements common to pro-V 
Studio. For consistency, each of these common elements functions identically 
throughout the application.

COMMON ELEMENTS

The common UI elements found in pro-V Studio are:

ROOMS

As discussed in “The pro-V Studio Process” on page 20, creating a finished scene involves 
several steps laid out in a logical order to provide you with full control while minimizing 
the work required to generate great-looking results. Placing all of this functionality in a 
single location would clutter the workspace and make pro-V Studio much harder to use. 
For this reason, pro-V Studio contains separate workspaces called rooms that make the 
workflow obvious and present only those interface elements (windows, etc.) necessary for 
that step of the process.

To switch between rooms, you may either click the room tabs as shown above and 
described in “Room Tabs” on page 53, or use the Menu bar as described in “The View 
Menu” on page 94.

MENUS

As in most restaurants, pro-V Studio menus provide a fixed list of 
choices grouped into a logical order. Menus may be hierarchical, 
meaning that a menu might have a sub-menu. This is most evident in 
areas like the pro-V Studio Menu bar, where (or example), selecting 
File>Import opens the Import sub-menu.

TABS

Tabs allow you to switch between areas within a window or within the 
pro-V Studio application itself (Room tabs).

T
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DIALS

Dials allow you to alter values by “scrubbing”, i.e. clicking and 
dragging your mouse. pro-V Studio dials also have fields, allowing 
you to make precise changes.

FIELDS

Fields allow you enter textual information directly 
by typing.

NOTE
ASSET NAMES (TEXTURES, MATERIALS, ANIMATORS, INTERACTION COMPONENTS, ETC.) MUST BE ENTERED 
USING 7-BIT ASCII (PLAIN) TEXT. THE FIRST CHARACTER CANNOT NOT BE A SPACE OR A DIGIT. IN ADDITION, 
YOU CANNOT USE COLONS (:), BACKSLASHES (\),OR AMPERSANDS (&). YOU WILL RECEIVE AN ERROR MESSAGE 
IF YOU ENTER AN UNSUPPORTED NAME.

SLIDERS

Sliders are similar to dials, except that they may 
used to “scrub” between several preset options or 
values. Like dials, sliders also have fields, allowing 
you to make precise changes.

CHECKBOXES/RADIO BUTTONS

Both checkboxes and radio buttons allow you to toggle 
options on and off. A checkmark in a checkbox or a dot in a 
radio button signify that the specified option is enabled, 
and vice-versa. Typically, checkboxes are used when you 
may select multiple options (A and B), while radio buttons allow you to select one option 
or another but not both (A or B).

BUTTONS

Buttons perform their specified function when clicked. For example, 
clicking a button labeled OK accepts your current choice or launches 
your specified function and is typically the equivalent of pressing 
[ENTER].

AVAILABLE OPTIONS

This manual describes all options available in all areas of the pro-V Studio interface. 
Some options may be enabled or disabled depending on the currently selected object. 
Disabled options will appear “grayed out” and will not be functional.
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Chapter 11: pro-V Studio Rooms
iewpoint Studio consists of seven separate workspaces, called rooms. This chapter 
provides some basic information about each room and cross-references more 
detailed information found later in this Reference Manual.

SCENE SETUP

The Scene Setup room is the core of the pro-V Studio application. This is where you 
assemble your scene, add content, work with your scene hierarchy, and add interactivity. 
The Scene Setup room appears as follows:

In addition to rooms, pro-V Studio uses floating palettes and windows. Much of its 
functionality is available within floating palettes and windows within the room itself. pro-
V Studio rooms allow you to customize the workspace by hiding/displaying and relocating 
controls anywhere you like.

The numbers on the image above identify the controls available in the Scene Setup room:

Menu bar (1)

Room tabs (2)

Hierarchy Viewer palette (3)

V
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Scene Display window (4)

Media palette (5)

Play Controls palette (6)

Interaction palette (7)

Object Settings palette (8)

Simple Animations palette (9)

Please refer to “Preferences” on page 76 for more information about creating and saving 
custom workspace layouts. The following sections provide a brief description of the 
labeled interface elements and references to more detailed information.

MENU BAR

The Menu Bar consists of a series of pull-down menus used for accessing pro-V Studio 
functionality. Some menus and/or submenus duplicate other on-screen interface elements. 
The Menu Bar appears as follows and is available from every pro-V Studio room:

Please refer to “The pro-V Studio Menu Bar” on page 69 for complete descriptions of all 
Menu Bar pull-down menus and sub-menus.

ROOM TABS

The Room tabs allow you to switch from room to room within pro-V Studio. To enter a 
room, simply click its tab. Please see “Tabs” on page 50 for an image of the Room tabs.
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HIERARCHY VIEWER WINDOW

The Hierarchy Viewer window allows you to view and manipulate your scene’s 
hierarchies, including objects, animators, timelines, and interaction elements.

Please refer to “The Hierarchy Viewer Window” on page 106 for a complete description 
of the Hierarchy Viewer palette.

SCENE DISPLAY WINDOW

The Scene Display window is your 
viewport into the pro-V Studio where you 
view and arrange your scene. Each view of 
the Document window is taken through a 
virtual camera, which means you can view 
each scene from two angles (either the 
Runtime or Edit camera).

You can position cameras to view your 
scene from any angle or distance. In 
addition, the Scene Display window has 
numerous controls around its edges that 
you use to change the appearance of scene 
elements. You can also select objects 
within your scene by clicking them directly 
within the Scene Display window.

Please refer to “The Scene Display Window” on page 100 for a complete description of 
the Scene Display window.
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MEDIA PALETTE

The Media palette is where you add content instances to your scene from the pro-V Studio 
library, project library, or assorted primitive objects.

Please refer to “The Media Palette” on page 108 for a complete description of the Media 
palette.

SIMPLE ANIMATIONS PALETTE

The Simple Animations palette allows you to quickly and easily add animations to scene 
objects and is particularly useful for animating the Runtime camera.
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Please refer to “The Simple Animations Palette” on page 110 for a complete description of 
the Simple Animations palette.

INTERACTION PALETTE

The Interaction palette stores all of the interaction 
components for inclusion in your scene.

Please refer to “The Interaction Palette” on page 114 
for a complete description of the Interaction 
palette.

OBJECT ATTRIBUTES PALETTE

The Object Attributes palette allows you to control 
an object’s attributes such s translation, rotation, 
scale, shear, and zoom.

Please refer to “Object Attributes Palette” on page 141 for a complete description of the 
Object Attributes palette.
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MATERIALS ROOM

The Materials room is where you apply textures and bump, light, and alpha maps to your 
scene objects and apply additional material settings to control how your scene will appear 
when published. You can achieve amazingly realistic results in your Viewpoint 
presentations by carefully adjusting object material settings.

Please refer to “The Materials Room” on page 148 for more information about the 
Materials room.
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ANIMATION ROOM

The Animations room provides detailed animation controls allowing you to create, edit, 
and delete animators and timelines.

Please refer to “The Animation Room” on page 158 for more information about the 
Animation room.
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INTERACTION ROOM

The Interaction room is where you work with behaviors in your scene. You can use either 
the Interaction or Scene Setup room to work with the other interaction component types. 
pro-V Studio lets you use your imagination to create rich interactive Viewpoint content.

Please refer to “The Interaction Room” on page 167 for more information about the 
Interaction room.
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WEB INTEGRATION ROOM

The Web Integration room is where you insert your scenes into pre-made HTML 
templates or into your own page to preview the published results and add the HTML code 
necessary to host your Viewpoint presentation (published scene) in your Web page.

Please refer to “The Web Integration Room” on page 170 for more information about the 
Web Integration room.
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PUBLISH ROOM

The Publish room is where pro-V Studio outputs your scene and (if specified) 
accompanying HTML code to the Viewpoint Experience Technology (VET) format, ready 
for publication to your Web site, where viewers will be able to see/interact with your 
scene.

Please refer to “The Publish Room” on page 172 for more information about the Publish 
room.
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CONTENT ROOM

Much of pro-V Studio’s value comes from the capability to add custom content (such as 
figures, textures, props, hair, poses, etc.) to the libraries. Whether you create your own 
add-ons or purchase some of the rich variety of available content, you will find your 
artistic abilities and range growing with every new addition.

pro-V Studio includes the Content room gateway to the online Content Paradise portal, 
where you can obtain free or purchased content. To complement this feature, pro-V Studio 
can auto-detect and attempt to install your add-on content for you. Simply choose your 
content, download it, and pro-V Studio does the rest!

Please refer to “The Content Room” on page 177 for more information about the Content 
room.

AUTHORED BY ANTHONY HERNANDEZ - (415)786-2081 - anthony94122@outlook.com



PART 4

Your First pro-V
Studio Projects

AUTHORED BY ANTHONY HERNANDEZ - (415)786-2081 - anthony94122@outlook.com



64 

 PRO-V STUDIO REFERENCE MANUAL

Chapter 12: Let’s Create a Project
his chapter guides you through creating two pro-V Studio projects. You’ll add 
objects, edit materials, and add interaction. When you’re finished, you’ll publish 
your work and launch your Web browser to see the results.

PROJECT 1: DROPPING A BALL

For your first tutorial, you will insert a sphere into a scene and make it drop when clicked.

1 Launch pro-V Studio and select New to create a new project. Select your desired 
project name and hard drive folder using the Create a New pro-V Studio Project 
window. pro-V Studio will open to the Scene Setup room.

2 Select the Media palette’s Primitives tab and select the Sphere asset. Click and drag it 
into the Scene Display window to create an instance of the soccer ball in your scene.

3 In the Object Attributes palette, set the Translate Y attribute to 3. This should raise 
the sphere above the ground plane without lifting it completely out of sight. If the 
sphere disappears, reduce the attribute’s value until you can see the its bottom edge.

4 Create a new animator by selecting Animator>New Animator. Next, select the 
Animators tab in the Hierarchy Viewer palette to enable the Simple Animations 
palette.

5 Click the film symbol on the right side of the Simple Animations palette to open the 
Property Selection dialog. Select the sphere on the left side of this dialog. A list of 
animatable properties for that object appears on the right. Select the loc_ property and 
click OK.

6 Enter 4 seconds in the Duration fields, then click the + button to add an initial 
keyframe.

7 Disable the animator’s Auto Run  feature, as described in “Animation Details 
Window” on page 158.

8 Move the time scrubber at the bottom of the Simple Animation palette to a new 
position such as 2 seconds. In this example, the slider will be in the middle of its run 
and you will see 2.0 seconds displayed in the Current Time fields.

9 Move the sphere down (change the Translate Y attribute to 2), then add a new 
keyframe by clicking the + button.

10 Drag the time control all the way to 4 seconds. Change the Translate Y attribute to 0 
and add a third keyframe by clicking the + button. Preview your new animation by 

T
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clicking the Play button in the Simple Animations palette. The sphere will fall, 
accelerating as it goes.

11 Drag the timeline back to 0 and watch the sphere climb back to its original position. 
Now switch to the Interaction room, select a Simple Reactor in the Interaction 
palette, and drag it onto the sphere. This opens a Simple Reactor dialog.

12 Select the following attributes using the appropriate pull-down menus in the Simple 
Reactor dialog. Click OK when finished:

Incoming Message: Mouse Left Down
Action: Start Animation
Action Target: <target>

13 Using the Play Controls palette, click the Play from start button. Next, click the 
sphere and watch it drop to the floor.

14 Switch to the Web Integration room, click the New Page from Template button, and 
select generic.html. This creates a blank Web page with your scene in it. Next, click 
the Preview in Browser button to launch your Web browser with your project in the 
Web page you just created.

15 Return to pro-V Studio and switch to the Publish room. Save your project by selecting 
File>Save. In the Publish dialog, check both the Write MTX and Write HTML 
checkboxes, set the Bitmap quality slider to 75, check the Use TrixelsNT checkbox, 
and click Publish.

Congratulations! In just a few minutes, you’ve created and published an animated 
Viewpoint presentation with a simple interaction. Let’s move on to something a little more 
challenging.

PROJECT TWO: MORE ANIMATION

This tutorial continues the basic animations you learned above and provides another 
lesson in tying animators to reactors. You will practice animating different scene 
properties and how to trigger these animations using simple reactors. Please decide what 
object/property combination you want to animate before you start. Please see “Animation” 
on page 38 for more information about animation in pro-V Studio and “Interactions” on 
page 47 for more information about interaction components.

1 Launch pro-V Studio and open an existing project or create a new one.

2 Add a 3D object to your scene (use a primitive for fastest results).

3 Select Animator>New Animator. In the Hierarchy Viewer window, click the 
Animators tab and select your new animator.
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4 In the Scene Setup room, click the Add Timeline button in the Simple 
Animations palette (see “The Simple Animations Palette” on page 110 for more 
information). This opens the Property Selection dialog. Select the object to animate 
on the left side of this window. A list of animatable properties appears on the right. 
Check your desired property and click OK. For a 3D object, try the following 
properties: rot_ (rotation), scl_ (scale), or opac (opacity). Repeat as many times as 
necessary.

5 Switch to the Animation room. The Animation Details window displays the 
timelines you created in the preceding step. Rename these timelines so that you know 
which animation you are currently working on. Click a timeline to highlight its default 
name. Click a second time to open a field allowing you to enter your desired timeline 
name. Enter your desired name and press [ENTER] when done.

6 Select the Scale tool in the Scene Display window (see “Scale” on page 105) and scale 
your object. In the Animation Details window, select the Scale timeline and click the 
Add Keyframe button. Be sure to set the desired scale before creating a keyframe. 
Enter a new time in the Current Time field, re-scale your object, and add a new 
keyframe. Repeat as often as desired. Repeat this step for the other two properties. Use 
the Play Controls palette (see “The Play Controls Palette” on page 140) to play your 
animations.

7 To animate materials, you must select a material property, then enter the room in 
question (such as the Material Room to change opacity). Change the values as 
needed, then return to the Animation room to set the keyframe as described above. 
Repeat these steps for all keyframes.

8 Now let’s add some interactivity. We’ll start the animation with a left-click and stop it 
with a right-click. In the Scene Setup room, select the Objects tab in the Hierarchy 
Viewer window. Drag and drop a Simple reactor from the Interactions palette (see 
“Simple Reactors” on page 115) and drop it onto your desired object in the Hierarchy 
Viewer window. When that object is selected, you will see its reactor at the bottom of 
the Hierarchy Viewer window.

9 Double-click the reactor in the Hierarchy Viewer window to open a Simple Reactor 
window and modify the reactor’s properties. Enter the following information:

a Name: Enter a name for this reactor in the Name field.

b Incoming Message: Select MouseLeftClick using the Incoming Message pull-
down menu.

c Select Trigger Animation using the Action pull-down menu.

d Select your desired animator using the Action Target pull-down menu.

10 Click OK to exit the Simple Reactor window.
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11 Repeat Steps 8-10 to add a second Simple Reactor. In this reactor, select 
MouseRightClick using the Incoming Message pull-down, Stop Animation using 
the Action pull-down menu, and your desired animator in the Action Target pull-
down menu.

12 Test your animation using the Play Controls window and publish your scene as 
described in “The Publish Room” on page 172.

KEYFRAMING ROTATIONS

When animating rotations, you should enter new keyframe settings numerically using the 
Keyframe Settings window. Be sure to use the same syntax shown in the Data field. Your 
numeric values will automatically be applied to the selected keyframe.

MORE PROJECTS & TUTORIALS

Want to try your hand at other sample projects? Need a tutorial? Select Help>Tutorials to 
open the Curious Labs pro-V Studio Tutorials page. We’ll be updating it over time, so be 
sure to visit regularly.
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Chapter 13: The File Menu
s the name implies, the File menu is where you work with your pro-V Studio 
project files. Remember that everything in pro-V Studio revolves around a 
project. Whenever you work in pro-V Studio, you are working on a project.

NEW PROJECT

Selecting File>New Project or pressing [CTRL]+[N] creates a new project file tree on 
your hard drive. You may specify both the name and location for your new project. You 
will be prompted to save any unsaved changes in your current project.

OPEN PROJECT

Selecting File>Open Project or pressing [CTRL]+[O] opens an existing project. You will 
be prompted to save any unsaved changes in your current project.

SAVE

Selecting File>Save or pressing [CTRL]+[S] saves your current project to your hard 
drive. Curious Labs strongly recommends that you regularly save your work in case of 
problems.

SAVE AS

Selecting File>Save As or pressing [CTRL]+[SHIFT]+[S] saves your current project 
under a different filename. You will then continue working in your new project. Your 
previous project is retained in the same state as when you last saved it.

REVERT

Selecting File>Revert reverts your current project to its most recently saved state. You 
will lose all changes made to this project since your last save. use this option with caution.

IMPORT

Selecting File>Import allows you to import a wide variety of content to your pro-V 
Studio or project library for use in projects and scenes. When importing, you may select 
the following options:

A
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Single File: Selecting Single File or pressing [CTRL]+[M] opens a standard 
Open dialog, allowing you to import a single file into either the pro-V Studio or 
project library.

Multiple Files: Selecting Multiple Files or pressing [CTRL]+[SHIFT]+[M] opens a 
standard Open dialog, allowing you to select multiple files for import into either the 
pro-V Studio or project library. To select multiple files, press [CTR:L] while clicking 
your selections.

Entire Folder: Selecting Entire Folder or pressing [CTRL]+[ALT]+[M] opens a 
standard Browse for Folder dialog, allowing you to import all supported files within a 
given folder into either the pro-V Studio or project library. Content in sub-folders is 
not imported.

THE IMPORT SETTINGS DIALOG

The Import Settings dialog 
appears after you have selected 
the file(s) to import.

This dialog appears once for each 
file you import. This dialog 
contains the following standard 
options:

Import Location: Use the 
Import Location pull-down 
menu to select Project Assets 
or Library to import the 
content file(s) into the project 
or pro-V Studio libraries, 
respectively.

Default: Clicking Default 
selects pro-V Studio default 
options for the content type 
being imported.

Cancel: Clicking Cancel aborts the current import.

OK: Clicking OK proceeds to import the selected file(s) with the selected options.

Apply To All: Checking the Apply To All checkbox makes the Import Options dialog 
appear for each file being imported. Clearing this checkbox imports the remaining files 
(of the same type) with the same settings and hides the Import Options dialog.
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Apply To All: When importing multiple files, checking the Apply to all checkbox 
applies the current settings to all remaining files being imported. The Import Options 
dialog appears for subsequent files, allowing you to modify your specified settings on 
a per-file basis.

In addition, custom options will appear depending on the type of file(s) being imported. 
These custom options are:

Importing Images

The following option is available when importing images:

Power of 2: Checking the Power of 2 checkbox resizes the image so that its height and 
width in pixels are a power of 2 (2, 4, 8, 16, 32, etc.). This option will rescale 
arbitrarily sized images to the closest fit if selected.

pro-V Studio can import images in most popular formats. Imported images are 
automatically converted to JPG or PNG format based on your selected pro-V Studio 
preferences. See “Preferences” on page 76 for more information.

Importing 3D Objects (OBJ)

The following options are available when importing 3D (OBJ) objects:

Scale to unit cube: Checking the Scale to unit cube checkbox rescales the imported 
OBJ object to fit within the default pro-V Studio bounding box, which is a cube equal 
to 1 Viewpoint unit with coordinates ranging from {0,0,0} to {1,1,1}. The imported 
object retains its proportions. If this checkbox is cleared and the object exceeds the 
default bounding box, the box will scale appropriately to fit the imported object.

Scale Percentage: Entering a value in the Scale Percentage field scales the imported 
object to the selected percentage of its original size. For example, entering 50 imports 
the object at half of its original size. You should only use this option when you are sure 
of the imported object’s size relative to your scene. Otherwise, use the Scale to unit 
cube option, above.

Drop to Floor: Checking the Drop to Floor checkbox places the imported object’s 
lower edge on the scene’s ground plane.

Flip Normals: Checking the Flip Normals checkbox reverses the imported object’s 
normals.
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Importing 3D Objects (ASE or NFF)

The following options are available when importing 3D (ASE or NFF) objects:

Scale to unit cube: Checking the Scale to unit cube checkbox rescales the imported 
OBJ object to fit within the default pro-V Studio bounding box, which is a cube equal 
to 1 Viewpoint unit with coordinates ranging from {0,0,0} to {1,1,1}. The imported 
object retains its proportions. If this checkbox is cleared and the object exceeds the 
default bounding box, the box will scale appropriately to fit the imported object.

Scale Percentage: Entering a value in the Scale Percentage field scales the imported 
object to the selected percentage of its original size. For example, entering 50 imports 
the object at half of its original size. You should only use this option when you are sure 
of the imported object’s size relative to your scene. Otherwise, use the Scale to unit 
cube option, above.

Drop to Floor: Checking the Drop to Floor checkbox places the imported object’s 
lower edge on the scene’s ground plane.

Importing Movies (Quicktime)

You must convert movies into Macromedia Flash (SWF) animations using the Viewpoint 
QuickTime Conversion Template availble from http://developer.viewpoint.com prior to 
importing them to pro-V Studio.

Importing SWF Animations

SWF animations are imported using the default import options described above.

Importing Viewpoint Scenes (MTX)

The following options are available when importing Viewpoint scenes:

Scale to unit cube: Checking the Scale to unit cube checkbox rescales the imported 
OBJ object to fit within the default pro-V Studio bounding box, which is a cube equal 
to 1 Viewpoint unit with coordinates ranging from {0,0,0} to {1,1,1}. The imported 
object retains its proportions. If this checkbox is cleared and the object exceeds the 
default bounding box, the box will scale appropriately to fit the imported object.

Scale Percentage: Entering a value in the Scale Percentage field scales the imported 
object to the selected percentage of its original size. For example, entering 50 imports 
the object at half of its original size. You should only use this option when you are sure 
of the imported object’s size relative to your scene. Otherwise, use the Scale to unit 
cube option, above.

Drop to Floor: Checking the Drop to Floor checkbox places the imported object’s 
lower edge on the scene’s ground plane.
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Deep Copy: Checking the Deep Copy checkbox copies the selected MTX file and all 
files and subfolders referenced by that MTX, preserving the exact file/folder structure. 
This function only works when the scene file with all of the references is on the same 
or higher level on the same folder tree as the files being referenced. In this case, the 
files are copies to the selected library intact to preserve quality. If the references 
include files in other folder trees and/or at a higher level, pro-V Studio will load the 
MTX file and its referenced content and republish the scene into a new MTS file. This 
can cause texture and geometry quality degradation. Further, this may lose SWF and 
sound files present in the original scene. This function is useful for importing 
Viewpoint scenes created in other applications and performing post-production work 
to create the finished product. For example, you could export a Viewpoint scene from 
Curious Labs’ Poser and add interactivity in pro-V Studio.

Importing Audio

Please see “Sound Modifier” on page 138 for information about adding sound to your pro-
V Studio scenes.

EXIT

Selecting File>Exit or pressing [CTRL]+[Q] closes pro-V Studio. You are prompted to 
save any unsaved changes. 
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Chapter 14: The Edit Menu
he Edit menu allows you to perform basic editing functions and access your pro-
V Studio application’s general preferences settings.

UNDO

Selecting Edit>Undo or pressing CTRL]+[Z] undoes your last action. pro-V Studio 
features multiple levels of undo and redo.

REDO

Selecting Edit>Redo or pressing [CTRL+[Y] restores the most recently undone action. 
pro-V Studio features multiple levels of undo and redo.

CUT

Selecting Edit>Cut or pressing [CTRL]+[X] removes the selected element(s) from your 
scene and places them in the system Clipboard for later pasting. You can do this for any 
object in your scene. This function also cuts children and interaction elements attached to 
cut elements, but does not alter any animations or change any references to the cut 
object(s).

COPY

Selecting Edit>Copy or pressing [CTRL]+[C] places a copy of the selected element(s) in 
the system Clipboard. This function also copies children and interaction elements attached 
to copied elements, but does not alter any animations or change any references to the 
copied object(s).

PASTE

Selecting Edit>Paste or pressing [CTRL]+[V] pastes an instance of all cut/copied 
elements from the system Clipboard into your scene. You can paste 3D objects anywhere 
you like in the scene hierarchy. Pasted objects will have their interaction elements, 
however all targets remain the same. Pasted objects will appear in the same locations they 
had when they were cut/copied, so there may be duplicates that won’t be visible until you 
alter the position of either the original or pasted object. Pasted objects lose any animations 
previously assigned to the original objects. If your cut/copied object included children, 
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those children will also be pasted into the scene hierarchy when you paste the parent 
object.

NOTE
A WARNING DIALOG APPEARS IF YOU ATTEMPT AN UNSUPPORTED CUT/COPY/PASTE OPERATION.

DELETE

Selecting Edit>Delete or pressing [DEL] or [BACK] deletes the currently selected object. 
If you delete an object targeted by a reactor, the affected reactor is also deleted.

DESELECT ALL

Selecting Edit>Deselect All or pressing [CTRL]+[D] deselects all selected objects in your 
scene.

COPY ATTRIBUTES

Selecting Edit>Copy Attributes copies 
the attributes of the currently selected 
object to another compatible object and 
opens the Copy Attributes dialog.

To copy attributes from one object to the 
other, select the attribute(s) you wish to 
copy on the left side of the dialog and your 
desired target(s) on the right side. Click 
OK to confirm the copy, or Cancel to 
abort.

PREFERENCES

Selecting Edit>Preferences opens the Application Settings window, which allows you 
to specify global pro-V Studio preferences and default file paths. The Application 
Settings dialog has three tabs: Preferences, Paths, and Advanced. It also has three 
buttons, which are available in all three tabs:

Default: Clicking Default restores the pro-V Studio default preferences/file paths.

Cancel: Clicking Cancel exits this window and discards your changes.

OK: Clicking OK accepts your changes and exits this window.
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PREFERENCES TAB

The Preferences tab gives you the 
following choices:

Save Image Data As: All images 
imported into pro-V Studio are 
converted to either JPG or PNG 
format depending on your 
selection in the Save Image Data 
as pull-down menu. Selecting JPG 
optimizes image size for faster 
downloading but degrades quality, 
while the PNG option optimizes 
image quality while sacrificing 
download speed.

Save Window Position: Checking 
the Save Window Position 
checkbox stores your last-used 
window positions and restores 
them when you exit and re-launch 
pro-V Studio.

Maximize Window on Startup: Checking the Maximize Window on Startup checkbox 
opens the main pro-V Studio window maximized on your desktop. Clearing this 
checkbox causes pro-V Studio to open in partial-screen mode.

Beep when Done: Some pro-V Studio functions can take a few minutes depending on 
your computer’s resources and the complexity of the operation being performed. 
Checking the Beep when Done checkbox causes your computer to beep whenever a 
task is completed, allowing you to work on other applications with pro-V Studio in the 
background or leave your computer unattended and receive an audible alert. Clearing 
this checkbox makes pro-V Studio work in a “silent” mode.

Viewpoint Interaction Components: Checking the Viewpoint Interaction 
Components checkbox makes the default Viewpoint interaction components available 
for use in your scene. Clearing this checkbox does not expose these components. 
Please see “Native VET Components” on page 48 and “Native VET Components” on 
page 120 for more information about Viewpoint and pro-V Studio interaction 
components.
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Edit Interaction Object After Attach: Checking the Edit Interaction Object After 
Attach automatically opens an interaction element’s dialog when you bring it into 
your scene and saves you the step of manually opening the dialog. Clearing this 
checkbox does not automatically open this dialog.

Instance Asset After Import: By default, importing an object, does not create an 
instance in the scene. Checking the Instance Asset After Import automatically 
creates an instance of the asset in your scene when you import it, and vice-versa.

PATHS TAB

The Library tab is where you specify 
your desired default paths for various 
pro-V Studio functions. Your path 
choices are:

Library Path: The Library Path is 
the drive/folder where the pro-V 
Studio library is stored. Please see 
“Library vs. Project Assets” on 
page 17 for more information 
about libraries.

Use Default File Import Path: 
Checking the Use Default File 
Import Path button begins each 
import function in the specified 
folder when you first launch pro-V 
Studio. If this checkbox is blank, 
pro-V Studio remembers the last-
used import path upon restarting. 
pro-V Studio will remember your last-used import path until you exit the application.

Download Path: The Download Path is the default path for content downloaded using 
the Content room. Please see “The Content Room” on page 177 for more information 
about the Content room.

Project Path: The Project Path is the default path for saving your pro-V Studio 
projects.
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INTERFACE TAB

The Interface tab is has these choices:

Use Background Shader: 
Checking the Use Background 
Shader checkbox enables a 
custom background color. 
Checking the Shader Color box 
opens a standard Color Picker, 
allowing you to choose your color.

Use Background Texture: 
Checking the Use Background 
Texture checkbox enables a 
custom image, and vice-versa.

SETTING CUSTOM 
BACKGROUNDS

To set a custom background shader, 
either click the Shader Color box as 
described above, or:

1 Open the AppSettings.xml file located in your pro-V Studio’s Runtime folder.

2 Modify the UseBGShader tag as follows: UseBGShader=”1”.

3 Modify the UseBGShaderColor tag with any valid color number.

4 Save the modified AppSettings.xml file.

SETTING CUSTOM TEXTURES

To set a custom background shader:

1 Open the AppSettings.xml file located in your pro-V Studio’s Runtime folder.

2 Modify the UseBGTexture tag as follows: UseBGTexture=”1”

3 Modify the BGTextureFileName tag by inserting the complete path to your texture 
image between the quotation marks. For example: BgTextureFileName=”C:\My 
Pictures\image1.jpg”.

4 Save the modified AppSettings.xml file.

WARNING
BE SURE TO SAVE A BACKUP COPY OF THE ORIGINAL APPSETTINGS.XML FILE. FAILURE TO DO SO CAN CAUSE 
DATA LOSS AND/OR UNEXPECTED BEHAVIOR. ONLY ADVANCED USERS SHOULD MODIFY XML FILES.
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Chapter 15: The Scene Menu
he Scene menu allows you to enable and disable viewing layers and also setup 
some global scene preferences.

CREATE ASSET INSTANCE

Selecting Scene>Create Asset Instance creates a new instance of the currently selected 
asset. Please see “Instances” on page 18 for more information about instances.

SCENE SETTINGS

Selecting Scene>Scene Settings opens the Scene Settings dialog with the Main tab 
selected. All tabs in this dialog have the following options:

Default: Clicking Default restores the pro-V Studio default scene preferences.

Cancel: Clicking Cancel exits this window and discards your changes.

OK: Clicking OK accepts your changes and exits this window.

Edit Camera Controls: The left bottom corner of the Scene 
Settings dialog contains a full set of Edit Camera controls so 
that you can view your changes in the Scene Display window 
in real time. Please see “Edit Camera Controls” on page 102 for more information 
about the Edit Camera controls. You may switch tabs at any time by clicking the 
desired tab.

T
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MAIN TAB

The Main tab has the following 
options:

Project Width: Enter your desired 
project width in pixels in the 
Project Width field.

Project Height: Enter your desired 
project height in pixels in the 
Project Height field.

Render Mode: Select your desired 
render mode by clicking your 
desired Render Mode icons. pro-
V Studio supports seven render 
options. You can select different 
render options for your entire 
scene and/or on a per-project 
basis. Please refer to “Material 
Tab” on page 149 for more 
information about the supported 
render modes.

Use Shadows: Checking the Use Shadows checkbox enables shadows for your scene 
and vice-versa.

Blend Shadows: Checking the Blend Shadows checkbox blends overlapping shadows 
cast by different objects into one. Clearing this checkbox causes individual shadows to 
appear, which can lessen your scene’s realism.

Shadow Color: Clicking the Shadow Color box opens a standard Color Picker that 
allows you to specify your desired shadow color.

Shadow Opacity: The Shadow Opacity slider controls the shadow transparency. A 
setting of 0 (slider all the way to the left) creates a fully transparent shadow, while a 
setting of 1.0 (slider all the way to the right) creates a fully opaque shadow. You can 
also enter your desired value in the field.

Shadow Radius: The Shadow Radius slider determines the radius of the shadow 
around objects. Increasing this value causes larger shadows and vice-versa. You can 
also enter your desired number in the field.

Shadow Y Translation: The Shadow Y dial translates (moves) the shadow up and 
down. Click and drag the dial to make your selection, and/or input your desired value 
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directly in the field to the right of the dial. This change is only visible when the shadow 
is not bound to the scene bounding box (see below).

Bind Shadow to Scene Bounds: Checking the Bind Shadow to Scene Bounds forces 
shadows to remain within the scene’s bounding box and vice-versa. Clearing this 
checkbox enables you to alter the Shadow Y parameter, above.

LIGHTMAP SETTINGS

Selecting Scene>Lightmap Settings opens the Scene Settings dialog with the Lightmap 
tab selected. pro-V Studio uses light maps, which are described in “Light Maps” on 
page 45. You may switch tabs at any time by clicking the desired tab. The Lightmap tab 
has the following options:

Procedural/Image: You can load an image to use for a light map, or you can use a 
procedural method to create a custom light map using the Lightmap Type pull-down 
menu.

PROCEDURAL LIGHTMAPS

Selecting Procedural in the 
Lightmap tab allows you to create or 
modify a lightmap using a procedural 
system that emulates the lighting 
system found in some popular 3D 
rendering applications such as 
Curious Labs Poser. You can specify 
lightmaps on a scene or per-object 
level. Lightmaps applied to objects 
override scene settings.

You have the following options 
available when using procedural 
lightmaps:

Light Sphere: The Light Sphere is 
a virtual spherical panorama 
representing the edges of your 
scene on all sides. The colored 
pins represent individual lights. 
You may select a light using the Select Light pull-down menu. To position a light, 
click and drag it anywhere you want. If you continue dragging a light past the sphere’s 
edge, it will move to the back as shown in the image above. A small red dot indicates 
the currently selected light.
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New Light: Clicking the New Light icon creates a new light.

Delete Light: Clicking the Delete Light icon deletes the currently selected light.

Light Color: Clicking the Light Color box opens a standard Color Picker that allows 
you to specify your desired color for the currently selected light. You can also adjust 
the light’s color using the sliders, as explained below.

Force Low Black: Checking the Force Low Black checkbox creates a black border 
around the lightmap image, which can affect how objects appear in your scene.

Red: The Red slider determines the amount of red in the light’s color. A value of 0 
(slider all the way to the left) indicates no red, while a value of 255 (slider all the way 
to the right) indicates maximum redness. You can also enter your desired value in the 
field.

Green: The Green slider determines the amount of green in the light’s color. A value 
of 0 (slider all the way to the left) indicates no green, while a value of 255 (slider all 
the way to the right) indicates maximum green. You can also enter your desired value 
in the field.

Blue: The Blue slider determines the amount of red in the light’s color. A value of 0 
(slider all the way to the left) indicates no blue, while a value of 255 (slider all the way 
to the right) indicates maximum blueness. You can also enter your desired value in the 
field.

NOTE
SETTING THE RED, GREEN, AND BLUE VALUES TO 255 MAKES WHITE. SETTING ALL THREE VALUES TO 0 MAKES 
BLACK. YOU CAN SELECT OVER 16 MILLION LIGHT COLORS (255*255*255=16,581,375).

Color Brightness: The Color Brightness slider determines the light’s shade. 
Increasing this value (moving the slider to the right) lightens the shade, and vice-versa. 
This slider adjusts the Red, Green, and Blue sliders at once, preserving the 
relationships between them. You can also enter your desired value in the field

Specularity: The Specularity slider adjusts the size of the highlight. Moving it to the 
right enlarges the highlight and vice-versa. You can also enter your desired value in the 
field

Light Intensity: The Light Intensity slider controls the light’s overall brightness. 
Moving it to the right increases this value and vice-versa. You can also enter your 
desired value in the field

Clamp Diffuse Val: The Clamp Diffuse Val slider controls’ the strength of the light’s 
color. Moving it to the right increases this value and vice-versa. You can also enter 
your desired value in the field
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Blur Image: The Blur Image slider controls the amount of blurring in the current light 
map. Moving it to the right increases this value and vice-versa. You can also enter your 
desired value in the field.

Num Diffuse Color Val: The Num 
Diffuse Color Val slider specifies the 
number of steps (increments) in the 
diffuse color. Moving it to the right 
increases this value and vice-versa. You 
can also enter your desired value in the 
field.

Num Specular Color Val: The Num 
Specular Color Val slider specifies the 
number of steps (increments) in the 
specular color. Moving it to the right 
increases this value and vice-versa. You 
can also enter your desired value in the 
field.

IMAGE LIGHTMAPS

Selecting Image in the Lightmap tab 
allows you to work with lightmap 
images.

You have the following options when 
working with lightmap images:

Load Image From: The Load 
Image From pull-down menu 
allows you to specify your desired 
source from which to load image 
maps. Your options are File, pro-
V Studio Library, and Project 
Library. Please see “Library vs. 
Project Assets” for more 
information about the libraries.

Load: Clicking the Load button 
allows you to load a lightmap file 
using a standard Load dialog.

Convert: Clicking the Convert button converts a procedural lightmap to a lightmap 
image that can be saved to your hard drive.
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Save: Clicking the Save button opens a standard Save dialog, allowing you to save 
your current lightmap image to your hard drive. You can create as many custom light 
maps as you wish, save them as images, and apply them to individual objects within 
your scene. Object light maps override scene lightmaps. Please see “Light Map 
Palette” on page 156 for more information.

BACKGROUND SETTINGS

Selecting Scene>Background 
Settings opens the Scene 
Settings dialog with the Background 
tab selected. You may switch tabs at 
any time by clicking the desired tab.

The Background tab has the 
following options:

Background Color: Clicking the 
Background Color box opens a 
standard Color Picker that allows 
you to specify your desired 
background color.

Use Panorama: Checking the Use 
Panorama checkbox enables 
loading images or animations into 
the background layer (see 
“Background Layer” on page 21 
for more information) and vice-
versa. Checking this box also enables the following options:

Panorama Type: Use the Panorama Type pull-down menu to select the projection 
method for objects in this layer:

Flat: Selecting Flat places the image/animation in the background layer. This 
content is fixed, meaning you cannot scroll it.
Cylinder: Selecting Cylindrical allows you to scroll the background left and 
right.
Sphere: Selecting Sphere allows you to scroll the background in any direction.

Load Image: Clicking the Load Image icon opens a standard Open dialog, allowing 
you to select a file to load directly into the background layer.
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Image Source: The Image Source pull-down menu allows you to specify your desired 
source from which to load background images, etc. Your options are File, pro-V 
Studio Library, and Project Library.

CAMERA SETTINGS

Selecting Scene>Camera Settings 
opens the Scene Settings dialog with 
the Camera tab selected. You may 
switch tabs at any time by clicking 
the desired tab.

The Camera tab has the following 
options:

Camera Mode: The Camera 
Mode pull-down allows you to 
select the camera mode. The 
available options are:

Orbit: Selecting Orbit places 
the camera at the end of an 
invisible stick that's anchored 
at the point defined by the 
Pivot tag. The camera always 
points at the pivot point and 
moves in relation to it at a 
fixed distance, allowing you to view the geometry from every possible vantage 
point.
Walk: Selecting Walk allows you to move the camera freely around the scene.
Pano: Selecting Pano pivots the camera right, left, up, and down from a fixed 
point in the middle of your scene.
Still: Selecting Still locks the camera in its current position.

Scale: The Scale Minimum and Scale Maximum dials set the camera’s minimum and 
maximum zoom, respectively. Checking a checkbox enables the selected limit and 
vice-versa. To adjust a value, click and drag the desired dial to the right (increase) or 
left (decrease). You can also enter your desired value in the appropriate field.

Distance: The Distance Minimum and Distance Maximum dials set the camera’s 
minimum and maximum distance from the scene’s center, respectively. This is the 
absolute distance from the scene center along any axis. Checking a checkbox enables 
the selected limit and vice-versa. To adjust a value, click and drag the desired dial to 
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the right (increase) or left (decrease). You can also enter your desired value in the 
appropriate field.

XYZ Rotation: The XYZ Rotation Minimum and XYZ Rotation Maximum dials set 
the camera’s minimum and maximum rotation along each axis in degrees, respectively. 
Checking a checkbox enables the selected limit and vice-versa. To adjust a value, click 
and drag the desired dial to the right (increase) or left (decrease). You can also enter 
your desired value in the appropriate field.

XYZ Limits: The XYZ Limits Nearest and XY Z Limits Farthest dials set the 
camera’s minimum and maximum distance along each axis, respectively. This is the 
distance along an axis regardless of the distance from the scene center. Checking a 
checkbox enables the selected limit and vice-versa. To adjust a value, click and drag 
the desired dial to the right (increase) or left (decrease). You can also enter your 
desired value in the appropriate field.

ADVANCED SETTINGS

Selecting Scene>Advanced Settings 
opens the Scene Settings dialog with 
the Advanced tab selected. You may 
switch tabs at any time by clicking the 
desired tab. The Advanced tab has the 
following options:

Use Advanced Settings: Checking 
the Use Advanced 
Settings checkbox enables the 
advanced settings for the current 
scene and vice-versa.

Antialias Maximum Milliseconds: 
The Antialias Maximum 
Milliseconds value specifies the 
number of milliseconds that the 
viewer’s computer should spend to 
antialias the scene. If not 
completed in the specified time, 
the process will stop. To adjust a value, click and drag the desired dial to the right 
(increase) or left (decrease). You can also enter your desired value in the appropriate 
field

AUTHORED BY ANTHONY HERNANDEZ - (415)786-2081 - anthony94122@outlook.com



88 

 PRO-V STUDIO REFERENCE MANUAL

Filter Maximum Milliseconds: The Filter Maximum Milliseconds value specifies the 
number of milliseconds that the viewer’s computer should spend to filter texture maps 
in the current scene. If not completed in the specified time, the process will stop. To 
adjust a value, click and drag the desired dial to the right (increase) or left (decrease). 
You can also enter your desired value in the appropriate field

Sort Rule: The Sort Rule allows you to determine the order in which objects appear on 
the viewer’s computer when your scene is accessed. Check the appropriate radio 
button to make your selection. Your choices are Nearest (objects closest to the camera 
appear first), Farthest (objects furthest from the camera appear first), or 
Center (objects in the center of the scene appear first).

Enable Scene Clearing: Checking the Enable Scene Clearing causes the Viewpoint 
Media Player to clearing the previous frame’s screen content (render buffer), and vice-
versa. Viewpoint Media Player disables this mode when you have a panorama in your 
scene’s background.

COPY SCENE ASSET SETTINGS

Selecting Scene>Copy Scene Asset Settings copies the settings from the selected scene 
asset (object) to your current scene. This function copies everything described in the 
Scene Settings dialog except for the light map and the camera position settings.

AUTHORED BY ANTHONY HERNANDEZ - (415)786-2081 - anthony94122@outlook.com



89

THE PRO-V STUDIO MENU BAR

Chapter 16: The Object Menu
he Object menu allows you to control object attributes, create action primitives, 
and perform basic 2D and 3D object operations.

ATTRIBUTES

Selecting Object>Attributes opens the Object Attributes palette for the selected object 
in any pro-V Studio room. This window varies by object type and is visible in the Scene 
Setup room by default. You can also open it by double-clicking either the Runtime camera 
or any visible object listing in the Hierarchy Viewer window or by pressing [CTRL]+[I]. 
Please refer to “Object Attributes Palette” on page 141 for more information about the 
Object Attributes palette.

CREATE ACTION PRIMITIVE

The Create Action Primitive sub-menu allows you 
to create the following action primitives, which 
allow you to add interface elements to your scene.

To create an action primitive:

1 Select Object>Create Action 
Primitive><primitive>.

2 Add your desired images.

3 Configure the interaction components.

2D BUTTON

Selecting Object>Create Action Primitive>2D Button allows you to create a 2D button 
by opening the 2D Button Wizard palette, which has the following options:

Up Image: The Up Image is the image that appears when the button is “up”, that is, 
not pressed with the mouse not over the button.

Roll Over Image: The Roll Over Image is the image that appears when the mouse is 
on top of the button.

Down Image: The Down Image is the image that appears when the button is pressed.

T
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Each image has the following options:

Load Image: Clicking the Load Image icon opens a standard Open dialog, allowing 
you to select a file to load directly into the background layer.

Image Source: The Image Source pull-down menu allows you to specify your desired 
source from which to load background images, etc. Your options are File, pro-V 
Studio Library, and Project Library.

Buttons appear in the 2D layer. Each button can be up (default), rollover (mouse in on top 
of the button), or down (clicked). Creating a button also adds the following interaction 
components:

Button Up: The Button Up has a Multi Reactor named Button UP MultiReactor.

Button Roll Over: The Button Roll Over has two Multi Reactor named Button 
RollOver MultiReactor 1 and Button RollOver MultiReactor 2.

Button Down: The Button Up has a Multi Reactor named Button Down 
MultiReactor and a behavior named Button Click Behavior.

NOTE
IN THE ABOVE EXAMPLE, <NAME> REFERS TO THE NAME OF THE PARENT OBJECT (SUCH AS BUTTON_0).

Please refer to “Multi Reactors” for more information on Multi Reactors and to “About 
Behaviors” on page 167 for more information on behaviors.

2D CHECKBOX

Selecting Object>Create Action Primitive>2D Checkbox allows you to create a 2D 
checkbox by opening the 2D Checkbox Wizard palette, which has the following options:

Unchecked Image: The Unchecked Image is the image that appears when the 
checkbox is “clear”, that is, not checked.

Checked Image: The Checked Image is the image that appears when the checkbox is 
checked.

Each image has the following options:

Load Image: Clicking the Load Image icon opens a standard Open dialog, allowing 
you to select a file to load directly into the background layer.

Image Source: The Image Source pull-down menu allows you to specify your desired 
source from which to load background images, etc. Your options are File, pro-V 
Studio Library, and Project Library.
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Checkboxes appear in the 2D layer. Each checkbox can be unchecked (clear) or checked. 
Creating a button also adds the following interaction components:

Checkbox Unchecked: The Checkbox Unchecked has a Multi Reactor named 
<name> Unchecked MultiReactor.

Checkbox Checked: The Checkbox Checked has a Multi Reactor named <name> 
Checked MultiReactor.

NOTE
IN THE ABOVE EXAMPLE, <NAME> REFERS TO THE NAME OF THE PARENT OBJECT (SUCH AS CHECKBOX_0).

Please refer to “Multi Reactors” on page 119 for more information on Multi Reactors and 
to “About Behaviors” on page 167 for more information on behaviors

2D OBJECT OPERATIONS

The 2D Operations sub-menu allows you to perform basic operations to 2D objects:

CENTER VERTICALLY

Selecting Object>2D Object Operations>Center Vertically centers the selected 2D 
object vertically in your scene.

CENTER HORIZONTALLY

Selecting Object>2D Object Operations>Center Horizontally centers the selected 2D 
object horizontally in your scene.

3D OBJECT OPERATIONS

The 3D Operations sub-menu allows you to perform basic operations to 3D objects:

MOVE TO WORLD ORIGIN

Selecting Object>3D Object Operations>Move To World Origin moves the selected 
object to the global origin in all three axes (0,0,0).
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Chapter 17: The Animator Menu
he Animator menu allows you to work with animators, timelines, and keyframes. 
You can add, split, and play animators, and can add timelines and keyframes. 
Please refer to “Creating Simple Animations” on page 112 for more information 

on creating simple animations inside pro-V Studio and to “The Animation Room” on 
page 158 for more information about the Animation room.

NEW ANIMATOR

Selecting Animator>New Animator creates a new animator. To create a new animator:

1 Select the desired parent for the new animator.

2 Select Animator>New Animator to create the new animator.

3 Name the new animator by selecting it in the Animators tab 
of the Hierarchy Viewer window, then clicking it (slow double-click). Enter your 
desired animation name in the field. Press [ENTER] when finished.

You may rename animators at any time using this method.

NEW ACTION TIMELINE

Selection Animation>New Action Timeline creates a new action timeline in your 
selected animator. See “Action Timelines” on page 163 for more information.

SPLIT SELECTION

Selecting Animator>Split Selection splits an animator with multiple timelines into 
separate animators, each with one timeline. You can also split timelines and keyframes. 
Please see “Splitting Selections” on page 166 for more information.

This is a great way to refine control over animations in scenes. Splitting an animator does 
not delete the original animator or timelines. This allows you to revert your changes or 
perform other operations since no data is lost.

PLAY ANIMATOR

Selecting Animator>Play Animator plays the currently selected animator. You can also 
do this by clicking the Play button in the Simple Animations palette, as described in “The 
Simple Animations Palette” on page 110.

T
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ADD TIMELINE

Selecting Animator>Add Timeline or pressing [CTRL]+[T] adds a new timeline to the 
currently selected animator.

ADD KEYFRAME

Selecting Animator>Add Keyframe or pressing [CTRL]+[K] adds a keyframe to the 
currently selected timeline.
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Chapter 18: The View Menu
he Project menu is another convenient way of switching between rooms while 
using pro-V Studio.

HIDE/SHOW BACKGROUND

When the background layer is visible, selecting Scene>Hide Background hides the 
background layer. When the background layer is invisible, selecting Scene>Show 
Background displays the background layer. This function is also available directly within 
the Scene Display window. Please see “Layer Display” on page 101 for more information.

HIDE/SHOW 3D LAYER

When the 3D layer is visible, selecting Scene>Hide 3D Layer hides the 3D layer. When 
the 3D layer is invisible, selecting Scene>Show 3D Layer displays the 3D layer. This 
function is also available directly within the Scene Display window. Please see “Layer 
Display” on page 101 for more information.

HIDE/SHOW 2D LAYER

When the 2D layer is visible, selecting Scene>Hide 2D Layer hides the 2D layer. When 
the background layer is invisible, selecting Scene>Show 2D Layer displays the 2D layer. 
This function is also available directly within the Scene Display window. Please see 
“Layer Display” on page 101 for more information.

HIDE/SHOW FOREGROUND LAYER

When the foreground layer is visible, selecting Scene>Hide Foreground Layer hides the 
post-animation layer. When the post-animation layer is invisible, selecting Scene>Show 
Foreground Layer displays the foreground layer. This function is also available directly 
within the Scene Display window. Please see “Layer Display” on page 101 for more 
information.

T
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HIDE/SHOW GROUND PLANE

When the ground plane is visible, selecting Scene>Hide Ground 
Plane hides the 2D ground plane. When the ground plane is 
invisible, selecting Scene>Show Ground Plane displays the 
ground plane. This function is also available directly within the 
Scene Display window. Please see “Layer Display” on page 101 
for more information.You may also toggle the ground plane on and off by pressing 
[CTRL]+[G].

HIDE/SHOW AXES

When the scene and object axes are visible, selecting Scene>Hide 
Axes hides them in the Scene Display window. When the scene 
and object axes are invisible, selecting Scene>Show Axes 
displays them.

HIDE/SHOW BOUNDING BOXES

When object bounding boxes are visible, selecting 
Scene>Hide Bounding Boxes hides them in the Scene 
Display window. When object bounding boxes are invisible, 
selecting Scene>Show Bounding Boxes displays them. You 
may also toggle bounding boxes on and off by pressing 
[CTRL]+[B].

SCENE SETUP

Selecting Project>Scene Setup switches to the Scene Setup room. This is the same as 
clicking the Scene Setup room tab.

MATERIALS

Selecting Project>Materials switches to the Materials room. This is the same as clicking 
the Materials room tab.

ANIMATION

Selecting Project>Animation switches to the Animation room. This is the same as 
clicking the Animation room tab.
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INTERACTION

Selecting Project>Interaction switches to the Interaction room. This is the same as 
clicking the Interaction room tab.

WEB INTEGRATION

Selecting Project>Web Integration switches to the Web Integration room. This is the 
same as clicking the Web Integration room tab.

PUBLISH

Selecting Project>Publish switches to the Publish room. This is the same as clicking the 
Publish room tab.

CONTENT

Selecting Project>Content switches to the Content room and accesses the online 
Content Paradise portal. This is the same as clicking the Content room tab

AUTHORED BY ANTHONY HERNANDEZ - (415)786-2081 - anthony94122@outlook.com



97

THE PRO-V STUDIO MENU BAR

Chapter 19: The Help Menu
he Help menu provides assistance while you’re using pro-V Studio.

PRO-V STUDIO HELP

Selecting Help>pro-V Studio Help opens this manual in Adobe Acrobat (PDF) format.

CURIOUS LABS WEB LINKS

Selecting Help>Curious Labs Web Links opens Curious Labs Web pages containing lots 
of useful information about pro-V Studio.

TUTORIALS

Selecting Help>Tutorials opens a Web page containing tutorials on how to use pro-V 
Studio.

OTHER WEB LINKS

Selecting Help>Other Web Links opens an assortment of online Web pages containing 
lots of useful information about pro-V Studio.

ABOUT PRO-V STUDIO

Selecting Help>About pro-V Studio displays your pro-V Studio version and licensing 
information. You will need this information when contacting Curious Labs Technical 
Support.

T
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Chapter 20: The Scene Display 
Window

he Scene Display window 
is where you will view 
and work with your 

scenes as you build them. It 
appears in all pro-V Studio rooms 
except the Web Integration and 
Content rooms. This window 
appears as shown.

The Scene Display window has 
the following functional areas:

Layer Display (1): Toggle 
layers and the ground plane on 
and off.

Miscellaneous Tools (2): View 
the entire scene and add notes.

Camera Selection (3): Select 
your desired camera and 
toggle viewing the entire scene.

Edit Camera Controls (4): Manipulate the Edit camera.

Editing Tools (5): Position objects and the Runtime camera.

Scene Display (6): Directly manipulate objects in your scene using the Editing tools.

The following sections discuss each area in further detail:

T
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LAYER DISPLAY

The Layer Display tools (area 1) allow you toggle both the pro-V Studio layers and the 
ground plane on and off. Toggling layers off can help visualization and provide added 
control when creating complex scenes. From left to right, these tools are:

Toggle Background Layer: Clicking the Toggle Background Layer icon toggles 
displaying the background layer on and off.

Toggle 3D Layer: Clicking the Toggle 3D Layer icon toggles displaying the 3D layer 
on and off.

Toggle 2D Layer: Clicking the Toggle 2D Layer icon toggles displaying the 2D layer 
on and off.

Toggle Foreground Layer: Clicking the Toggle Foreground Layer icon toggles 
displaying the foreground layer on and off.

Toggle Ground Plane: Clicking the Toggle Ground Plane icon toggles displaying the 
ground plane on and off.

MISCELLANEOUS TOOLS

The Scene Display window includes two Miscellaneous tools (area 2). From left to right, 
these tools are:

View Whole Scene: Clicking the View Whole Scene icon zooms the Scene Display 
window to view your entire scene for as long as the button remains pressed. Releasing 
the button reverts to your previous view. This function is good for getting an overview 
of your scene and overall progress.

Markup Tool: Activating the Markup tool lets you “draw” on your scene, allowing 
you to (for example) visualize animation paths, highlight areas of concern, etc. This 
information is not saved and is not published with your scene. Deactivating the 
Markup tool clears all markups.

CAMERA SELECTION

The Camera Selection tools (area 3) allow you to select your current camera and get a 
“bird’s eye” view of your scene:

Edit Camera: Clicking the Edit Camera icon selects the Edit camera and activates the 
Edit Camera controls (see below). The Scene Display window changes to view your 
scene from this camera’s current position. The Edit camera is the “working” camera 
you use to build your scene. The Edit camera’s position and movements are not saved 
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and do not get published with your scene. You can also activate this camera by 
pressing [CTRL]+[E].

Runtime Camera: Clicking the Runtime Camera icon selects the Runtime camera and 
deactivates the Edit Camera controls (see below). The Scene Display window 
changes to view your scene from this camera’s current position. The Runtime camera 
is the “viewing” camera from which viewers see your published scene. The Runtime 
camera’s position and movements are saved and get published with your scene. You 
can also activate this camera by pressing [CTRL]+[R] or by selecting it in the 
Hierarchy Viewer window.

EDIT CAMERA CONTROLS

The Edit Camera controls (area 4) 
allow you to move your Edit camera 
to view your scene from different 
angles without affecting any of the objects in your scene. They appear as shown.

From left to right, the Edit Camera controls are:

Trackball: The Trackball tilts and spins the Edit camera about all three axes.

Move XY: Move XY: The Move XY control constrains camera motions to the side/side 
(X) and up/down (Y) axes.

Move XZ: The Move XZ control constrains camera motions to the side/side (X) and 
front/back (Z) axes.

Move YZ: The Move YZ control constrains camera motions to the up/down (Y) and 
front/back (Z) axes.

Focal Length: The Focal Length (or Scale) control increases or decreases the selected 
camera’s focal length. Clicking the control and dragging right increases the focal 
length, while clicking and dragging to the left reduces the focal length. This zooms the 
camera view in and out of your scene without moving the camera or any objects.

Auto Spin: Checking the Auto Spin checkbox causes the scene to keep spinning in the 
direction and velocity of the most recent click and drag in any empty portion in your 
scene. To spin in a new direction, click and drag in your desired direction. To stop 
spinning, click the mouse at any empty point in your scene. Clearing this checkbox 
disables this function.
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EDITING TOOLS

The Editing tools (area 5) appear as follows in the Scene Display window:

The Editing tools let you move objects in many different ways. Moving a parent object 
also moves its children. To move an object:

1 Select the object by either clicking it in the Scene Display window or by selecting it in 
the Hierarchy Viewer window.

2 Click and drag your desired Editing tool to move the selected object and any children.

From left to right, the Editing tools are:

RUNTIME CAMERA

The Runtime Camera tool selects the Runtime camera. Unlike the Edit camera, The 
Runtime camera’s position is stored and published with your scene. Please see “Runtime 
Camera” on page 103 for more information. You can enable this tool by pressing [1].

TRANSLATE

The Translate tool moves the selected object vertically around or laterally around the 
Camera’s X and Y axes depending on how you drag. The translation may occur on the 
object’s X, Y, and or Z axes depending on the position of the camera relative to the object. 
You can also adjust an object’s translation using the Object Attributes palette, as 
described in “Object Attributes Palette” on page 141. You can enable this tool by pressing 
[2].

PUSH/PULL

The Push/Pull tool moves the selected object along the camera’s Z axis (in and out). This 
translation may take place along the object’s X, Y, and/or Z axes. Dragging down pulls the 
object towards you, and vice versa. Moving an object towards you makes that items seem 
larger, and vice versa. You can also adjust an object’s translation using the Object 
Attributes palette, as described in “Object Attributes Palette” on page 141. You can 
enable this tool by pressing [3].
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TRANSLATE XZ

The Translate XZ tool moves the selected object along the global X and Z axes regardless 
of the Camera’s position. Dragging left and right moves the object along the X axis. 
Dragging up and down moves the object along the Z axis. You can also adjust an object’s 
translation using the Object Attributes palette, as described in “Object Attributes 
Palette” on page 141. You can enable this tool by pressing [4].

TRANSLATE Y

The Translate Y tool moves the selected object along the global Y axis regardless of the 
Camera’s position. Dragging up and down moves the object along the Y axis. You can also 
adjust an object’s translation using the Object Attributes palette, as described in “Object 
Attributes Palette” on page 141. You can enable this tool by pressing [5].

ROTATE Y

The Rotate Y tool rotates the selected object along the Camera’s Y axis (yaw - see 
“Rotation” on page 32). This rotation may take place along the object’s X, Y, and/or Z 
axes. Drag left or right to rotate the object. You can also adjust an object’s rotation using 
the Object Attributes palette, as described in “Object Attributes Palette” on page 141. 
You can enable this tool by pressing [6].

ROTATE X

The Rotate X tool rotates the selected object along the Camera’s X axis (pitch - see 
“Rotation” on page 32). This rotation may take place along the object’s X, Y, and/or Z 
axes. Drag up or down to rotate the object. You can also adjust an object’s rotation using 
the Object Attributes palette, as described in “Object Attributes Palette” on page 141. 
You can enable this tool by pressing [7].

ROTATE Z

The Rotate Z tool rotates the selected object along the Camera’s Z axis (roll - see 
“Rotation” on page 32). This rotation may take place along the object’s X, Y, and/or Z 
axes. Drag left or right to rotate the object. You can also adjust an object’s rotation using 
the Object Attributes palette, as described in “Object Attributes Palette” on page 141. 
You can enable this tool by pressing [8].
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TUMBLE

The Tumble tool rotates an object along the Camera’s X, Y, or Z axes. This rotation may 
take place along the object’s X, Y, and/or Z axes. Drag in any direction to rotate the object. 
You can also adjust an object’s rotation using the Object Attributes palette, as described 
in “Object Attributes Palette” on page 141. You can enable this tool by pressing [0].

SCALE

The Scale tool scales an object along the Camera’s X, Y, or Z axes. This may take place 
along the object’s X, Y, and/or Z axes. Select a control point (see image) and drag in any 
direction to scale the object. Selecting a control point in a corner scales the object 
uniformly. Selecting a control point that is not in a corner scales the object along the 
selected axis. You can also adjust an object’s scale using the Object Attributes palette, as 
described in “Object Attributes Palette” on page 141. You can enable this tool by pressing 
[0].

SCENE DISPLAY

The Scene Display area (area 6) displays your scene’s objects.

To access Trackball functionality, left-click and drag in any open area of the window.

To zoom in and out, right-click and drag in any open area of the window.

To add an object to your scene, you can select the desired object in the Media palette 
and drag the object into the window. Dragging a 2D object into the window places it in 
the background layer. Please see “Background Layer” on page 21 for more 
information.

To directly manipulate an object, select an Editing tool then click and drag the 
selected object. Be sure your mouse is over the selected object when you do this to 
avoid rotating your viewing angle.

The Scene Display window shows your scene in its set height and width. Resizing this 
window does not resize your scene. To resize your scene, use the Scene Settings 
window as described in “Scene Settings” on page 80.
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Chapter 21: The Hierarchy Viewer 
Window

ireplace’s Hierarchy View window displays 
your scene’s hierarchies. It appears in all 
pro-V Studio rooms except the Web 

Integration and Content rooms. Please see 
“Hierarchies” on page 36 for more information 
about hierarchies. This window breaks down 
hierarchies by layer, interaction components, 
materials, and animators. It appears as shown.

The Hierarchy View window has the following 
functional areas:

Objects Tab (1): The Objects tab displays the 
scene hierarchies by layer.

Animators Tab (2): The Animators tab displays 
your scene’s animator hierarchy.

Interactions/Materials Area (3): The 
Interactions/Materials area displays all 
interaction elements or materials assigned to 
each object.

OBJECTS TAB

The Objects tab (area 1) 
displays your scene’s 
object hierarchies by 
layer. Children appear 
indented in the hierarchy 
view. You can add 
objects to the 3D layer 
by dragging them from the Media palette to the Hierarchy Viewer window. Click the 
arrows next to objects to expand and collapse hierarchy branches. You can also rearrange 
the hierarchy in the 2D and 3D layers by dragging and dropping objects as shown in this 
example.

F
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In the Scene Setup room, selecting an object in the 3D or 2D layer opens the Object 
Attributes window for that object. In other rooms, double-clicking the object has the 
same function. Please see “Object Attributes Palette” on page 141 for more information 
about the Object Attributes window.

ANIMATORS TAB

The Animators tab (area 2) displays all of the animators and their hierarchy in your scene. 
As with the Objects tab, you can click and drag animators to create or modify the 
animator hierarchy as shown in this example:

When in the Animation room, selecting an animator in the Hierarchy View window 
opens the Animation Details window for that animator. Please see “The Simple 
Animations Palette” on page 110 for more information about animating within pro-V 
Studio.

INTERACTIONS/MATERIALS AREA

The Interactions/Materials area (area 3) displays either the 
interaction components or (if you are in the Materials room) the 
material assigned to the currently selected object in the scene 
hierarchy. Please see “Interactions” on page 47 for more 
information about interaction components and “Materials & 
Lights” on page 42 for more information about materials. Use the pull-down arrow to 
select whether you wish to view interaction components or materials for the selected 
object as shown.

NOTE
REMEMBER, YOU CAN VIEW INTERACTION COMPONENTS IN ANY PRO-V STUDIO ROOM. MATERIALS ARE ONLY 
AVAILABLE WHEN IN THE MATERIALS ROOM.

DELETING OBJECTS/ANIMATORS

To delete an object or animator, select the item to delete, then either select Edit>Delete or 
press [DEL] or [BACK]. Deleting a parent deletes its children as well. Deleting an object 
with interaction components attached also deletes those interaction components. You 
cannot have “empty” (unattached) interaction components in scenes.
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Chapter 22: The Media Palette
he Media palette is where you access the project assets, pro-V Studio library, and 
primitives. It appears in the Scene Setup and Materials rooms. Please see 
“Library vs. Project Assets” on page 17 and “Primitives” on page 17 for more 

information about each of these content types. The Media palette has three tabs, one for 
each object type, which appear as follows:

PROJECT ASSETS TAB

The Project Assets tab contains all of the 2D and 3D objects in your current project/scene. 
These objects may be instanced from the Library tab or may be imported solely for your 
current project. Assets are organized into:

3D Objects: contains all of the 3D objects in your current project.

Scenes: contains all of the Viewpoint scene objects (such as ASE, NFF, and MTX) in 
your current project.

2D Objects: contains all of the 2D objects (images and animations) in your current 
project.

Scripts: contains all imported Java scripts in your current project.

Assets imported into the project assets are only available for that project. To import 
objects for use in more than one project, import them into the pro-V Studio Library. See 
“Library vs. Project Assets” on page 17 and “The Import Settings Dialog” on page 71 for 
more information.

To add an object from the Media palette to your current scene, click and drag the desired 
object into either the Scene Display or Hierarchy Viewer window. Dragging a 2D object 
into the scene adds it to the background layer. In the Materials room, you can also drag 
2D objects to create and modify materials. Please see “Maps Palettes” on page 153 for 
more information.

T
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LIBRARY TAB

The Library tab contains all of the 2D and 3D objects in your pro-V Studio Library. 
These objects are available for use in all of your projects. Assets are organized into:

3D Objects: contains all of the 3D objects in your pro-V Studio Library.

Scenes: contains all of the Viewpoint scenes in your pro-V Studio Library.

2D Objects: contains all of the 2D objects (images and animations) in your pro-V 
Studio Library.

Scripts: contains all imported Java scripts in your pro-V Studio Library.

To add an object from your pro-V Studio Library to your current scene, click and drag the 
desired object into either the Scene Display or Hierarchy Viewer window. Dragging a 
2D object into the scene adds it to the background layer. In the Materials room, you can 
also drag 2D objects to create and modify materials. Please see “Maps Palettes” on 
page 153 for more information.

Adding an object from the pro-V Studio Library to your current project also adds that 
object to your project objects, and it will be accessible from the Project Assets tab. This is 
done to prevent data loss caused by deleting objects from the pro-V Studio Library that are 
in use in your scene.

PRIMITIVES TAB

The Primitives tab contains an assortment of basic primitive shapes. These are available 
at all times while using pro-V Studio. To add an object from your primitives to your 
current scene, click and drag the desired object into either the Scene Display or 
Hierarchy Viewer window. All primitives are 3D objects. Primitives do not appear in the 
Project Assets tab because of their universal availability.
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Chapter 23: The Simple Animations 
Palette

he Simple Animations palette lets you quickly add animations to your scene. For 
detailed animation control, you will need to go to the Animation room (see “The 
Animation Room” on page 158 for more information).

SIMPLE ANIMATION PALETTE CONTROLS

The Simple Animations palette appears as follows:

This palette has the following controls:

Slider Snapping (1): Checking the Slider Snapping checkbox causes the Time slider 
(1) to jump or snap to the nearest keyframe when dragged and released.

Animator Name (2): The Animator Name displays the currently selected animator.

Current Time (3): The Current Time fields display the animation’s current location in 
minutes:seconds:milliseconds format. See the following section for more information.

Duration (4): The Duration fields display the animation’s total length in 
minutes:seconds:milliseconds format. See the following section for more information.

Speed Scale (5): The Scale field displays the current time scale. A value of 2 means 
that the animation will play double speed. 0.5 means the animation will play at half 
speed, and so forth. Enter your desired scale using the Animation Details window, as 
described in “Animation Details Window” on page 158.

Remove Keyframe (6): Clicking the Remove Keyframe button removes the current 
keyframe.

T
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Add Keyframe (7): Clicking the Add Keyframe button or pressing [CTRL]+[K] dds a 
keyframe at the time specified in the Current Time fields (3). If a keyframe already 
exists at the specified time, this function only adds keyframes to timelines without 
keyframes. To replace an existing keyframe, you must use the Force Add Keyframe 
button, described below.

Force Add Keyframe (8): Clicking the Force Add Keyframe button or pressing 
[CTRL]+[SHIFT]+[K] replaces keyframes at the current time with the new values. For 
example, if you have an existing keyframe with a Translate value of 3 and the object is 
at 5Y, this button replaces the TranslateY 3 keyframe with a TranslateY 5 keyframe.

Add Timeline (9): The Add Timeline button adds a timeline to the current animator 
and opens the Property Selection dialog. Please see “Animation Hierarchy” on 
page 39 for information about the pro-V Studio animation hierarchy and “The 
Property Selection Dialog” on page 113 for information about the Property Selection 
dialog. You can also create a new timeline by pressing [CTRL]+[T]

Time (10): The Time slider allows you to drag or scrub to any time in the animation.

Animation Controls (11): The Animation Controls allow you 
to preview your animation. They appear as shown.

The Animation Controls are as follows:
Rewind (A): Clicking the Rewind button returns to the 
beginning of the animation.
Reverse/Pause (B): Clicking the Reverse button plays the 
animation in reverse. While the animation is playing, clicking this button again 
pauses playback.
Stop (C): Clicking the Stop button stops the animation at its current position.
Play/Pause (D): Clicking the Play button plays the animation. While the 
animation is playing, clicking this button again pauses playback.
Fast Forward (E): Clicking the Fast Forward button plays the animation at 
higher speed.
First Keyframe (F): Clicking the First Keyframe button moves the animation to 
the first keyframe.
Previous Keyframe (G): Clicking the Previous Keyframe button moves the 
animation to the next previous keyframe.
Next Keyframe (H): Clicking the Next Keyframe button moves the animation to 
the next proceeding keyframe.
Last Keyframe (I): Clicking the Last Keyframe button moves the animation to 
the last keyframe.
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CREATING SIMPLE ANIMATIONS

To create a simple animation:

1 Create a new animator by selecting Animation>New Animator.

2 In the Hierarchy Viewer tab, select the Animations tab and select your new animator. 
This enables the Simple Animations palette.

3 Click the Add Timeline button and select your desired target object and properties in 
the Property Selection dialog (see below for more information about the Property 
Selection dialog).

4 Specify the total length of this animation by entering your desired time in 
minute:second:millisecond format in the Duration fields. For example, to create an 
animation that is 1 minute and 23.5 seconds long, you would enter 1 in the left field, 
23 in the middle field, and 500 in the right field.

5 Click the Add Keyframe button to add an initial keyframe.

6 Move the Time slider to a new position or enter the time for the first keyframe in the 
Current Time fields using the same format described in Step 4, above.

7 Change the target object’s properties. How you do this will depend on the property 
being animated. For example, if you are changing an object’s location (translation), 
you may either click and drag the object in the Scene Display window or adjust its 
location using the Object Attributes dialog (see “Object Attributes Palette” on 
page 141 for more information).

8 Repeat steps 5-7 as often as desired to create your keyframes.

9 Preview your new animation.

To adjust an existing animation, go to the Animation room (see “The Animation Room” 
on page 158 for more information).
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THE PROPERTY SELECTION DIALOG

As described in Step 3, above, clicking the 
Add Keyframe or Force Add Keyframe 
button in the Simple Animations palette 
(see “The Simple Animations Palette” on 
page 110) opens the Property Selection 
dialog box, which appears as shown.

The left side of this dialog contains a 
display of your scene’s hierarchy, much 
like the Hierarchy Viewer window (see 
“The Hierarchy Viewer Window” on 
page 106 for more information).

1 To create a new animator, select Animator>New Animator

2 To add a timeline to an existing animator, select the animator in which you wish to 
create the timeline in the Hierarchy Viewer window.

3 Select the object you want to animate just like you would in the Hierarchy Viewer 
window.

4 The right side of the Property Selection dialog displays a list of animatable attributes 
for the selected object. Select the property or properties you wish to animate and click 
OK. This creates one new timeline in the currently selected animator for each selected 
property. Preexisting timelines appear already checked. Unchecking the checkbox 
stops adding keyframes to the selected timeline until when and if you check the box 
again.
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Chapter 24: The Interaction Palette
he Interaction palette allows you to add interaction components to your scene. 
There are four types of interaction components: reactors, behaviors, native VET 
components, and modifiers. This chapter discusses the Interaction palette and the 

different types of interaction components.

INTERACTION PALETTE

The Interaction palette appears as shown.

To add an interaction component:

1 Select the component you wish to add.

2 Drag the desired interaction component from the 
Interaction palette onto the desired object in the 
Hierarchy Viewer window.

3 Edit your newly added interaction component by 
double-clicking it in the Hierarchy Viewer 
window. Remember that you will only see the 
interaction components that are attached to your 
currently selected object, as shown below:

In the above example, if you have a reactor attached to the pyramid, selecting the pyramid 
will display that reactor.

Checking the Edit Interaction Object After Attach checkbox in the 
Application Settings dialog automatically opens an interaction 
component’s dialog box whenever you add an interaction component. 
Please see “Scene Settings” on page 80 for more information.

REACTORS

pro-V Studio supports three types of reactors: Simple, Timer, and Multi. Each type of 
reactor is discussed in further detail below. All reactors have the same basic function of 
making a pre-defined triggering event cause a pre-defined response. For example, a 
Simple Reactor reacts to a trigger (incoming message) that causes it to perform its 
specified action. The other reactor types are variations on this theme.

T
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SIMPLE REACTORS

A Simple Reactor appears as shown. This 
reactor type has the following elements:

Name: Enter a name for the reactor in 
the Name field (1). This must be an 
alpha or alphanumeric entry (no 
numeric entries). Further, this name 
must be unique and cannot contain any 
special or XML characters.

Incoming Message: The Incoming 
Message pull-down menu (2) allows 
you to specify the reactor’s trigger. pro-
V Studio includes messages. You can 
also create custom messages. For 
example, if another reactor sends out 
the message MYMESSAGE, then you 
can set another reactor to be triggered when MYMESSAGE is posted to the system. The 
built-in options are:

Scene Start: Selecting Scene Start triggers the reactor when the scene begins 
playing on a viewer’s computer.
Mouse Left Down: Selecting Mouse Left Down triggers the reactor when the left 
mouse button is pushed (but not necessarily released) while the mouse is on top of 
the selected object.
Mouse Left Click: Selecting Mouse Left Click triggers the reactor when the left 
mouse button is clicked (pushed and released) while the mouse is on top of the 
selected object.
Mouse Left Up: Selecting Mouse Left Up triggers the reactor when the left mouse 
button is released while the mouse is on top of the selected object.
Mouse Right Down: Selecting Mouse Right Down triggers the reactor when the 
right mouse button is pushed (but not necessarily released) while the mouse is on 
top of the selected object.
Mouse Right Click: Selecting Mouse Right Click triggers the reactor when the 
right mouse button is clicked (pushed and released) while the mouse is on top of 
the selected object.
Mouse Right Up: Selecting Mouse Right Up triggers the reactor when the right 
mouse button is released while the mouse is on top of the selected object.
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Mouse Drag: Selecting Mouse Dragged triggers the reactor when the mouse is 
dragged across the selected object (moved across the object with a button held 
down).
Mouse Move: Selecting Mouse Move triggers the reactor when the mouse is 
moved across the selected object without a button pushed.
Mouse Enter: Selecting Mouse Enter triggers the reactor when the mouse cursor 
crosses over any edge of the selected object. 
Mouse Exit: Selecting Mouse Exit triggers the reactor when the mouse cursor 
goes beyond any edge of the selected object.
Mouse Drag Enter: Selecting Mouse Drag Enter triggers the reactor when the 
mouse cursor crosses over any edge of the selected object while a button is 
pushed.
Mouse Drag Exit: Selecting Mouse Drag Exit triggers the reactor when the 
mouse cursor goes beyond any edge of the selected object while a button is 
pushed.
Mouse Wheel: Selecting Mouse Wheel triggers the reactor when the mouse wheel 
is moved while the mouse is on top of the selected object.
Key Down: Selecting Mouse Left Down triggers the reactor when a key is 
pressed.
Key Up: Selecting Mouse Left Down triggers the reactor when a key is released.
Custom: If you have custom messages output by other interaction components, 
you can use any of those messages to trigger another reactor. Simply select your 
desired message from the pull-down menu. For example, if you create a message 
called MYMESSAGE, then MYMESSAGE will appear as an option in the menu.

Action: Once the reactor is triggered, it will perform the action specified in the 
Action pull-down menu (3). Available actions are:

Post Message: Selecting Post Message sends a custom message to the system 
when the current reactor is triggered. For example, if you select this option and 
enter MYMESSAGE in the Message field (see below), then MYNMESSAGE will 
appear as an option in the Incoming Message pull-down (described above) and 
can be used to trigger another reactor.
Set Built In Property: Selecting Set Built In Property allows you to set a 
property, which you select using the Property pull-down menu (see below).
Collapse: Selecting Collapse collapses the current object. Please see “Collapsing 
Objects” on page 37 for more information.
Uncollapse: Selecting Uncollapse uncollapses the selected object and children. 
Collapsing and uncollapsing objects allows you to create more complex scenes 
while conserving resources.
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Hide: Selecting Hide makes the current object invisible. Hidden objects are still 
present in the scene and can have interaction components, etc. They also consume 
resources.
Show: Selecting Show makes the current object visible.
Set Object Opacity: Selecting Set Object Opacity allows you to specify the 
object’s opacity in the Data field.
Drag Object: Selecting Drag Object allows the viewer to drag the current object 
to a new location.
Set Material Diffuse Color: Selecting Set Material Diffuse Color allows you to 
set the current object’s color. Please see “Material Settings Palette” on page 149 
for more information.
Set Material Opacity: Selecting Set Material Opacity allows you to specify the 
opacity of the object’s material (not the object itself) in the Data field.
Trigger Animation: Selecting Trigger Animation allows you to trigger an action 
animator that begins playing when the reactor is triggered.
Start Animation: Selecting Start Animation starts the selected animator.
Stop Animation: Selecting Stop Animation stops the selected animator.
Load MTX: Selecting Load MTX loads the specified Viewpoint MTX file.
Execute VB Script: Selecting Execute VB Script loads and executes a Visual 
Basic (VB) script.
Execute JavaScript: Selecting Execute JavaScript loads and executes a Java 
Script script.

WARNING
USE SCRIPTS WITH CARE! SCRIPTS CAN CAUSE DATA LOSS AND UNPREDICTABLE BEHAVIOR ON 
DEVELOPMENT AND VIEWER COMPUTERS IF NOT THOROUGHLY TESTED.

Data: Some of the actions allow you to send data to the system. For example, posting a 
message allows you to enter a custom message as described above. The Data field (4) 
is where you enter the data to be applied by the reactor. The displayed name of this 
field changes depending on the action you select using the Action pull-down menu. 
For some values, you can select the following by clicking the arrow to the left of the 
field name and using the pull-down menu:

Value: Selecting Value sends the specified value to the selected target.
Append: Selecting Append adds the value you enter to the existing value. For 
example, if the rot_ value is currently 3 and you enter 2, the rot_ value will 
become 5 (2+3).
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Message: As described above, you can create custom messages, post that value to 
the system, and have other interaction components react to that custom message. 
Messages have a “broadcast” effect, meaning that they exist throughout the scene 
once posted. Thus, one message can affect multiple targets.

Action Target: The Action Target pull-down menu displays a hierarchical list of 
objects in your scene. This appears similarly to the list found in the 
Hierarchy Viewer window and functions identically. This is the object on which the 
reactor will act. For example, you could set up a reactor to begin an animation when a 
sphere is clicked. In this case, you would attach the reactor to the sphere and select the 
animator as the target object.

Property: If you selected an action that requires you to select a property, you can select 
an available property using the Property pull-down menu.

Comments: If desired, you may enter up to 5 lines of text as comments or explanations 
about the current reactor and its function. This can help with complex scenes, 
especially if more than one person is working on a scene or if the scene is subject to 
periodic revision.

Depending on which combinations you select, different options and pull-downs will 
become enabled or disabled. This prevents inadvertent and impossible/useless/conflicting 
entries. Once you have finished making your selections, click OK to save your changes or 
Cancel to abort. You may access the reactor at any time by selecting the object it is 
attached to in the Hierarchy Viewer window and double-clicking the reactor.

TIMER REACTORS

A Timer Reactor is the same as a Simple Reactor (see “Simple Reactors” on page 115), 
except that it includes a Delay field. Enter your desired delay in seconds and fractions of a 
second in the Delay field. Once the reactor is triggered, the delay period will pass before 
the specified action occurs. Once you have finished making your selections, click OK to 
save your changes or Cancel to abort.
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MULTI REACTORS

A Multi Reactor combines a Simple and 
Timer reactor with added functionality. 
This type of reactor can be triggered by any 
or all of a set of incoming messages and 
can perform multiple actions. Multi 
Reactors appear as shown.

Incoming Message(s): Instead of the 
Incoming Message pull-down menu 
that appears in Simple and Timer 
Reactors, Multi Reactors have an 
Incoming Message(s) list. Check the 
boxes to the left of the messages you 
wish to use to trigger this reactor. You 
can check one or as many messages as 
you like. Use the scroll bar on the right 
side of this list if necessary to view the 
entire list of available messages. Both built-in and custom messages will appear here.

Any/All Messages: You can decide whether any one or all of your selected message(s) 
will trigger the reactor:

Any Message: Checking the Any Message radio button triggers the reactor when 
any one of your selected messages occurs.
All Messages: Checking the All Messages radio button only triggers the reactor 
once all selected messages have occurred. These messages may occur in any 
order.

Add/Remove Actions: See below.

Defining Actions in Multi Reactors

As described above, Multi Reactors can perform multiple actions. To specify more than 
one action:

1 Click the Add button once for each action you wish to add. For example, if you want 
the reactor to perform five actions, click this button four times.

2 Set the first action just as you would for a Simple Reactor, as described in “Simple 
Reactors” on page 115.

3 Move the Action Number slider until the number to the right of the slider changes to 
the next number (for example, from 1 to 2).

4 Set the second action just as you would for a Simple Reactor.
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5 Repeat Steps 3 and 4 for each subsequent action.

To delete an action, move the Action Number slider to the action you wish to delete and 
click the Delete button. Once you have finished making your selections, click OK to save 
your changes or Cancel to abort.

Multi Reactors will perform all of their specified actions when triggered by any or all 
messages in any order. Specified actions occur simultaneously. If you need triggers and/or 
actions to occur in a pre-defined order, you need to use a behavior (see “About Behaviors” 
on page 167, and below).

BEHAVIORS

At their root, behaviors are containers for other interaction components. Like reactors, you 
assign them on a per-object basis. You can reorder and group behaviors into hierarchies, 
thereby affecting multiple items. Do this by dragging and dropping, just like you would 
for any other items in the Hierarchy Viewer window (see “The Hierarchy Viewer 
Window” on page 106)

NOTE
BEHAVIORS REQUIRE YOUR VIEWERS TO HAVE VIEWPOINT MEDIA PLAYER 3.0.12 OR LATER INSTALLED. 
PLEASE CONTACT VIEWPOINT AT WWW.VIEWPOINT.COM FOR MORE DETAILS.

pro-V Studio’s Interaction room is where you work with behaviors. You may add and 
remove behaviors in any room where the Hierarchy Viewer window. In any room other 
than the Interaction room, however, a simplified dialog will appear when you double-
click a behavior. Please see “The Interaction Palette” on page 114 for more information 
about the Interaction room and working with behaviors.

NATIVE VET COMPONENTS

pro-V Studio includes support for native VET interaction components. We recommend 
using them if you import Viewpoint scenes that already have these components built in or 
if you wish to hand-edit published MTX files following publication from pro-V Studio or 
if you are an expert Viewpoint developer.

Please visit http://developer.viewpoint.com and http://xml.viewpoint.com for more 
information about native VET interaction components.
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INTERACTOR

Viewpoint Interactors are similar to Multi 
Reactors (see “Multi Reactors” on 
page 119), except that each action can have 
its own message. Interactors also contain a 
fairly primitive state machine that enables 
them to combine some features of a pro-V 
Studio Behavior. To use the state engine, 
enter a start state (optional) then enter a 
transition start and end state. An action 
inside the Interactor will only take place if 
the Interactor is in the transition start state 
specified for that action. If no transition 
start state is entered, there is no state 
requirement for the current action. If you 
want to use states, you should normally 
enter the same value for both the start and 
transition start states. The transition end 
state sets the state once the action is 
completed.

Name: Enter a name for the Interactor in the Name field. This must be an alpha or 
alphanumeric entry (no numeric entries). Further, this name must be unique and cannot 
contain any special or XML characters.

Active: Checking the Active checkbox enables the Interactor and allows it to process 
events, and vice-versa.

Never Handle: Checking the Never Handle checkbox causes events processed by the 
current Interactor to not be flagged as processed, allowing another Interactor to 
process the same event.

Ignore Handled: Checking the Ignore Handled checkbox allows you to set the 
Interactor so that it processes messages (events) even if some other Interactor has 
already processed the message.

Ignore Error: Checking the Ignore Error checkbox causes the Interactor to process 
messages that have already caused errors in other interaction components. Clearing 
this checkbox prevents Interactor processing in this case, meaning that the message is 
ignored if it previously caused an error.

Process: Checking the Process checkbox allows the Interactor to process events and 
pass them to its children, and vice-versa.
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Process Before Children: Checking the Process Before Children checkbox causes the 
Interactor to be processed before its children, meaning that it is always processed first.

Process After Children: Checking the Process After Children checkbox causes the 
Interactor to be processed after its children, meaning that it is always processed last. If 
both Process Before Children and Process After Children checkboxes are checked, 
the Interactor is processed twice: once before its children, and again afterward.

Propagate To Children: Checking the Propagate to Children checkbox causes the 
Interactor to propagate an event to its children and vice-versa.

Source Object: Use the Source Object pull-down menu to select the source object 
(scene element that originates the interactor). For example, if you select a cube and 
Mouse Left Click, the Interactor will process when a viewer left-clicks the cube.

Start State: Enter your desired starting state in the Start State field (see “Interactions” 
on page 47 for more information about states).

Incoming Message: The Incoming Message pull-down menu (2) allows you to specify 
the Interactor’s trigger. pro-V Studio includes messages. You can also create custom 
messages. For example, if another Interactor sends out the message MYMESSAGE, then 
you can set another Interactor to be triggered when MYMESSAGE is posted to the 
system. The built-in options are:

Scene Start: Selecting Scene Start triggers the Interactor when the scene begins 
playing on a viewer’s computer.
Mouse Left Down: Selecting Mouse Left Down triggers the Interactor when the 
left mouse button is pushed (but not necessarily released) while the mouse is on 
top of the selected object.
Mouse Left Click: Selecting Mouse Left Click triggers the Interactor when the 
left mouse button is clicked (pushed and released) while the mouse is on top of the 
selected object.
Mouse Left Up: Selecting Mouse Left Up triggers the Interactor when the left 
mouse button is released while the mouse is on top of the selected object.
Mouse Right Down: Selecting Mouse Right Down triggers the Interactor when 
the right mouse button is pushed (but not necessarily released) while the mouse is 
on top of the selected object.
Mouse Right Click: Selecting Mouse Right Click triggers the Interactor when the 
right mouse button is clicked (pushed and released) while the mouse is on top of 
the selected object.
Mouse Right Up: Selecting Mouse Right Up triggers the Interactor when the right 
mouse button is released while the mouse is on top of the selected object.
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Mouse Drag: Selecting Mouse Dragged triggers the Interactor when the mouse is 
dragged across the selected object (moved across the object with a button held 
down).
Mouse Move: Selecting Mouse Move triggers the Interactor when the mouse is 
moved across the selected object without a button pushed.
Mouse Enter: Selecting Mouse Enter triggers the Interactor when the mouse 
cursor crosses over any edge of the selected object. 
Mouse Exit: Selecting Mouse Exit triggers the Interactor when the mouse cursor 
goes beyond any edge of the selected object.
Mouse Drag Enter: Selecting Mouse Drag Enter triggers the Interactor when the 
mouse cursor crosses over any edge of the selected object while a button is 
pushed.
Mouse Drag Exit: Selecting Mouse Drag Exit triggers the Interactor when the 
mouse cursor goes beyond any edge of the selected object while a button is 
pushed.
Mouse Wheel: Selecting Mouse Wheel triggers the Interactor when the mouse 
wheel is moved while the mouse is on top of the selected object.
Key Down: Selecting Mouse Left Down triggers the Interactor when a key is 
pressed.
Key Up: Selecting Mouse Left Down triggers the Interactor when a key is 
released.
Custom: If you have custom messages output by other interaction components, 
you can use any of those messages to trigger another Interactor. Simply select 
your desired message from the pull-down menu. For example, if you create a 
message called MYMESSAGE, then MYMESSAGE will appear as an option in the 
menu.

Transition Start State: Enter your desired starting state for the current action in the 
Transition Start State field. If the Interactor is in the specified state for the current 
action (see “About Behaviors” on page 167), that action occurs.

Transition End State: If you want an action to create a state change, enter your desired 
ending state in the Transition End State field. For example, say you have a red object 
in your scene. Clicking the object should toggle between red and green. Set a start state 
and set up the desired action, being sure to specify an end state. Add an action and set 
the previous action’s end state as the new action’s start state. This allows subsequent 
clicks to toggle between states and toggle the object color from red to green.
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Action: Once the Interactor is triggered, it will perform the action specified in the 
Action pull-down menu (3). Available actions are:

Post Message: Selecting Post Message sends a custom message to the system 
when the current Interactor is triggered. For example, if you select this option and 
enter MYMESSAGE in the Message field (see below), then MYNMESSAGE will 
appear as an option in the Incoming Message pull-down (described above) and 
can be used to trigger another interaction component.
Set Built In Property: Selecting Set Built In Property allows you to set a 
property, which you select using the Property pull-down menu (see below).
Collapse: Selecting Collapse collapses the current object. Please see “Collapsing 
Objects” on page 37 for more information.
Uncollapse: Selecting Uncollapse uncollapses the selected object and children. 
Collapsing and uncollapsing objects allows you to create more complex scenes 
while conserving resources.
Hide: Selecting Hide makes the current object invisible. Hidden objects are still 
present in the scene and can have interaction components, etc. They also consume 
resources.
Show: Selecting Show makes the current object visible.
Set Object Opacity: Selecting Set Object Opacity allows you to specify the 
object’s opacity in the Data field.
Drag Object: Selecting Drag Object allows the viewer to drag the current object 
to a new location.
Set Material Diffuse Color: Selecting Set Material Diffuse Color allows you to 
set the current object’s color.
Set Material Opacity: Selecting Set Material Opacity allows you to specify the 
opacity of the object’s material (not the object itself) in the Data field.
Trigger Animation: Selecting Trigger Animation allows you to trigger an action 
animator that begins playing when the Interactor is triggered.
Start Animation: Selecting Start Animation starts the selected animator.
Stop Animation: Selecting Stop Animation stops the selected animator.
Load MTX: Selecting Load MTX loads the specified Viewpoint MTX file.
Execute VB Script: Selecting Execute VB Script loads and executes a Visual 
Basic (VB) script.
Execute JavaScript: Selecting Execute JavaScript loads and executes a Java 
Script script.
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Value: Some of the actions allow you to send data to the system. For example, posting 
a message allows you to enter a custom message as described above. The Value field 
(4) is where you enter the data to be applied by the Interactor. The displayed name of 
this field changes depending on the action you select using the Action pull-down 
menu. For some values, you can select the following by clicking the arrow to the left 
of the field name and using the pull-down menu:

Value: Selecting Value sends the specified value to the selected target.
Append: Selecting Append adds the value you enter to the existing value. For 
example, if the rot_ value is currently 3 and you enter 2, the rot_ value will 
become 5 (2+3).
Message: As described above, you can create custom messages, post that value to 
the system, and have other interaction components react to that custom message. 
Messages have a “broadcast” effect, meaning that they exist throughout the scene 
once posted. Thus, one message can affect multiple targets.

Action Target: The Action Target pull-down menu displays a hierarchical list of 
objects in your scene. This appears similarly to the list found in the 
Hierarchy Viewer window and functions identically. This is the object on which the 
Interactor will act. For example, you could set up an Interactor to begin an animation 
when a sphere is clicked. In this case, you would attach the Interactor to the sphere and 
select the animator as the target object.

Property: If you selected an action that requires you to select a property, you can select 
an available property using the Property pull-down menu.

Add/Remove Actions: See below.

Comments: If desired, you may enter up to 5 lines of text as comments or explanations 
about the current reactor and its function. This can help with complex scenes, 
especially if more than one person is working on a scene or if the scene is subject to 
periodic revision.

Defining Actions in Interactors

As described above, Interactors can perform multiple actions. To specify more than one 
action:

1 Click the Add button once for each action you wish to add. For example, if you want 
the Interactor to perform five actions, click this button four times.

2 Set the first action using the Action pull-down menu as described above.

3 Move the Event Handler Number slider until the number to the right of the slider 
changes to the next number (for example, from 1 to 2).

4 Set the second action just as you did in Step 2, above.
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5 Repeat Steps 3 and 4 for each subsequent action.

To delete an action, move the Event Handler Number slider to the action you wish to 
delete and click the Delete button. Once you have finished making your selections, click 
OK to save your changes or Cancel to abort.

ACTION LIST

An Action List can trigger actions such as 
playing animations, posting messages, etc. 
If you add an Action List to your scene, 
you can call it by name from the Action 
field of any other interaction component.

You can specify an arbitrary number of 
actions and an arbitrary number of 
parameters per action and then call these 
parameters and pass values to them using 
other interaction components. Think of 
parameters as placeholders for real objects 
and values. You supply the actual values 
for these parameters when configuring the 
calls to these parameters and the Action 
List performs the specified action(s) using 
the parameters and values given to it by 
other interaction components. Thus, an Action List functions similarly to a programming 
function.

Parameter names must be entered in plain ASCII text using no special characters or 
spaces.

Name: Enter your desired name for the Action List in the Name field.

Parameter Names: The Parameter Names area lists the parameters in the current 
Action List. Selecting a parameter and then clicking it again allows you to rename the 
selected parameter.

Add Parameter: To add a parameter, click the Delete Parameter button. A new 
parameter appears in the Parameter Names area.

Delete Parameter: To delete a parameter, select it in the Parameter Names area and 
click the Delete Parameter button.

Value: Some of the actions allow you to send data to the system. For example, posting 
a message allows you to enter a custom message as described above. The Value field 
(4) is where you enter the data to be applied by the Action List. The displayed name of 

AUTHORED BY ANTHONY HERNANDEZ - (415)786-2081 - anthony94122@outlook.com



127

WORKSPACE REFERENCE

this field changes depending on the action you select using the Action pull-down 
menu. For some values, you can select the following by clicking the arrow to the left 
of the field name and using the pull-down menu:

Value: Selecting Value sends the specified value to the selected target.
Append: Selecting Append adds the value you enter to the existing value. For 
example, if the rot_ value is currently 3 and you enter 2, the rot_ value will 
become 5 (2+3).
Message: As described above, you can create custom messages, post that value to 
the system, and have other interaction components react to that custom message. 
Messages have a “broadcast” effect, meaning that they exist throughout the scene 
once posted. Thus, one message can affect multiple targets.

Action Target: The Action Target pull-down menu displays a hierarchical list of 
objects in your scene. This appears similarly to the list found in the 
Hierarchy Viewer window and functions identically. This is the object on which the 
Action List will act. For example, you could set up an Action List to begin an 
animation when a sphere is clicked. In this case, you would attach the it to the sphere 
and select the animator as the target object

Action Target: The Action Target pull-down menu displays a hierarchical list of 
objects in your scene.scene. This appears similarly to the list found in the 
Hierarchy Viewer window and functions identically. This is the object on which the 
Action List will act. For example, you could set up an Action List to begin an 
animation when a sphere is clicked. In this case, you would attach it to the sphere and 
select the animator as the target object.

Property: If you selected an action that requires you to select a property, you can select 
an available property using the Property pull-down menu.

Add/Remove Actions: See “Defining Actions in Interactors” on page 125, above.

Comments: If desired, you may enter up to 5 lines of text as comments or explanations 
about the current reactor and its function. This can help with complex scenes, 
especially if more than one person is working on a scene or if the scene is subject to 
periodic revision. 

Once you have finished making your selections, click OK to save your changes or Cancel 
to abort.
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Action List Example

The following example shows a simple Action List:

1 Create a new scene and add a sphere and a pyramid. Locate the pyramid above the 
sphere.

2 Add an Action List to the sphere.

3 Add two params by clicking the Add Parameter button twice. By default, the new 
parameters are named param1 and param2. Leave the default names.

4 In the Action field, select Show. In the Action Target field, select or type param1.

5 Click the Add button to add an action.

6 In the Action field, select Set Object Opacity. In the Action Target field, select or 
type param2. Click OK when finished.

7 Now add a Simple Reactor to the pyramid and open its dialog.

8 Type ActionList_0 (case sensitive) in the Action field. The Data field now says 
param1. Select or type Sphere_0 (also case-sensitive). Then use the pull-down 
menu above the field to select param2. Enter 0.5 in the field. Click OK when 
finished.

9 Select the sphere and make it invisible by clearing the Visible checkbox in the 
Settings tab of the Object Attributes palette.

10 Click the Play button in the Play Controls and click the pyramid. The sphere appears 
semi-transparent.

EVENT COLLECTION

An Event Collection collects one or more incoming 
messages and generates an outgoing message. Event 
Collections appear as shown. You can make the 
following selections:

Name: Enter your desired name for the Event 
Collection in the Name field.

Incoming Message(s): Event Collections have an 
Incoming Message(s) list. Check the boxes to 
the left of the messages you wish to use to 
trigger this Event Collection. You can check one 
or as many messages as you like. Use the scroll bar on the right side of this list if 
necessary to view the entire list of available messages. Both built-in and custom 
messages will appear here. If all of the selected messages occur, the Event Collection 
will generate the outgoing message.
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Message: Enter your desired message in the Message field.

Delay: Enter your desired delay in seconds and fractions of a second in the Delay field. 
Once the Event Collection is triggered, the delay period will pass before the specified 
action occurs.

Comments: If desired, you may enter up to 5 lines of text as comments or explanations 
about the current reactor and its function in the Comments field. This can help with 
complex scenes, especially if more than one person is working on a scene or if the 
scene is subject to periodic revision. 

Once you have finished making your selections, click OK to save your changes or Cancel 
to abort.
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MODIFIERS

Modifiers allow you to add text or image-based descriptions, sounds, and special effects to 
your pro-V Studio scenes. There are four types of modifiers: Text Hotspot, Image Hotspot, 
HyperView, and Sound.

TEXT HOTSPOT MODIFIER

Text Hotspots allow you to add a 
pop-up text callout that is attached 
to your selected object. They 
appear as shown. and have the 
following options:

Name (1): Enter your desired 
name for the Text Hotspot in 
the Name field.

Switchable (2): Checking the 
Switchable checkbox causes 
the modifier to be enabled and 
disabled using messages. For 
example, you could set up a 
modifier to only display when 
the mouse cursor is over the 
selected object. Clearing this 
checkbox causes the modifier 
to always be active.

Enable Message: Use the Enable Message pull-down menus to select your 
desired enabling message. You can select from the list of built-in and custom 
messages. Please see “Interactor” on page 121 for a complete list of built-in 
messages.
Disable Message: Use the Disable Message pull-down menus to select your 
desired disabling message. You can select from the list of built-in and custom 
messages.

Text (3): Enter the text you wish the Text Hotspot modifier to display in the Text field.

Choose (4): Clicking the Choose button opens a Font dialog containing all of the 
following options. You can make your selection using this dialog box and/or any of the 
methods outlined below.
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Text Formatting Options (5): You 
have the following text formatting 
options. Each option applies to the 
entire text block; you cannot 
format different portions of the 
same hotspot differently:

Italics (A): Clicking the Italics 
box makes your text italic.
Underline (B): Clicking the Underline box places a line underneath your text.
Strikethrough (C): Clicking the Strikethrough box places a line through your 
text.
Bold (D): Clicking the Bold box makes your text bold.
Left Align (E): Clicking the Left Align box justifies the text on its own left side.
Center Align (F): Clicking the Center Align box justifies the text on its own 
center.
Right Align (G): Clicking the Right Align box justifies the text on its own right 
side.
Text Font (H): Clicking the Text Font label opens the Font dialog box. Use the 
pull-down menus and checkboxes to make your selection. This is the same as 
clicking the Choose button, above. The Font dialog box is OS-standard. Please 
refer to your operating system documentation for information using this dialog 
box, adding fonts, etc.
Text Size (I): Click and drag the Text Size dial to set the text size in points. You 
may also click the text to the right of this dial and directly enter the font size in the 
field that appears.
Language (J): Use the Language pull-down menu to select your desired language 
for the hotspot.

Always Visible (6): Checking the Always Visible checkbox forces the hotspot to 
always remain in the camera’s field of vision, and vice-versa. This option allows the 
hotspot to move as needed as the camera moves.

Constrain To Window (7): Checking the Constrain To Window checkbox causes the 
text to remain within the bounds of the original scene window if a HyperView 
Modifier is being used in your scene. Clearing this checkbox allows the hotspot to 
extend into the HyperView area. Please see “HyperView Modifier” on page 136 for 
more information about HyperView.

Cast Shadow (8): Checking the Cast Shadow checkbox causes the hotspot to cast a 
shadow, and vice-versa.
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Shadow Radius: If Cast Shadow is enabled, use the Shadow Radius to define the 
radius of the shadow surrounding the hotspot. Alternatively, you can enter your 
desired value in the field to the right of the slider.

Render Layer (9): Enter your desired render layer in the Render Layer field. Please 
see “About Render Layers” on page 23 for more information about render layers.

Color (10): Checking the Color box opens an OS-standard Color Picker. This defines 
the hotspot’s text and line colors.

Anchor Hotspot (11): Checking the Anchor Hotspot checkbox anchors the hotspot in 
its current position no matter how the camera moves, and vice-versa. When this option 
is enabled, you have the following options:

Origin: Use the Origin pull-down menu to select which window corner to use as 
the anchor.
Relation: Use the Relation pull-down menu to determine if you want the hotspot 
anchored using pixels or percent of window size. This affects the Anchor 
Position dials, below.
Anchor Position XY: Click and drag the Anchor Position X and Anchor Position 
Y dials to set the X and Y anchor points for the hotspot. You can also enter your 
desired value in the fields to the right of the dials.

HotSpot Line (12): Checking the Hotspot Line checkbox creates a line between the 
hotspot and the target object, and vice-versa. When checked, you have the following 
options:

Line Origin XY: Click and drag the Line Origin X and Line Origin Y dials to 
adjust the connecting line’s origin point location at the target object end. You can 
also enter your desired value in the fields to the right of the dials.
Line Destination XY: Click and drag the Line Destination X and Line 
Destination Y dials to adjust the connecting line’s destination point location at 
the hotspot end. You can also enter your desired value in the fields to the right of 
the dials.
Distance From HotSpot: Drag the Distance From HotSpot slider to set the 
hotspot’s distance from the target object. You can also enter your desired value in 
the field to the right of the slider.

Item Offset XYZ (13): Click and drag the Item Offset X, Item Offset Y, and Item 
Offset Z dials to adjust the hotspot’s offset (shift) along the selected axis or axes. You 
can also enter your desired value in the fields to the right of the dials.
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Comments (14): If desired, you may enter up to 5 lines of text as comments or 
explanations about the current reactor and its function in the Comments field. This 
can help with complex scenes, especially if more than one person is working on a 
scene or if the scene is subject to periodic revision

Edit Camera Controls (15): These Edit Camera controls are identical to those found 
in the Scene Setup window. Please see “Edit Camera Controls” on page 102 for more 
information.

Once you have finished making your selections, click OK to save your changes or Cancel 
to abort.

IMAGE HOTSPOT MODIFIER

Image Hotspots allow you to add a 
text callout to your selected 
object. They appear as shown and 
have the following options:

Name (1): Enter your desired 
name for the Image Hotspot in 
the Name field.

Switchable (2): Checking the 
Switchable checkbox causes 
the modifier to be enabled and 
disabled using messages. For 
example, you could set up a 
modifier to only display when 
the mouse cursor is over the 
selected object. Clearing this 
checkbox causes the modifier 
to always be active.

Enable Message: Use the 
Enable Message pull-
down menus to select 
your desired enabling message. You can select from the list of built-in and custom 
messages. Please see “Interactor” on page 121 for a complete list of built-in 
messages.
Disable Message: Use the Disable Message pull-down menus to select your 
desired disabling message. You can select from the list of built-in and custom 
messages.
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Image Load Controls (3): The Image Load controls allow you to load the image into 
the hotspot. You have the following options:

Load Images From: The Load Images From pull-down menu allows you to 
specify where to locate the image for the hotspot. Selecting File allows you to 
import an image that is not part of your Library or project assets. If you have any 
valid images in your Library and/or project assets, those selections will display a 
sub-menu with all available choices.
Load: If you selected File in the pull-down menu, clicking the Load button opens 
a standard Open dialog that allows you to browse for and import your desired 
image. Imported images are added to the project assets.

Always Visible (4): Checking the Always Visible checkbox forces the hotspot to 
always remain in the camera’s field of vision, and vice-versa. This option allows the 
hotspot to move as needed as the camera moves.

Constrain To Window (5): Checking the Constrain To Window checkbox causes the 
text to remain within the bounds of the original scene window if a HyperView 
Modifier is being used in your scene. Clearing this checkbox allows the hotspot to 
extend into the HyperView area. Please see “HyperView Modifier” on page 136 for 
more information about HyperView.

Cast Shadow (6): Checking the Cast Shadow checkbox causes the hotspot to cast a 
shadow, and vice-versa.

Shadow Radius: If Cast Shadow is enabled, use the Shadow Radius to define the 
radius of the shadow surrounding the hotspot. Alternatively, you can enter your 
desired value in the field to the right of the slider.: 

Color (7): Checking the Color box opens an OS-standard Color Picker. This defines 
the hotspot’s connecting line color.

Render Layer (8): Enter your desired render layer in the Render Layer field. Please 
see “About Render Layers” on page 23 for more information about render layers.

Anchor Hotspot (9): Checking the Anchor Hotspot checkbox anchors the hotspot in 
its current position no matter how the camera moves, and vice-versa. When this option 
is enabled, you have the following options:

Origin: Use the Origin pull-down menu to select which window corner to use as 
the anchor.
Relation: Use the Relation pull-down menu to determine if you want the hotspot 
anchored using pixels or percent of window size. This affects the Anchor 
Position dials, below.
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Anchor Position XY: Click and drag the Anchor Position X and Anchor Position 
Y dials to set the X and Y anchor points for the hotspot. You can also enter your 
desired value in the fields to the right of the dials.

HotSpot Line (10): Checking the Hotspot Line checkbox creates a line between the 
hotspot and the target object, and vice-versa. When checked, you have the following 
options:

Line Origin XY: Click and drag the Line Origin X and Line Origin Y dials to 
adjust the connecting line’s origin point location at the target object end. You can 
also enter your desired value in the fields to the right of the dials.
Line Destination XY: Click and drag the Line Destination X and Line 
Destination Y dials to adjust the connecting line’s destination point location at 
the hotspot end. You can also enter your desired value in the fields to the right of 
the dials.
Distance From HotSpot: Drag the Distance From HotSpot slider to set the 
hotspot’s distance from the target object. You can also enter your desired value in 
the field to the right of the slider.

Item Offset XYZ (11): Click and drag the Item Offset X, Item Offset Y, and Item 
Offset Z dials to adjust the hotspot’s offset (shift) along the selected axis or axes. You 
can also enter your desired value in the fields to the right of the dials.

Comments (12): If desired, you may enter up to 5 lines of text as comments or 
explanations about the current reactor and its function in the Comments field. This 
can help with complex scenes, especially if more than one person is working on a 
scene or if the scene is subject to periodic revision.

Edit Camera Controls (13): These Edit Camera controls are identical to those found 
in the Scene Setup window. Please see “Edit Camera Controls” on page 102 for more 
information: 

Once you have finished making your selections, click OK to save your changes or Cancel 
to abort.
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HYPERVIEW MODIFIER

HyperView modifiers allow your 
scene or selected objects to go 
beyond the normal scene window 
when playing on viewers’ 
computers, thereby creating a 
truly immersive experience.

Name (1): Enter your desired 
name for the HyperView in the 
Name field.

Enable Message (2): Use the 
Enable Message pull-down 
menus to select your desired 
enabling message. You can 
select from the list of built-in 
and custom messages. To 
avoid confusion and possible settings collisions, only one HyperView modifier can be 
used at once. All are therefore switchable. Please see “Interactor” on page 121 for a 
complete list of built-in messages.

Disable Message (3): Use the Disable Message pull-down menus to select your 
desired disabling message. You can select from the list of built-in and custom 
messages.

Relative Coordinates (4): The Relative Coordinates controls allow you to specify the 
reference frame and size of the HyperView window.Your available options are:

Player: Checking the Player radio button makes the HyperView window relative 
to the VMP window when playing scenes.
Browser: Checking the Browser radio button makes the HyperView window 
relative to the viewer’s Web browser when playing scenes.
Desktop: Checking the Desktop radio button makes the HyperView window 
relative to the viewer’s desktop when playing scenes.
Left: Click and drag the Left dial to specify the number of pixels to the left of the 
selected reference (player, browser, or desktop) to expand the HyperView 
window. You may also enter your desired value in the field to the right of the dial.
Right: Click and drag the Right dial to specify the number of pixels to the right of 
the selected reference (player, browser, or desktop) to expand the HyperView 
window. You may also enter your desired value in the field to the right of the dial.

AUTHORED BY ANTHONY HERNANDEZ - (415)786-2081 - anthony94122@outlook.com



137

WORKSPACE REFERENCE

Top: Click and drag the Top dial to specify the number of pixels above of the 
selected reference (player, browser, or desktop) to expand the HyperView 
window. You may also enter your desired value in the field to the right of the dial.
Bottom: Click and drag the Bottom dial to specify the number of pixels below the 
selected reference (player, browser, or desktop) to expand the HyperView 
window. You may also enter your desired value in the field to the right of the dial.

Preserve Camera Controls (5): 
Based on rectangle: Checking the Based on rectangle radio button preserves the 
expanded view as if that expansion was the normal view. The camera is 
repositioned so as to capture the same view of the larger scene window. Content in 
the scene therefore appears larger, which can create dramatic effects.
Preserve for 2D Media Atoms Only: Checking the Preserve for 2D Media 
Atoms radio button preserves the camera settings for 2D objects in your scene. 
3D objects will appear larger.
Preserve for All Media: Checking the Preserve for All Media radio button leaves 
the camera and content in their current positions. Since the window is larger, you 
may see more of the objects in your scene but they will not appear larger.
Preserve for 3D Media Atoms Only: Checking the Preserve for 3D Media 
Atoms radio button preserves the camera settings for 3D objects in your scene. 
2D objects will appear larger.

Comments (6): If desired, you may enter up to 5 lines of text as comments or 
explanations about the current reactor and its function in the Comments field. This 
can help with complex scenes, especially if more than one person is working on a 
scene or if the scene is subject to periodic revision.

Once you have finished making your selections, click OK to save your changes or Cancel 
to abort.
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SOUND MODIFIER

Sound modifiers allow you to add sound to 
your selected object/scene. They appear as 
shown and have the following options:

Name (1): Enter your desired name for 
the Sound modifier in the Name field.

Switchable (2): Checking the 
Switchable checkbox causes the 
modifier to be enabled and disabled 
using messages. For example, you 
could set up a modifier to only display 
when the mouse cursor is over the 
selected object. Clearing this checkbox 
causes the modifier to always be active.

Enable Message: Use the Enable 
Message pull-down menus to 
select your desired enabling message. You can select from the list of built-in and 
custom messages. Please see “Interactor” on page 121 for a complete list of built-
in messages.
Disable Message: Use the Disable Message pull-down menus to select your 
desired disabling message. You can select from the list of built-in and custom 
messages.

Path (3): See “Using Audio in Scenes” on page 139, below.

Clamp (4): The Clamp dial controls the number of times the sound plays. Click and 
drag the dial or enter your desired value in the field.

Comments (5): If desired, you may enter up to 5 lines of text as comments or 
explanations about the current reactor and its function in the Comments field. This 
can help with complex scenes, especially if more than one person is working on a 
scene or if the scene is subject to periodic revision.

Once you have finished making your selections, click OK to save your changes or Cancel 
to abort.
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Using Audio in Scenes

You cannot directly import audio into your Library or project assets. To use audio in your 
scenes:

1 Download and install the Viewpoint TalkNow converter utility from http://
www.viewpoint.com.

2 Convert your audio file to the Viewpoint MTS format using the converter. Please see 
the TalkNow documentation for information on using this utility.

3 Add a Sound Modifier hotspot to an object.

4 Enter a path to the MTS file you created in Step 2 in the Path field or click the Browse 
button to open a standard Browse dialog allowing you to locate the file. This path is 
converted to a relative path when your scene is published.

5 Enter your other settings in the Sound Modifier as described above.

The TalkNow converter is optimized for spoken text. Results with other audio may vary.
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Chapter 25: The Play Controls 
Palette

our scene is complete. Congratulations! Before publishing it, you should perform 
some testing and dry runs to ensure that it functions as you intended before 
publishing it. The Play Controls palette is the place to do this. This palette 

appears in the Scene Setup, Materials, Animation, and Interaction rooms.

As described in “Modes” on page 20, pro-V Studio runs in two modes: Edit and Run. The 
Play Controls palette lets you switch between these modes to run and troubleshoot your 
scene. While in Run mode, all windows and palettes disappear from your current room 
except for the Scene Display window and the Play Controls palette. All palettes reappear 
when pro-V Studio switches back to Edit mode.

PLAY CONTROLS PALETTE

The Play Controls window has three buttons. From left to right, 
these are:

Play from Start: Clicking the Play from Start button places 
pro-V Studio in Run mode and plays your scene from the 
beginning.

Stop: Clicking the Stop button stops scene playback, returns the scene to its beginning 
and resets all changed states, and returns pro-V Studio to Edit mode.

Play/Pause: While your scene is stopped, clicking the Play button places pro-V Studio 
in Run mode and continues playing your scene from where it stopped. While your 
scene is playing, clicking the Pause button returns pro-V Studio to Edit mode and 
freezes scene playback at the current location.

Y
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Chapter 26: The Scene Setup Room
he Scene Setup room is where you add assets to your scene and complete most of 
the basic arranging prior to adding materials, animations, and interactions. This 
room contains the following windows and palettes:

Scene Display Window: Please see “The Scene Display Window” on page 100 for 
more information about the Scene Display window.

Hierarchy Viewer Window: Please see “The Hierarchy Viewer Window” on page 106 
for more information about the Hierarchy Viewer window.

Media Palette: Please see “The Media Palette” on page 108 for more information 
about the Media palette.

Simple Animations Palette: Please see “The Simple Animations Palette” on page 110 
for more information about the Simple Animations palette.

Interaction Palette: Please see “The Interaction Palette” on page 114 for more 
information about the Interaction palette.

Play Controls Palette: Please see “The Play Controls Palette” on page 140 for more 
information about the Play Controls palette.

Object Attributes Palette: Please see below for more information about the Object 
Attributes palette.

OBJECT ATTRIBUTES PALETTE

The Object Attributes palette allows you 
to access and edit object attributes. This 
palette is available in the Scene Setup 
room. You may also access it from any pro-V Studio room by selecting 
Object>Attributes. Available attributes will vary by type of object (asset) selected. As 
shown, this palette has three tabs.

NOTE
IF YOU HAVE THE RUNTIME CAMERA SELECTED, THE OBJECT SETTINGS PALETTE WILL DISPLAY THE CAMERA 
TAB, WHICH IS DISCUSSED BELOW.

T
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POSITION TAB

The Object Settings palette’s Position tab appears as follows:

This tab controls an object’s transformation. Please refer to “Transformation” on page 31 
for more information about transformations. The available options are:

World/Object Space: Check the appropriate radio button to determine if 
transformations should occur in World Space or Object Space. Please see “World vs. 
Object Coordinates” on page 30 for more information about world vs. object space.

Rotate XYZ: Use the Rotate X, Rotate Y, and/or Rotate Z dials to rotate the object 
along the selected axis. Clicking a number next to a dial opens a text field, allowing 
you to directly enter your desired value. Please see “Rotation” on page 32 for more 
information about rotation.

Translate XYZ: Use the Translate X, Translate Y, and/or Translate Z dials to move 
the object along the selected axis. Clicking a number next to a dial opens a text field, 
allowing you to directly enter your desired value. Please see “Translation” on page 32 
for more information about translation.

Shear XY, XZ, YZ: Use the Shear XY, Shear XZ, and/or Shear YZ dials to shear (or 
stretch) the object along the selected axes. Clicking a number next to a dial opens a 
text field, allowing you to directly enter your desired value. Please see “Shear” on 
page 33 for more information about shear.

Scale All: Use the Scale All dial to enlarge or shrink the object uniformly along all 
three axes. Clicking a number next to a dial opens a text field, allowing you to directly 
enter your desired value. Please see “Scale” on page 33 for more information about 
scale.

Scale XYZ: Use the Scale X, Scale Y, and/or Scale Z dials to enlarge or shrink the 
object along the selected axis. Clicking a number next to a dial opens a text field, 
allowing you to directly enter your desired value. Please see “Scale” on page 33 for 
more information about scale.
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SETTINGS TAB

The Object Settings palette’s Settings tab appears as follows:

This tab controls an object’s general settings. The available options are:

Name: Enter your desired name for the selected object by clicking the Name field and 
entering your desired text. Each object must be uniquely named to prevent confusion. 
pro-V Studio does not allow duplicate names to be used.

Render Layer: Enter your desired render layer in the Render Layer field. Please see 
“About Render Layers” on page 23 for more information about using render layers.

Prelite Color: Clicking the Prelite Color box opens a standard Color Picker, which 
allows you to select the desired pre-light color for the currently selected object.

Opacity: The Opacity slider allows you to set the selected material’s transparency. 
You can also enter your desired value (in percent) in the field to the right of the slider. 
A value of 0 indicates that the material is completely transparent, and a value of 1 
indicates complete opacity.

NOTE
THE DIFFERENCE BETWEEN OBJECT AND MATERIAL OPACITY CAN SEEM CONFUSING AT FIRST. EXPERIMENT 
WITH OBJECTS THAT HAVE MORE THAN ONE MATERIAL GROUP TO SEE THE DIFFERENCE.

Pass Click On/Off/Parent: Select your desired mouse click behavior using the Pass 
Click radio buttons, as follows:

On: Checking the Pass Click On radio button causes mouse clicks to pass through 
the selected object, meaning that the object will not capture a mouse click. 
Enabling this option allows an object that is behind another object to record a 
mouse click.
Off: Checking the Pass Click Off radio button causes mouse clicks to be caught 
by the selected object, meaning that the object will record a mouse click. This is 
useful for interaction components. Please see “Interactions” on page 47 for more 
information about using interaction components inside pro-V Studio. When this 
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option is enabled, objects that are behind the currently selected object will not 
record mouse clicks.
Parent: Checking the Pass Click Parent radio button causes mouse clicks to 
either pass through or be caught by the selected object based on the setting used 
by that object’s parent.

Visible: Checking the Visible checkbox makes the selected object visible, and vice-
versa. Invisible objects remain instantiated and can have all of the attributes of visible 
objects. Use invisible objects with caution, since they will use resources and increase 
the size of your published scene.

Collapsed: Checking the Collapsed checkbox collapses the current object and vice-
versa. Please see “Collapsing Objects” on page 37 for more information.

Do Shadow: Checking the Do Shadow checkbox causes the selected object to cast a 
shadow and vice-versa.

Billboard: Checking the Billboard checkbox causes the selected object’s positive Z 
axis to face the Runtime camera at all times no matter what else is happening in the 
scene. Clearing this checkbox disables this option. This is useful if, for example, you 
always want an object facing the viewer.

Z-Buffer: The Z-Buffer option determines the 
perceived depth of a scene and which geometries 
are ahead or behind other geometries. Clearing 
the Z-Buffer checkbox optimizes your scene so 
that only polygons that are showing are rendered 
(right, on right), and vice-versa (right, on left).

Edge Flag: The Edge Flag pull-down menu allows you to determine how an object’s 
edges are drawn. Your available options are:

Draw No Edges: Selecting Draw No Edges makes the 
selected object appear normally with no edges drawn, and 
vice-versa:

Draw All Edges: Selecting Draw All Edges displays the edges 
of all polygons comprising the selected object, and vice-versa:
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Draw Quad Edges: Selecting Draw Quad Edges displays the 
edges of all four-sided polygons comprising the selected 
object, and vice-versa:

Draw Solid Edges: Selecting Draw Solid Edges displays the 
object’s object edges, and vice-versa:

Draw Edges Only: Selecting Draw Edges Only only displays 
the object’s object edges, and vice-versa:

GEOMETRY TAB

The Object Settings palette’s Geometry tab controls a 3D object’s 
geometry settings, giving you detailed control over how the geometry 
will appear in an end viewers’ computer. This tab appears as follows:

The available options in this tab are:

Backface Direction: The Backface Direction radio buttons determine which direction 
the selected object’s polygons face.

On: Checking the Backface Direction On radio button reverses the normals of 
back-facing polygons.
Off: Checking the Backface Direction Off radio button leaves polygon normals 
facing in their original directions.
Flip All Polygons: Checking the Flip All Polygons radio button reverses all 
normals. Please see “Normals” on page 35 for more information.
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Backface Culling: Checking the Backface Culling checkbox saves resources by 
rendering only those portions of the selected object that are visible from the viewer’s 
location. Clearing this checkbox renders all portions of the object whether visible or 
not.

Antialiasing: Antialiasing is a process of 
applying a small amount of blur to object 
edges to smooth them and avoid a “pixelated” 
appearance. The images show a test render 
both without (left) and with (right) antialiasing 
enabled.

Enabling antialiasing makes objects look better on 
viewers’ computers but also increases the amount of resources needed for rendering. 
Please see “Advanced Settings” on page 87 for information about forcing limits on the 
amount of time a viewer’s computer will spend antialiasing objects. Check the appropriate 
Antialiasing checkbox(es) to apply antialiasing as follows:

Creases: Checking the Creases checkbox applies antialiasing at points where an 
object creases or folds sharply. If this checkbox is checked, you can choose the 
desired crease angle at which to begin applying antialiasing using the Crease 
Angle slider (see below).
Open Edges: Checking the Open Edges checkbox antialiases open edges on the 
selected object (such as the rim of a bucket) and vice-versa.
Materials: Checking the Materials checkbox antialiases the edges of the current 
object’s material(s) and vice-versa.

Crease Angle: The Crease Angle slider allows you to specify the crease angle at 
which antialiasing will be applied to the current object. You can also specify your 
desired value by entering it in the field on the right of the slider. Decreasing this angle 
makes your objects appear smoother but consumes more resources.

Specular Wrap: The Specular Wrap slider enhances the lightmap’s effect (see “Light 
Maps” on page 45 for more information about lightmaps). Valid values are 0 to 10. 
You can also specify your desired value by entering it in the field on the right of the 
slider.
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CAMERA TAB

The Camera tab appears in place of the three tabs discussed above whenever you have the 
Runtime camera selected. This tab has the following options:

Pivot XYZ: Use the Pivot X, Pivot Y, and/or Pivot Z dials to 
rotate the camera about its own axes, as shown here. You can also 
enter your desired value in the fields to the right of the dials.

Orbit Distance: Use the Orbit 
Distance dial to specify the camera’s 
distance from the global origin, as 
shown. You can also enter your desired 
value in the fields to the right of the 
dials.

Rotate3D XYZ: Use the Rotate3D X, Rotate3D Y, and/
or Rotate3D Z dials to rotate the camera about the 
global axes, as shown here. You can also enter your 
desired value in the fields to the right of the dials.

Translate3D XYZ: Use the Translate3D X, Translate3D 
Y, and/or Translate3D Z dials to move the Runtime camera 
along the selected axis. You can also enter your desired value 
in the fields to the right of the dials.

Scale3D XYZ: Use the Scale3D X, Scale3D Y, 
and/or Scale3D Z dials to zoom in or out along 
the selected axis. You can also enter your 
desired value in the fields to the right of the 
dials.

Scale 3D All: Use the Scale3D All dial to 
zoom in or out along all three axes at once. 
You can also enter your desired value in 
the fields to the right of the dials.
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Chapter 27: The Materials Room
nce you have built your scene in the Scene Setup room, you are ready to assign 
materials to the objects in your scene using the Materials room. pro-V Studio 
gives you powerful control over your scene’s look and feel. Please see “Materials 

& Lights” on page 42 for information about materials. This room contains the following 
windows and palettes:

Scene Display Window: Please see “The Scene Display Window” on page 100 for 
more information about the Scene Display palette.

Hierarchy Viewer Window: Please see “The Hierarchy Viewer Window” on page 106 
for more information about the Hierarchy Viewer window.

Media Palette: Please see “The Media Palette” on page 108 for more information 
about the Media palette.

Material Settings Palette: Please see below for more information about the Material 
Settings palette.

Maps Palette: Please see below for more information about the Maps palettes. pro-V 
Studio has four Maps palettes:

Texture Palette: The Texture palette is where you assign texture maps (see 
“Texture Maps” on page 44) to your selected object. This palette is discussed in 
“Texture Tab” on page 151.
Alpha Channel: The Alpha Channel palette is where you assign alpha maps (see 
“Alpha Channel (Transparency Maps)” on page 44) to your selected object. This 
palette is discussed in “Alpha Channel Palette” on page 155.
Bumpmap Texture: The Bumpmap Texture palette is where you assign bump 
maps (see “Bump Maps” on page 44) to your selected object. This palette is 
discussed in “Bump Map Palette” on page 155.
Light Map: The Light Map palette is where you assign light maps (see “Light 
Maps” on page 45) to your selected object. This palette is discussed in “Light Map 
Palette” on page 156.

Simple Animations Palette: Please see “The Simple Animations Palette” on page 110 
for more information about the Simple Animations palette.

Play Controls Palette: Please see “The Play Controls Palette” on page 140 for more 
information about the Play Controls palette

O
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The following topics describe the Materials room interface in detail. The last topic in this 
chapter, “Working With Materials” on page 156, provides some tips on working with 
materials inside pro-V Studio.

MATERIAL SETTINGS PALETTE

The Material Settings palette has three tabs: Material, Texture, and Advanced. These 
tabs appear as follows:

The following topics discuss each Material Settings tab in detail.

MATERIAL TAB

The Materials tab allows you to set certain global options for the currently selected 
object’s material. It has the following functionality:

Name: Enter your desired name in the Name field. Special characters are not allowed. 
You must enter a unique name.

Diffuse Color: An object’s diffuse color is the color that is displayed prior to applying 
a lightmap. Clicking the Diffuse Color box opens a standard Color Picker allowing 
you pick the desired diffuse color for this object.

Opacity: The Opacity slider allows you to set the selected material’s transparency. 
You can also enter your desired value (in percent) in the field to the right of the slider. 
A value of 0 indicates that the material is completely transparent, and a value of 100 
indicates complete opacity.

NOTE
THE DIFFERENCE BETWEEN OBJECT AND MATERIAL OPACITY CAN SEEM CONFUSING AT FIRST. EXPERIMENT 
WITH OBJECTS THAT HAVE MORE THAN ONE MATERIAL GROUP TO SEE THE DIFFERENCE.

Dither: Checking the Dither checkbox enables texture dithering, or filtration that cuts 
down on pixelated or “jagged” looking texture. When the Dither checkbox is checked, 
you can use the Dither slider to specify the amount of dithering you wish. You can 
also enter your desired value in the field to the right of the slider.
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Bump Strength: The Bump Strength dial controls the amount of bumps generated by a 
bump map (see “Bump Maps” on page 44 for information about bump maps). 
Increasing this value exaggerates bumps, and vice-versa. Negative values reverse the 
bump effect. Click and drag the dial and/or enter your desired value in the field to the 
right of the dial.

Render Mode: pro-V Studio supports seven render modes, described below. You can 
set global rendering modes using the Scene Settings dialog as described in “Scene 
Settings” on page 80 and can also select your desired rendering mode on a per-object 
basis using the Materials tab. Local settings always override global settings, meaning 
that any changes you make to one object’s render mode will not affect other objects. 
Flat for a sphere, all objects in that scene will appear as point clouds, while The 
supported render modes are:

Point: Selecting Point (1) displays the selected object as a 
series of points, with each point representing one vertex. 
Pressing [1] selects this render mode for the current object. 
Pressing [CTRL]+[1] selects this render mode for the entire 
scene.

Wire: Selecting Wire (2) displays the selected object’s 
polygon edges. Pressing [2] selects this render mode for the 
current object. Pressing [CTRL]+[2] selects this render mode 
for the entire scene.

Flat: Selecting Flat (3) displays the selected object as a solid 
object with no depth. 3D objects rendered in this mode will 
appear two-dimensional. Pressing [3] selects this render mode 
for the current object. Pressing [CTRL]+[3] selects this render 
mode for the entire scene.

Texture: Selecting Texture (4) displays the selected object 
with its texture applied but does not display lightmaps, diffuse 
color, etc. Pressing [4] selects this render mode for the current 
object. Pressing [CTRL]+[4] selects this render mode for the 
entire scene.
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LightMap: Selecting LightMap (5) displays the selected 
object’s diffuse color with the global or object lightmap 
applied, as appropriate. Pressing [5] selects this render mode 
for the current object. Pressing [CTRL]+[5] selects this render 
mode for the entire scene.

LightMap Texture: Selecting LightMap Texture (6) displays 
the selected object’s texture with the global or object lightmap 
applied, as appropriate. Pressing [6] selects this render mode 
for the current object. Pressing [CTRL]+[6] selects this render 
mode for the entire scene.

LightMap TexMod: Selecting LightMap TexMod (7) displays 
both the selected object’s diffuse color and texture with the 
global or object lightmap applied, as appropriate. This render 
mode displays all material settings applied to an object. 
Pressing [7] selects this render mode for the current object. 
Pressing [CTRL]+[7] selects this render mode for the entire 
scene.

TEXTURE TAB

Some of the following options may or may not appear depending on the type of texture 
being used (image, SWF, etc.):

Current Map: The Current Map pull-down menu allows you to select the image map 
you are applying settings to. Your options are Diffuse Texture, Alpha Texture, 
Bumpmap Texture, and Lightmap Texture. Different options in this tab will be 
enabled or disabled based on your map selection.

Keep Aspect Ratio In Frame: Checking the Keep Aspect Ratio In Frame checkbox 
forces image maps to appear in their original aspect ratio (ratio of width to height) in 
the Maps palettes. Please see below for details about the Maps palettes.

Name: Enter your desired name for the current texture in the Name field. You may not 
use special characters, and your selected name must be unique.

Has Alpha: Every diffuse texture consists of both a diffuse channel (each pixel’s color 
information) and an alpha channel (each pixel’s transparency information). Checking 
the Has Alpha checkbox causes pro-V Studio to use the alpha channel and the object 
will become transparent according to the alpha map. Clearing this checkbox disregards 
all alpha information. Please see “Maps” on page 42 for more information about maps. 
Enabling this option affects all instances of the same texture map in your scene. If you 
drag a apply a texture to an object with an existing alpha map, this checkbox will be 
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cleared because pro-V Studio is unable to detect if a texture has an alpha channel. In 
this case, simply check the checkbox if appropriate.

Save External: Checking the Save External checkbox forces pro-V Studio to not 
insert the texture map into the MTS file (see “Publish Window” on page 174). Instead, 
the texture will be saved as a JPG image in the same folder as the MTS file and will be 
loaded into your scene when played in the Viewpoint Media Player using an image 
stream animator. Clearing this checkbox saves the texture map in the MTS file. 
Enabling this option affects all instances of the same texture map in your scene.

Auto Run: If you have applied a SWF animation as a texture, checking the Auto Run 
checkbox automatically starts the animation. If this checkbox is cleared, you must 
trigger the playback like you would any other animation.

Compose: The Compose checkbox determines whether the background of a SWF 
animation or SVG content is composited onto the texture.

Loop: Checking the Loop checkbox plays the SWF animation continuously. Clearing 
it plays the animation once and stops at the last frame.

MIP Bias: Checking the MIP Bias checkbox enables MIP Bias texture filtering. This 
feature is useful if you have a large texture map applied to an object. When seen from 
close up, the texture will look good. However, zooming out may degrade its 
appearance due to arbitrary pixels being introduced as the texture shrinks and loses 
detail. MIP filtering builds a pyramid using the original texture and new textures sized 
at 50%, 25%, and 12.5% of the original size. This requires 33% more memory but 
greatly enhances appearance. The Viewpoint renderer automatically decides which 
filter to use. Leaving this box cleared only performs bilinear interpolation (see below).

MIP Bias Value: Adjusting the MIP Bias Value allows you to control the amount of 
blurring applied to the texture, giving you finer control over the MIP biasing function. 
You can also enter a numeric value in the fields to the right of the dial.

Bilerp Filter: Bilinear interpolation is a method of reducing texture pixelation where 
neighboring pixels are blended or separated to create a smoother appearance. Use the 
Bilerp Filter pull-down menu to select bilinear interpolation settings for the current 
object:

Always On: Selecting Always On forces bilinear interpolation to complete for the 
currently selected object. This can increase the number of resources required to 
render a scene and can degrade performance, but does produce optimum results.
By Performance: Selecting By Performance allows bilinear interpolation to 
proceed until the maximum allowable time is exceeded, at which point it stops. 
This option can provide a reasonable compromise between quality and 
performance. You set the global interpolation timeout by selecting 
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Scene>Advanced Settings and adjusting the Filter Maximum Seconds dial, as 
explained in “Advanced Settings” on page 87.
Always Off: Selecting Always Off disables bilinear interpolation.

NOTE
DO NOT CONFUSE BILINEAR INTERPOLATION WITH ANTIALIASING. THEY ARE DIFFERENT FUNCTIONS.

ADVANCED TAB

Translate Texture XY: Use the Translate Texture X and Translate Texture Y dials to 
move the texture horizontally and/or vertically. You can also enter a numeric value in 
the fields to the right of the dials. These settings are used for animation or interaction; 
they are not directly published to your finished scene.

Scale Texture XY: Use the Scale Texture X and Scale Texture Y dials to expand or 
shrink the texture along the desired axis. You can also enter a numeric value in the 
fields to the right of the dials. These settings are used for animation or interaction; they 
are not directly published to your finished scene.

Keep Aspect: Checking the Keep Aspect checkbox forces the texture to keep its 
original aspect ratio (width/height). When this box is checked, moving either of the 
Scale dials will move the other as well, to preserve the aspect ratio.

Edge Bias: The Edge Bias options allow you to remove edge artifacts than can appear 
when viewing geometry objects close up. Check the appropriate radio button to make 
your selection. Your available options are:

Off: Checking the Off radio button disables edge biasing.
Auto: Checking the Auto radio button enables edge biasing.
Custom: Checking the Custom radio button allows the Viewpoint Media Player to 
determine if edge biasing is needed or not when the scene is rendered on the 
viewer’s computer.

MAPS PALETTES

The Materials room contains four Map palettes, one for each map type supported by pro-
V Studio. Please see “Maps” on page 42 for more information about maps. To load a map:

1 Select the object on which to apply the map using either the Scene Display or the 
Hierarchy Viewer window.

2 In the Media palette, find the image map you wish to load.

3 Click and drag your selected map to your desired Map palette.
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NOTE
IN ADDITION TO IMAGES, PRO-V STUDIO SUPPORTS THE USE OF SWF AND ZOOMVIEW CONTENT AS MAPS.

The Map palettes are:

TEXTURE PALETTE

The Texture palette is where you load a texture 
map. It appears as shown.

If you checked the Keep Aspect Ratio In Frame 
checkbox (see “Texture Palette” on page 154), your 
image will appear in its original height/width 
proportions. Clearing that checkbox stretches the 
image to fit the palette. You have the following 
options:

Height: Adjust the texture’s height in pixels 
using the Height dial. You can also entered your 
desired value in the field to the right of the dial.

Width: Adjust the texture’s width in pixels using 
the Width dial. You can also entered your desired value in the field to the right of the 
dial.

Sizing Textures

SWF movies used as textures on 3D objects must be sized to a power of 2. See “Importing 
Images” on page 72 for more information. Adjusting the Height and Width dials will 
adjust the size up or down by powers of 2. 2D objects (hotspots and action primitives) can 
accept arbitrarily sized SWF textures, meaning that you can specify your desired height 
and width.

Image textures (JPG and PNG) cannot be resized when applied to 3D objects but can be 
resized if applied to 2D objects.

Adding SWF Textures to Objects

Adding a Macromedia Flash (SWF) texture to an object uses the same procedure as 
normal image maps.
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ALPHA CHANNEL PALETTE

The Alpha Channel palette is where you load an 
alpha channel map. pro-V Studio supports 256 
levels of transparency when using alpha maps. 256-
color grayscale images are optimal for use as alpha 
maps, however you can use any image desired. This 
palette appears as shown.

If the selected object’s transparency appears 
reversed (opaque where you want it transparent and 
vice-versa), you can press the Invert button to 
toggle alpha inversion on and off.

BUMP MAP PALETTE

The Bump Map palette is where you load a bump 
map. It appears as shown. You cannot make 
adjustments to bump maps. To view a bump map, 
you must first load a diffuse texture.
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LIGHT MAP PALETTE

The Light Map palette is where you load a light 
map. It appears as shown on the right. As with most 
pro-V Studio functions, loading a light map for an 
object overrides the scene light map. You can use 
any imported image as a light map. You can also 
create custom light maps as described in “Lightmap 
Settings” on page 82. To use a custom lightmap:

1 Create your light map.

2 Save the light map as an image.

3 Import the image to the Media palette (see “The 
Media Palette” on page 108).

4 Apply the imported image to the selected object as described above.

WORKING WITH MATERIALS

Please keep the following tips in mind when working with materials:

The Materials room and its palettes display the materials for the currently selected 
object. Selecting a different object updates the palettes accordingly.

In the Materials room, the bottom of the Hierarchy Viewer window can display the 
materials assigned to the currently selected object. Remember that objects can have 
more than one material group. Please see “Animators Tab” on page 107 for more 
information.

You can edit each material group separately by selecting the group to edit in the 
Hierarchy Viewer window.

Asset material options override global settings except for the bilinear interpolation 
filter timeout.

Image hotspots can use texture and alpha maps. They do not support bump or light 
maps. Please see “Image Hotspot Modifier” on page 133 for more information.

You must have an object selected in order to apply material settings.
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ADDITIONAL MAPPING CONSIDERATIONS

Using the same texture, alpha, bump, and/or light map on several primitives can result in a 
large MTS file (see “Viewpoint Files” on page 176) because of the duplicate images. To 
avoid this: 

1 Select the first 3D object.

2 Drag your desired image map onto the 3D object. pro-V Studio creates a new project 
object with the image map.

3 Use the project object created in Step 2 for the second and subsequent 3D objects on 
which you wish to use the same map.

LIGHT MAPS

Every light map must be sized at 256x256 pixels. pro-V Studio automatically resizes 
smaller or larger light maps and creates a new project object. Using the same light map 
again repeats this process.

For example, let’s assume that you want to use the same light map (one that’s 200x200 
pixels) on three different 3D objects. Drag your desired light map image into the selected 
object’s Light Map palette. Since this map is a different size, pro-V Studio automatically 
creates a new object with the map resized to 256x256. If you keep using the original 
200x200 image, you’ll wind up with three identical light maps. Use the 256x256 light map 
(it will have the name of your original lightmap plus the suffix _L) for the second and 
third objects, and you’ll only have one image in your MTS file.

ALPHA & TEXTURE MAPS

The above-described functionality also occurs with texture and alpha maps. Resized alpha 
maps have the suffix _A. An deleted alpha image creates an object with the suffix _OA.

In this example, let’s assume you have the same three 3D objects described above. In this 
case, you want to use the same texture and alpha maps for each object. Drag the textures 
and alpha maps to their appropriate palettes. This creates new project object for every 3D 
object which consists of both texture and alpha information. Simply use this newly created 
map for the other two 3D objects.

BUMP MAPS

Bump maps must be the same size as their corresponding image maps. If your selected 
bump map is a different size than your texture map, pro-V Studio resizes it and create a 
new project object. Simply reuse this newly created as described above. Newly created 
bump maps have the suffix _R.
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Chapter 28: The Animation Room
he Animation room allows you to add and edit animations. To create most simple 
animations, you can use the Simple Animations palette, as described in “The 
Simple Animations Palette” on page 110. This room gives you total control over 

your scene’s animations. it has the following windows and palettes:

Scene Display Window: Please see “The Scene Display Window” on page 100 for 
more information about the Scene Display palette.

Hierarchy Viewer Window: Please see “The Hierarchy Viewer Window” on page 106 
for more information about the Hierarchy Viewer window.x

Play Controls Palette: Please see “The Play Controls Palette” on page 140 for more 
information about the Play Controls palette.

Animation Details Window: Please see below for more information about the 
Animation Details window.

Keyframe Settings Window: Please see below for more information about the 
Keyframe Settings window.

Following the palette descriptions, this chapter discusses various additional tips for 
working with pro-V Studio animations. See “Working With Animations” on page 166.

ANIMATION DETAILS WINDOW

The Animation Details window lets you view and edit your animators and keyframes 
from a single convenient location. It appears as follows:

T
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The Animation Details window has the following controls, some of which function 
identically to their counterparts in the Simple Animations palette, which is discussed in 
“The Simple Animations Palette” on page 110.

Timeline Controls (1): The Timeline controls allow you to perform basic timeline 
functions. From left to right, these controls are:

Add Timeline: The Add Timeline button adds a timeline to the current animator 
and opens the Property Selection dialog. Please see “Animation Hierarchy” on 
page 39 for information about the pro-V Studio animation hierarchy and “The 
Property Selection Dialog” on page 113 for information about the Property 
Selection dialog. You can also create a new timeline by pressing [CTRL]+[T].
Add Keyframe: Clicking the Add Keyframe button or pressing [CTRL]+[K] dds a 
keyframe at the time specified in the Current Time fields (3). If a keyframe 
already exists at the specified time, this function only adds keyframes to timelines 
without keyframes. To replace an existing keyframe, you must use the Force Add 
Keyframe button, described below.
Force Add Keyframe: Clicking the Force Add Keyframe button or pressing 
[CTRL]+[SHIFT]+[K] replaces keyframes at the current time with the new 
values. For example, if you have an existing keyframe with a Translate value of 3 
and the object is at 5Y, this button replaces the TranslateY 3 keyframe with a 
TranslateY 5 keyframe.
Split Selection: Clicking the Split Selection button splits the currently selected 
timeline(s) based on your keyframe selections. Please see “Splitting Selections” 
on page 166 for more information about splitting timeline.

Playback Controls (2): The Playback controls allow you 
to play the currently selected timeline. The labels in the 
image on the right correspond to the following detailed 
explanations:

Fast Reverse (A): Clicking the Fast Reverse button 
plays the current timeline backwards at high speed 
(similar to doing a fast search on a VCR).
Normal Reverse (B): Clicking the Normal Reverse 
button or pressing [SHIFT]+[SPACE] plays the 
timeline in reverse. While the timeline is playing, 
clicking this button again pauses playback.
Stop (C): Clicking the Stop button stops the timeline at its current position.
Play/Pause (D): Clicking the Play button or pressing [SPACE] plays the timeline. 
While the timeline is playing, clicking this button again pauses playback
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Fast Forward (E): Clicking the Fast Forward button plays the current timeline 
forward at high speed (similar to doing a fast search on a VCR).
Start (F): Clicking the Start button moves the timeline to its beginning.
Previous Keyframe (G): Clicking the Previous Keyframe button moves the 
timeline to the next previous keyframe
Next Keyframe (H): Clicking the Next Keyframe button moves the timeline to the 
next proceeding keyframe
Last Keyframe (I): Clicking the Last Keyframe button moves the timeline to the 
last keyframe.

Time/Duration Controls (3): The Time/Duration controls allow you to specify the 
current animator’s total length and quickly skip to any point in the total duration.

Current Time Field: The Current Time fields display the animator’s current 
location in minutes:seconds:milliseconds format. Please see “Simple Animation 
Palette Controls” on page 110 for more information on using this field.
Spread: The Spread dial allows you to expand or compress the timeline display in 
the Keyframe Display Area (see #13, below). This allows you to either see more 
of your animator’s total duration at once or zoom in for precise control. Click and 
drag the dial to set your desired value.
Duration Field: The Duration fields display the animator’s total length in 
minutes:seconds:milliseconds format. Please see “Simple Animation Palette 
Controls” on page 110 for more information on using this field.

Speed Scale (4): The Speed Scale field allows you to rescale time. Setting this value to 
1 plays the animation at normal speed. Setting this value to 2 plays the animation at 
double speed. 0.5 plays the animation at half speed, and so forth. Enter your desired 
numeric value in the field.

Loop Continuously (5): Checking the Loop Continuously radio button forces the 
current animator to play continually once started. The animator will play from 
beginning to end and will keep repeating if this option is enabled. If you do not want 
this animator to loop, you will need to check the Play/Repeat radio button.

Play X Times (6): Checking the Play X Times radio button disables looping and forces 
the animator to play from beginning to end. Enter the desired number of repetitions in 
the field. This must be an integer. Decimals (such as 3.5) are not allowed.
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Auto Run (7): Checking the Auto Run checkbox makes the current animator begin 
running when your scene is opened. If this box is not checked, you will need to add an 
explicit trigger for the animation (such as a message sent by an interaction 
component). Alternatively, loading a template in the Web Integration room (see “The 
Web Integration Room” on page 170) will add a pair of Java script buttons labeled 
Start <animation> and End <animation>, where <animation> is the name of the 
selected animator. This option is hierarchical and operational so long as the entire 
hierarchy above the selected timeline has this option enabled. For example, if a parent 
animator has Auto Run enabled and its child does not, then the “grandchild” animator 
cannot be set to auto run.

Auto Stop (8): Once an animator starts, it continues until stopped by another property 
unless you check the AutoStop checkbox.

Timeline List (9): The Timeline List area displays all of your current timelines. To 
rename a timeline, select the desired then click again in a slow double-clicking motion 
and enter your desired name in the field that appears. Timelines must have unique 
names that do not have special characters. Each timeline has two checkboxes. From 
left to right, these checkboxes are:

Animation On/Off: Checking the Animation checkbox enables animation for the 
currently selected timeline and vice-versa. This is for previewing and testing 
purposes only and does not affect your published scene.
Tween: Checking the Tween checkbox makes pro-V Studio interpolate keyframes. 
Clearing this checkbox disables tweening. Please see “Interpolation” on page 40 
for more information.

By default, both boxes are checked.

Current Position Indicator (10): The Current Position Indicator is a visual indicator 
of where the current animator is in its current run. You can click and drag this slider 
and/or enter numeric values in the Current Time fields, described in #3, above.

Keyframe Display Area(11): The Keyframe Display area shows all of the keyframes 
in the timelines comprising the current animator. You can select a single keyframe by 
clicking it or select multiple keyframes by clicking and dragging to create a 
rectangular selection area. Selecting one or more keyframes enables the Key Frame 
Settings window, described below.
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KEY FRAME SETTINGS WINDOW

The Keyframe Settings window has two separate interfaces, one for normal timelines, the 
other for action timelines (see “Keyframing” on page 38 for more information about 
timeline types). To activate this window, select a keyframe in the Animation Details 
window, as described above.

NOTE
IF YOU SELECT MULTIPLE KEYFRAMES ON ONE OR MORE TIMELINES, THE KEYFRAME SETTINGS WINDOW WILL 
ONLY SHOW THOSE ATTRIBUTES THAT ARE COMMON TO ALL SELECTED KEYFRAMES - IF ANY.

NORMAL TIMELINES

The Keyframe Settings window appears 
as shown when working with normal 
timelines. This window has the following 
controls:

Keyframe Time (1): The Keyframe 
Time field displays the current 
keyframe’s position in 
minutes:seconds:milliseconds format. 
If you enter a new time, the keyframe 
will move to the newly created time. 
This can speed up or slow down the rate of change between the moved keyframe and 
those just before and just after.

Additive (2): If you check the Additive checkbox, the value you enter in the Value 
field (#5, below) is added to the previous keyframe’s value. For example, if your 
previous keyframe had a TranslateY value of 3, entering 2 would translate the 
affected object to +5 on the Y axis.

Wildcard (3): Normally, timelines begin playing in their initial state. Checking the 
Wildcard checkbox does not return the timeline to its pre-playback state. For wildcard 
to be truly effective, all timelines in the current animator must have this option enabled 
or they may not exhibit wildcard behavior.

Value (4): You may enter or modify your desired keyframe value in the Value field. 
Depending on the object/attribute being controlled, the required syntax may vary. use 
caution to enter the correct information using the exact syntax displayed.
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Interpolation Method (5): The Interpolation Method pull-down menu allows yo to 
select your desired interpolation method for the current timeline. pro-V Studio 
supports the following interpolation methods: Linear, Catmull-Rom Spline, TCB 
Spline, Smooth Rotation, Catmull-Rom Spline Rotation, and TCB Spline 
Rotation. Please see “Interpolation” on page 40 for more information about these 
keyframe interpolation methods.

ACTION TIMELINES

As described in “Keyframing” on page 38, each new animator contains one action 
timeline. If you discard this timeline, you can select Animator>New Action Timeline. To 
work with an action timeline:

1 Select the action timeline in the Animation Details window.

2 Scrub the Current Position Indicator or enter a time in the Current Time field.

3 Click the Add Keyframe button or press [CTRL]+[K].

4 Input your desired setting in the Keyframe Settings window.

The Keyframe Settings window 
appears as shown when working 
with action timelines. It has the 
following controls:

Keyframe Time (1): The 
Keyframe Time field displays 
the current keyframe’s 
position in 
minutes:seconds:milliseconds 
format. If you enter a new 
time, the keyframe will move 
to the newly created time. This 
can speed up or slow down the rate of change between the moved keyframe and those 
just before and just after.

Outgoing Message (2): Action timelines care capable of posting messages to the 
system, thereby triggering other animations or interaction components. When the 
keyframe is played, it will perform the action specified in the Outgoing Message pull-
down menu (3). Available messages are:

Post Message: Selecting Post Message sends a custom message to the system 
when the current reactor is triggered. For example, if you select this option and 
enter MYMESSAGE in the Message field (see below), then MYMESSAGE will 
appear as an option in the Incoming Message pull-down (described above) and 
can be used to trigger another reactor.

AUTHORED BY ANTHONY HERNANDEZ - (415)786-2081 - anthony94122@outlook.com



164 

 PRO-V STUDIO REFERENCE MANUAL

Set Built In Property: Selecting Set Built In Property allows you to set a 
property, which you select using the Property pull-down menu (see below).
Collapse: Please see “Collapsing Objects” on page 37 for more information.
Uncollapse: Selecting Uncollapse uncollapses the selected object and children. 
Collapsing and uncollapsing objects allows you to create more complex scenes 
while conserving resources.
Hide: Selecting Hide makes the current object invisible. Hidden objects are still 
present in the scene and can have interaction components, etc. They also consume 
resources.
Show: Selecting Show makes the current object visible.
Set Object Opacity: Selecting Set Object Opacity allows you to specify the 
object’s opacity in the Data field.
Drag Object: Selecting Drag Object allows the viewer to drag the current object 
to a new location.
Set Material Diffuse Color: Selecting Set Material Diffuse Color allows you to 
set the current object’s color. Please see “Material Settings Palette” on page 149 
for more information.
Set Material Opacity: Selecting Set Material Opacity allows you to specify the 
opacity of the object’s material (not the object itself) in the Data field.
Trigger Animation: Selecting Trigger Animation allows you to trigger an action 
animator that begins playing when the reactor is triggered.
Start Animation: Selecting Start Animation starts the selected animator.
Stop Animation: Selecting Stop Animation stops the selected animator.
Load MTX: Selecting Load MTX loads the specified Viewpoint MTX file.
Execute VB Script: Selecting Execute VB Script loads and executes a Visual 
Basic (VB) script.
Execute JavaScript: Selecting Execute JavaScript loads and executes a Java 
Script script.

Data (3): Some of the actions allow you to send data to the system. For example, 
posting a message allows you to enter a custom message as described above. The Data 
field is where you enter the data to be applied by the reactor. The displayed name of 
this field changes depending on the action you select using the Action pull-down 
menu. For some values, you can select the following by clicking the arrow to the left 
of the field name and using the pull-down menu:

Value: Selecting Value sends the specified value to the selected target.
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Append: Selecting Append adds the value you enter to the existing value. For 
example, if the rot_ value is currently 3 and you enter 2, the rot_ value will 
become 5 (2+3).
Message: As described above, you can create custom messages, post that value to 
the system, and have other interaction components react to that custom message. 
Messages have a “broadcast” effect, meaning that they exist throughout the scene 
once posted. Thus, one message can affect multiple targets

Outgoing Message Recipient (4): The Outgoing Message Recipient pull-down menu 
displays a hierarchical list of objects in your scene. This appears similarly to the list 
found in the Hierarchy Viewer window and functions identically. This is the object 
on which the reactor will act. For example, you could set up a reactor to begin an 
animation when a sphere is clicked. In this case, you would attach the reactor to the 
sphere and select the animator as the target object

Properties (5): If you selected an action that requires you to select a property, you can 
select an available property using the Property pull-down menu.

Add/Remove Actions: See below.

Defining Actions in Action Timelines

Action timelines can perform multiple actions. To specify more than one action:

1 Click the Add button (7) once for each action you wish to add. For example, if you 
want the reactor to perform five actions, click this button four times.

2 Set the first action just as you would for a Simple Reactor, as described in “Simple 
Reactors” on page 115.

3 Move the Action Number slider (6) until the number to the right of the slider changes 
to the next number (for example, from 1 to 2).

4 Set the second action just as you would for a Simple Reactor.

5 Repeat Steps 3 and 4 for each subsequent action.

To delete an action, move the Action Number slider to the action you wish to delete and 
click the Delete button (8). Once you have finished making your selections, click OK to 
save your changes or Cancel to abort.

As you can see, this functions in a manner similar to that of a Multi Reactor. Please see 
“Multi Reactors” on page 119 for more information.
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WORKING WITH ANIMATIONS

This topic contains additional information about working with animations:

SPLITTING SELECTIONS

You can split animators or timelines, as follows:

Splitting an animator creates a new animator for each timeline in the original animator.

Splitting a timeline creates two new animators, one with the keyframes before the 
current time, the other with the keyframes after the current time.

Selecting keyframes with a rectangular selection creates a new animator with the 
selected keyframes.

Splitting is a non-destructive process, meaning that original keyframes and animators are 
preserved.

EDITING MULTIPLE KEYFRAMES

If you have a timeline with multiple keyframes, selecting multiple keyframes displays the 
left-most keyframe’s time in the Current Time field. Changing this time moves the left-
most keyframe and all those to the right relative to the change. For example, say you have 
a timeline with keyframes at 1, 2, and 3 seconds. Selecting the right two keyframes 
displays 2 in the Current Time field. If you change that to 5, then the left-most selected 
keyframe move to 5 seconds and the next one to 6. This allows you to quickly re-time 
animations. You cannot, however, change the order in which keyframes appear.

With this technique you can move many keyframes by editing the new time 

ANIMATING MATERIALS

To animate materials, you must select a material property, then enter the room in question 
(such as the Material Room to change opacity). Change the values as needed, then return 
to the Animation room to set the keyframe as described above. Repeat these steps for all 
keyframes.
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Chapter 29: The Interaction Room
ehaviors offer an extremely powerful state-based means of adding interactivity to 
your scene. The Interaction room is where you work with behaviors. You may 
also work with any other interaction component you desire and preview your 

work. This room has the following windows and palettes:

Scene Display Window: Please see “The Scene Display Window” on page 100 for 
more information about the Scene Display palette.

Hierarchy Viewer Window: Please see “The Hierarchy Viewer Window” on page 106 
for more information about the Hierarchy Viewer window.

Interaction Palette: Please see “The Interaction Palette” on page 114 for more 
information about the Interaction palette.

Play Controls Palette: Please see “The Play Controls Palette” on page 140 for more 
information about the Play Controls palette.

Behavior Editor Dialog: Please see below for information about the Behavior Editor 
dialog.

Please see “The Interaction Palette” on page 114 for information on working with other 
types of interaction components. This chapter solely concerns itself with behaviors.

ABOUT BEHAVIORS

Behaviors are hierarchical interaction components that can contain states, reactors, 
behaviors, and/or modifiers. Each state can contain multiple interaction components, each 
with the same or different triggers.

Reactors have a “global” state. Any interaction components places into this global state 
will function as if they were not contained within a behavior, with the only difference that 
behaviors can be enabled or disabled, whereas an interaction component not within a 
behavior is always enabled.

By themselves, most interaction components do not set behavior states. Within a behavior, 
however, state changes are possible. Each behavior contains a starting state. If a behavior 
has two or more states, you can set your desired starting state, meaning that the behavior 
will be in your selected state until something happens to change it.

Interaction components are activated and deactivated by state. All interaction components 
within a state are active then that state is active. In any given state, only those interactions 
assigned to the current state and the global state are active. If a behavior has no states, then 
all interaction components within that behavior are active.

B
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BEHAVIOR BASE DIALOG

To add a behavior, click and drag a behavior from 
the Interaction palette to your desired object in the 
Hierarchy Viewer window. Double-clicking this 
behavior opens the Base Dialog as shown here. The 
Base Dialog has the following options:

Name: Enter your desired name in the Name 
field.

Enable Message: Use the Enable Message pull-
down menu to select a message (built-in or 
custom) that activates the current behavior. Your 
options are the same as the those suppled with 
Simple Reactors (see “Simple Reactors” on 
page 115 for more information).

Disable Message: Use the Disable Message pull-down menu to select a message 
(custom or built-in) that disables the current behavior. Your options are the same as 
those available in the Enable Message pull-down. See above.

Comments: If desired, you may enter up to 5 lines of text as comments or explanations 
about the current reactor and its function. This can help with complex scenes, 
especially if more than one person is working on a scene or if the scene is subject to 
periodic revision.

You can access the Base Dialog from any room. To edit a behavior, however, you must 
enter the Interaction room, which displays the Behavior Editor (see below).

BEHAVIOR EDITOR DIALOG

The Interaction room contains the Behavior 
Editor dialog, which appears as shown. This 
dialog is the same as the Base Dialog shown 
above with the following additions:

Add State: Clicking the Add State button 
adds a state to the current behavior. You can 
also drag states from the Interaction palette 
to the behavior in the Hierarchy Viewer 
window.

Set Start State: Clicking the Set Start State 
button makes the currently selected state the 
behavior’s starting state. To set a start state, 

AUTHORED BY ANTHONY HERNANDEZ - (415)786-2081 - anthony94122@outlook.com



169

WORKSPACE REFERENCE

select the state on the left side of the Behavior Editor dialog, then click the button. 
The current start state appears in italics.

WORKING WITH STATES

The image shows a behavior with three states, 
including the global state and two added states.

To add an interaction component to a state, drag 
the desired component from the 
Interaction palette to the desired state in the 
Hierarchy Viewer. You can see and edit these 
interaction components in the Behavior Editor 
dialog. Selecting a state on the left side of the 
Behavior Editor shows the interaction 
components assigned to that state, if any.

EVENT LINES

The right side of the Behavior Editor dialog contains one or more event lines. Each event 
line is labeled according to the action that will trigger that line (such as MouseLeftClick). 
In this example, there are no interaction components tied to a left mouse click.

To add an event line, select any interaction component within the desired state using the 
Hierarchy Viewer window. If you add or switch the interaction component’s incoming 
message(s), that interaction component will move to the specified event line (if the line 
already exists) or will create a new even line (if no corresponding event line exists). In the 
above example, a mouse left click does nothing while a mouse right click triggers the 
reactor and switches the behavior from State_0 to State_1. Remember that the event line 
has nothing to do with time, only with triggering events.

To cause an event line to set a new state, click the arrow at the right of the event timeline 
to open the States pull-down menu, which lists all states in the behavior, and make your 
selection. Each event line can trigger a different state, the same state, or no state.

Event timelines can be set to either built-in or custom messages.

REARRANGING TIMELINES

To rearrange the event line display, click and drag interaction components. To move 
interaction components between event lines, press [CTRL] while dragging your selected 
interaction component to your desired event line.

NOTE
BE SURE TO ADD DESCRIPTIVE NAMES TO INTERACTION COMPONENTS TO AVOID CONFUSION.
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Chapter 30: The Web Integration 
Room

ow that your scene has been published, you’re ready to insert it into a Web page 
in preparation for publication. The Web Integration room lets you do this. You 
may load and preview scenes in HTML pages and process Viewpoint Media 

Player (VMP) templates. This step is optional; you can insert the code to call your 
Viewpoint scene into any HTML after publishing your scene. You can publish just your 
scene or your scene with the HTML page. This room contains the Web Display window, 
described below.

WEB DISPLAY WINDOW

The Web Display window appears as follows:

N
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This window has the following buttons:

Load Existing Page: Clicking the Load Existing Page button opens a standard Open 
dialog box, allowing you to browse for and load an HTML page. Once loaded, your 
scene appears in the page.

Preview In Browser: Clicking the Preview In Browser button launches your Web 
browser and displays the currently loaded HTML page with your scene in it.

New Page From Template: pro-V Studio includes an assortment of basic HTML 
templates that you can use to publish your scene. Use the New Page From 
Template pull-down menu to make your selection.

Edge Effect: The Edge Effect pull-down menu allows you to specify how you wish 
objects to appear when they reach the edge of your scene window (such as when 
zooming in). Your available options are:

No Edge Effect: Selecting No Edge Effect makes your scene 
window’s edges invisible. Assets extending beyond the 
window edge appear cut off, as shown.

Soft, Invisible Edge: Selecting Soft, Invisible Edge makes 
your scene window’s edges invisible. Assets extending 
beyond the window edge fade out as they approach the edge, 
as shown.

Soft, Visible Edge: Selecting Soft, Visible Edge displays your 
scene window’s edges. Assets extending beyond the window 
edge fade out as they approach the edge, as shown.

Broadcast Key: You must obtain a broadcast key from Viewpoint 
in order to publicly display published scenes. Please see 
“Distribution” on page 10 for more information. The Broadcast Key pull-down menu 
allows you to enter your broadcast key. Your available options are:

Choose File: Selecting Choose File opens a standard Open dialog allowing you 
to browse for and load a broadcast key contained in a text file.
Direct Input: Selecting Direct Input opens the Enter Broadcast Key dialog. 
Enter your Viewpoint broadcast key in the field, then click OK.

Use Layers: Modern HTML browsers support multiple HTML layers using the <DIV> 
HTML tag. Checking the Use Layers checkbox places your scene in a new HTML 
layer that you can position at will. Clearing this checkbox places your scene at the 
bottom of the currently loaded HTML page. When layers are enabled, you can drag the 
scene layer to position it. Be sure not to place it on top of any Java script buttons as 
they cannot accept mouse clicks when behind your scene.
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Chapter 31: The Publish Room
ublishing. You’ve added and arranged objects, inserted animations and interaction 
components, and integrated your scene into a Web page. Now you’re ready for the 
last step. The Publish room publishes your scene files to a hard drive ready for 

uploading to the Web. This room contains the following windows and palettes:

Scene Display Window: Please see “The Scene Display Window” on page 100 for 
more information about the Scene Display palette.

Hierarchy Viewer Window: Please see “The Hierarchy Viewer Window” on page 106 
for more information about the Hierarchy Viewer window.

Quality Settings Palette: Please see below for more information about the Quality 
Settings palette.

Publish Palette: Please see below for more information about the Publish palette.

QUALITY SETTINGS PALETTE

The Quality Settings palette allows you to specify 
quality settings on a per-object basis. Per-object 
selections override scene selections. To specify 
quality settings for the entire scene, use the Publish 
window (see below). The Quality Settings palette 
appears as shown.

To enable the Quality Settings palette, select an 
object in either the Scene Display window or the 
Hierarchy Viewer window. Your settings will be 
applied to the currently selected object. This palette 
allows you to specify geometry and map quality. It 
has the following controls:

Use Local Geometry Settings: Checking the Use 
Local Geometry Settings checkbox allows you to apply custom geometry quality 
settings to the currently selected object and enables the top half of the Quality 
Settings palette. Clearing this checkbox forces the currently selected object to use the 
scene quality settings. This feature is useful if, for example, you have one item you 
wish to highlight in a scene with several items. In this case, enabling this option 
enhances your highlighted item while minimizing overall scene size.

P

AUTHORED BY ANTHONY HERNANDEZ - (415)786-2081 - anthony94122@outlook.com



173

WORKSPACE REFERENCE

Geometry: The Geometry slider allows you to specify your desired geometry (2D and 
3D mesh) quality settings. Dragging to the right increases both geometry quality and 
scene size, and vice-versa. You can also enter your desired value in the field to the 
right of the slider.

UV-Mapping: The UV-Mapping slider allows you to specify your desired UV map 
quality settings. Please see “Maps” on page 42 for more information about maps. 
Dragging to the right increases geometry quality and your scene size, and vice-versa. 
You can also enter your desired value in the field to the right of the slider.

Apply to: The Apply To pull-down menu allows you to specify custom quality settings 
for the currently selected object’s maps. Your available options are:

Texture: Selecting Texture applies quality settings to the object’s texture map.
Bump Map: Selecting Bump Map applies quality settings to the object’s bump 
map.
Light Map: Selecting Light Map applies quality settings to the object’s light map.

Use Local Map Settings: Checking the Use Local Map Settings checkbox allows you 
to apply custom image map quality settings to the currently selected object and enables 
the bottom half of the Quality Settings palette. Clearing this checkbox forces the 
currently selected object to use the scene quality settings. This feature is useful if, for 
example, you have one item you wish to highlight in a scene with several items. In this 
case, enabling this option enhances your highlighted item while minimizing overall 
scene size.

Bitmap: The Bitmap slider allows you to specify your desired image map quality 
settings. Dragging to the right increases both map quality and scene size, and vice-
versa. You can also enter your desired value in the field to the right of the slider.

Use TrixelsNT: Checking the Use TrixelsNT checkbox enables the use of Viewpoint's 
proprietary TrixelsNT wavelet-based compression, which dramatically reduces the 
size of certain image maps, and vice-versa.
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PUBLISH WINDOW

The Publish window allows you to specify global quality settings, set publishing options, 
view your scene’s size and download times, and publish your finished scene. This window 
appears as follows:

MTX/MTZ: The MTX/MTZ controls allow you to specify which scene files to 
publish:

Write MTX (1): Checking the Write MTX checkbox writes an XML-based file to 
the proprietary Viewpoint MTX format, and vice-versa. MTX files contain the 
hierarchical relationships between objects in your scene and contains a script for 
staging your scene. Think of the MTX file as your scene’s blueprint.
Write Verbose MTX (2): Checking the Write Verbose MTX checkbox writes an 
MTX file containing all of the possible XML tags for a Viewpoint scene, 
including those that are set to default values. You can use a verbose MTX file 
much as an auto mechanic uses extra cars for parts. Simply cut and paste MTX 
file elements from the verbose MTX file into the non-verbose MTX file and edit 
the attributes.

WARNING
VERBOSE MTX FILES ARE AN ADVANCED FEATURE THAT SHOULD ONLY BE USED BY ADVANCED USERS. 
EDITING MTX FILES CAN CAUSE SCENE CORRUPTION AND DATA LOSS.

Write MTZ (3): Checking the Write MTZ checkbox writes an MTZ file, which is 
a compressed form of MTX file, and vice-versa. MTZ is the preferred format for 
Web-enabled Viewpoint content, especially if your scene contains large 
animations. Compressing MTX files speeds up downloading of Viewpoint scenes.
Write HTML (4): Checking the Write HTML checkbox includes an HTML file 
with your published scene, and vice-versa. If you loaded an HTML page (template 
or custom) in the Web Integration room (see “The Web Integration Room” on 
page 170), your scene will be published with this HTML file. If you did not load 
an HTML file, pro-V Studio will generate a generic HTML page that loads your 
scene when opened in a Web browser.
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Preview Settings: The Preview Settings controls allow you to control your scene’s 
preview:

Show Preview (5): Checking the Show Preview checkbox allows you to preview 
the effect of your selected quality settings and vice-versa.
Auto-Update (6): If the Show Preview checkbox is checked, checking the Auto-
Update checkbox automatically refreshes the preview every time you change a 
settings. Clearing the checkbox disables this feature.
Rebuild Preview (7): Clicking the Rebuild Preview button refreshes your scene 
preview.

Quality Settings: The Quality controls allow you to specify quality settings for your 
entire scene. If you wish to apply custom quality settings to a particular object without 
affecting the rest of the scene, select your desired object and use the Quality Settings 
palette as described above. The available Quality controls are:

Bitmap (8): The Bitmap slider allows you to specify your desired image map 
quality settings. Dragging to the right increases both map quality and scene size, 
and vice-versa. You can also enter your desired value in the field to the right of the 
slider.
Lightmap (9): The Lightmap slider allows you to specify your desired light map 
quality settings. Dragging to the right increases both map quality and scene size, 
and vice-versa. You can also enter your desired value in the field to the right of the 
slider.
Geometry (10): The Geometry slider allows you to specify your desired geometry 
(2D and 3D mesh) quality settings. Dragging to the right increases both geometry 
quality and scene size, and vice-versa. You can also enter your desired value in the 
field to the right of the slider.
Use TrixelsNT (11): Checking the Use TrixelsNT checkbox enables the use of 
Viewpoint's proprietary TrixelsNT wavelet-based compression, which 
dramatically reduces the size of certain image maps, and vice-versa.

Download Time (12): The Download Time display shows your scene’s download time 
at the selected speed (see below).

Speed (13): Use the Speed pull-down menu to select a download speed. This updates 
the Download Time display (see above) and allows you to see how long viewer 
downloads will take.

Size (14): The Size display shows your scene’s current size.

Publish (15): Clicking the Publish button publishes your current scene with all 
objects, interaction components, animations, quality settings, etc. exactly as they 
appear within pro-V Studio. The Publish pro-V Studio Project window appears, 

AUTHORED BY ANTHONY HERNANDEZ - (415)786-2081 - anthony94122@outlook.com



176 

 PRO-V STUDIO REFERENCE MANUAL

allowing you to browse to the folder where your scene will be published. Please see 
“Paths Tab” on page 78 for information about changing the default publish folder.

VIEWPOINT FILES

Viewpoint uses the following file formats:

MTS: MTS files store a scene’s building blocks (sounds, images, geometry meshes, 
etc.)

MTX/MTZ: MTX files (compressed, an MTX file becomes an MTZ file) contain the 
information needed to build and run the scene such as settings, interactions, animators, 
etc.)

HTML: HTML files can host Viewpoint scenes and call the scene to load and begin 
playing.

A good way to think of these files is that MTS files provide the lumber and bricks, MTX 
files provide the blueprints, and HTML can provides the truck that brings these 
components where they’re needed.

AUTHORED BY ANTHONY HERNANDEZ - (415)786-2081 - anthony94122@outlook.com



177

WORKSPACE REFERENCE

Chapter 32: The Content Room
elcome to Content Paradise by Curious Labs! pro-V Studio’s Content room 
accesses Content Paradise, which is your gateway to leading marketplaces that 
provide both free and for-sale pro-V Studio content. Need a pro-V Studio 

object, texture, animation, or something else? Content Paradise has you covered. And, 
pro-V Studio’s Download Manager can auto-install most downloaded content and add it to 
the Media palette. Clicking the Content room tab at the top of the pro-V Studio 
workspace opens the Content room:

Aside from the Download Manager, the Content room accesses the online Content 
Paradise Web server and seamlessly displays Web pages in the pro-V Studio workspace. 
The Content Paradise features and interface are subject to change as Curious Labs adds to 
and refines this service. Because of this, the discussion in this reference manual is limited 
to discussing the Download Manager.

Content Paradise includes comprehensive online help, which is accessible from anywhere 
in the interface by clicking the Help links. Please be sure to read all of the applicable 
Terms of Service, including the Privacy Policy. Curious Labs reserves the right to alter 
these policies at any time without prior notice.

W
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DOWNLOADING AND INSTALLING CONTENT

After you purchase your content and check out of the marketplace(s), you will be able to 
download it to your computer. A progress meter keeps you informed of your download’s 
status. Follow the on-screen instructions to begin the download. Once the data transfer is 
complete, you can begin the installation process:

The Installation Options window appears for each downloaded file once data transfer is 
complete, with the following options:

Install: Clicking the Install button installs the downloaded content to your pro-V 
Studio library. Please see “Library vs. Project Assets” on page 17 for information 
about the pro-V Studio library and project objects. The content will be placed in the 
folder specified in the Paths field in the Paths tab (see “Paths Tab” on page 78). To 
change the folder that content is installed to, enter a new path in the Paths tab.

Copy: Clicking the Copy button copies downloaded content to the path specified in the 
Install Path field.

Cancel: Clicking the Cancel button cancels the installation process. Downloaded 
content will remain uninstalled in the folder used by pro-V Studio for temporary 
storage. You will need to re-download cancelled content in order to install it.

If the file being installed already exists, a dialog pops up asking if you want to overwrite 
the existing file. Click Cancel to abort, or OK to proceed with overwriting the old file.

A confirmation dialog appears once installation is complete. Click OK to acknowledge 
successful installation of your downloaded content.

If pro-V Studio cannot recognize the content or cannot install content (such as an 
executable file), the Copy to Folder window appears again with the notification and 
allows you to browse for a folder. Clicking the Copy button copies the content to the 
specified folder where you can access and process it, and clicking Cancel exits the 
Download Manager.
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Appendix A: Technical Support

e’ve worked hard to ensure that pro-V Studio’s powerful features are both easy 
to use and available to users running a wide variety of computers. However, 
there may be times when you need technical support. Curious Labs is pleased 

to offer free technical support to registered users of our products. To receive technical 
support, please visit our Web site at http://www.curiouslabs.com/support and browse 
through our extensive product FAQs.

Please use the following checklist before contacting Technical Support:

Manual: This Reference Manual answers most pro-V Studio questions. Before 
contacting Technical Support, please read the pertinent section(s) of this manual 
thoroughly.

FAQ: Please visit the product FAQs at the above-listed URL.

Still don’t see your question answered? Please contact Technical Support by clicking the 
link on the product FAQ (Frequently Asked Questions) page and completing our online 
support form. When contacting Technical Support, please fill out the form as completely 
as possible and include as much information as possible. This will help us resolve your 
issue faster. Once the form is complete, a Technical Support representative will contact 
you directly as soon as possible. Support requests are answered via email in the order they 
are received. Online support is free to all registered pro-V Studio users. pro-V Studio users 
are automatically registered while installing the application. You may also email support 
requests to tech@curiouslabs.com.

Telephone support is also free to registered users. Before using telephone support, please 
check the resources listed above. Phone support is intended to solve critical technical 
issues. We are unable to answer project-based questions.

In order to receive support, we require the following information:

Your name

Email address

Telephone number (including international dialing information, if applicable)

Your current operating system

Your computer specifications (CPU, RAM, hard drive, video card, etc.)

pro-V Studio serial number

W
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Detailed description of the problem

This information will help us isolate and resolve your issue. We require this information in 
order to provide support services and are unable to respond to incomplete requests in a 
timely fashion.

For international support, please contact your local distributor. Curious Labs maintains a 
list of our international distributors at http://www.curiouslabs.com.

NOTE
CURIOUS LABS RESERVES THE RIGHT TO ALTER OUR TECHNICAL SUPPORT POLICIES AT ANY TIME WITHOUT 
ADVANCE NOTICE.
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Appendix B: Glossary

his Appendix contains some important pro-V Studio terms and their definitions.

GLOSSARY

2D Layer: This is a layer contained within every pro-V Studio scene, which is 
displayed in front of the 3D layer. The 2D layer can contain any number of 2D objects. 
As with the Background Layer, the 2D Front Layer tracks with the camera so that 
camera movements do not change the user’s view of the layer, and objects are drawn at 
their full size (camera distance does not effect scale).

3D Layer: This layer is a normal 3D space that contains all the 3D objects in the scene. 
It is drawn in front of the Background and the 2D Back Layer, and behind the 2D Front 
Layer. As the camera is moved in three-dimensional space, the view on the objects in 
the 3D Layer will change accordingly.

Action Primitive: Action primitives are high-level objects such as 2D buttons, 3D 
buttons, etc., which pro-V Studio supports as primitive object types, and which it 
translates into multiple Viewpoint objects and interactors when publishing to 
Viewpoint format. These high-level objects inherently contain all the necessary 
interactions to function, without the user having to create several objects and specify 
the interactions explicitly.

Animator: Animators in pro-V Studio are the objects which embody most animations 
that pro-V Studio can perform. They are nearly analogous to Viewpoint animators, 
each having a timeline made up of keyframes. At each keyframe, any number of 
project attributes can take on a new value. As a simple example, within the one 
animator the z position of an object might be animated to move the object away from 
the camera, while the opacity of the object is also animating to make the object more 
and more transparent. Attribute values at keyframes may also be wild-carded, as in 
Viewpoint. Additionally, at each keyframe of an animator, any system or user-defined 
message may be sent to any object. A single project may have any number of 
animators, and animators are arranged in a hierarchy in pro-V Studio, as in Viewpoint.

Background: The background is a layer in the scene that can contain a flat image, an 
iPIX or QTVR panorama, a flat image, or simply a background color. The background 
layer is drawn behind all other layers in the scene.

T
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Behavior: Behaviors are a part of the pro-V Studio interaction system that allow for 
complex grouping of other interaction components, and provide support for a state 
machine. Each behavior contains a set of states, which will always contain at least one 
state. The user can create as many states as desired in any one behavior. Each state can 
have a completely different set of reactors and modifiers. Additionally, state changes 
can be accomplished by setting the state change field of a reactor that is contained 
within a behavior state. Behaviors may also be added to the application library and 
generalized with generic object placeholder names to fill the place of any actual 
objects referenced by the behavior. When a generalized behavior is removed taken out 
of the library, the user is then asked to assign actual objects to the placeholders used in 
the generic behavior.

Interaction Palette: The interaction palette is the source from which the user can 
instantiate reactors, modifiers, and behaviors. An iconic representation of each type of 
interaction component is contained in this palette. To instantiate any interaction 
component, the user simply drags the desired type of component from the interaction 
palette and drops it on either the object itself, or the object’s entry in the interaction 
hierarchy.

Library: Application repository for 2D and 3D objects, behaviors, etc. Elements can be 
dragged out of the library and dropped into the scene, onto an object, etc. Elements of 
a project may also be added to the library by dragging and dropping them onto the 
library pane of the media palette.

Media Palette: An important UI palette that houses the project assets collection, 
library, and primitive creation tools.

Modifier: Modifiers are designed to house specialized interactions and media effects 
not supported elsewhere in pro-V Studio. As with other components of the pro-V 
Studio reaction system, modifiers may be attached to objects directly, or they may be 
attached to any state of a behavior. Examples of modifiers include a pop-up label 
modifier which supports the same textual pop-up behavior as “widgets” in Viewpoint, 
as well as a sound-effect modifier, which will play a particular sound upon receipt of a 
specified message.

Primitive: Primitives are objects whose shapes are drawn entirely procedurally. pro-V 
Studio supports a number of basic 3D primitive shapes: sphere, cube, box, pyramid, 
cone, cylinder, 2D plane.

Project: Each pro-V Studio project consists of global project settings, a collection of 
project media assets, and a hierarchy of pro-V Studio scenes. In the first version of the 
application, this hierarchy of scenes will not be exposed, and each project will just 
contain one scene, with no controls to create more scenes. However, pro-V Studio is 
intended to support an arbitrary number of scenes.
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Project Assets: Collection of media assets imported for use in the current project. 
Housed in the project assets pane of the media palette. Objects can be imported from 
outside of pro-V Studio to the project assets collect. They can also be removed from 
the assets collection. Objects in the assets collection can be instantiated in the current 
scene by dragging and dropping.

Scene Settings: The scene settings dialog is a tabbed dialog which supports the 
selection of various project and scene-wide settings, including project dimensions, 
shadow parameters, anti-aliasing, scene background color and panorama selection, and 
camera type selection and constraints.

Reactor: Reactors are an integral part of the pro-V Studio interactions system. 
Reactors can be attached directly to objects, or to any state of a behavior. Reactors 
react to incoming messages by sending a message or command to another object, 
along with optional data. For example, a reactor could be attached to a 3D object 
which would respond to a mouse click on that 3D object by starting an animation. 
Additionally, if a reactor resides inside of a behavior, it may also cause a state change 
in the state machine of the behavior.
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Scene: A pro-V Studio scene consists of four layers. The first (backmost) layer of the 
scene is the background layer, which can contain a QTVR or iPIX panorama, a still 2D 
image, or simply a background color. The next layer is the background 2D layer 
(called 2D Back Layer), which can contain any number of 2D objects. The next layer 
is 3D layer, which contains any number of 3D objects. Finally, the foreground 2D layer 
(called 2D Front Layer), which can also contain any number of 2D objects. The 
background and 3D layers will operate as they do in Viewpoint. The primary 
difference is the addition of the two special 2D layers, one drawn behind the 3D scene 
and the other drawn in front of it. Images in these layers will be drawn at their full 
pixel size.

Scene Display: An important UI window, which displays the current scene, and which 
is present in most of the user interface tabs. The scene display may be resized, and if it 
is smaller than the size of the actual project, then the scene will be scaled to fit within 
the window. The scene display will allow selective display of any of the four layers in 
the scene. Additionally, it contains controls to display a grid over the scene, 
temporarily mark up the scene with a virtual dry erase pen, set the render mode for the 
entire scene, or choose a modal in-scene editing tool.

Timer Reactor: Works just like a standard reactor, except that the user can set an 
amount of time to delay between the time that the reactor is triggered and the time 
when it takes effect.
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Appendix C: Keyboard Shortcuts

s you have read throughout this manual, pro-V Studio includes many keyboard 
shortcuts to make creating scenes faster and easier. This Appendix contains a 
comprehensive list of all keyboard shortcuts that pro-V Studio supports:

FILE SHORTCUTS

The following File shortcuts are available:

New: [CTRL]+[N]

Open: [CTRL]+[O]

Save: [CTRL]+[S]

Save as: [CTRL]+[SHIFT]+[S]

Import Single File: [CTRL]+[M]

Import Multiple Files: [CTRL]+[SHIFT]+[M]

Import Entire Directory: [CTRL]+[ALT]+[M]

Quit: [CTRL]+[Q]

EDIT SHORTCUTS

The following Edit shortcuts are available:

Undo: [CTRL]+[Z]

Redo: [CTRL]+[Y]

Cut: [CTRL]+[X]

Copy: [CTRL]+[C]

Paste: [CTRL]+[V]

Deselect All: [CTRL]+[D]

Delete: [DEL] or [BACKSPACE]

A
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OBJECT SHORTCUTS

The following Object shortcuts are available:

Object Attributes: [CTRL]+[I]

VIEW SHORTCUTS

The following View shortcuts are available:

Toggle Ground Plane: [CTRL]+[G]

Switch to Edit Cam: {CTRL]+[E]

Switch to Runtime Cam: [CTRL]+[R]

GENERAL SHORTCUTS

The following general shortcuts are available:

Runtime Camera Tool: [1]

Translate Tool: [2]

Push/Pull Tool: [3]

Translate XZ Tool: [4]

Translate Y Tool: [5]

Rotate Y Tool: [6]

Rotate X Tool: [7]

Rotate Z Tool: [8]

Tumble Tool: [9]

Scale Tool: [0]

Toggle Selection, Add Selection (Multiple Items): [CTRL]+left mouse click
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